Zabbix使用Omsa来监控Dell服务器的硬件状态
OMSA(Open Manage Server Administrator)是Dell主机的硬件检测和维护软件
OpenManage系统管理方案是戴尔公司基于自主研发力量开发的IT系统管理解决方案,通过与业内领先的系统管理解决方案供应商密切配合,在深入了解用户对系统管理需求的基础上,OpenManage系统管理方案可以全面解决系统管理人员最关心的系统部署、系统监控和系统变更三大系统管理问题。
1、安装dell的yum源
wget -O - http://linux.dell.com/repo/hardware/latest/bootstrap.cgi | bash
2、安装omsa
yum install -y srvadmin-base srvadmin-storageservices (推荐,只安装必要的组件) 或 yum install srvadmin-all
srvadmin-base:安装omsa基础组件,不包含webserver
srvadmin-storageservices:安装raid管理界面
3、创建软连接
ln -s /opt/dell/srvadmin/sbin/omreport /usr/bin/omreport
ln -s /opt/dell/srvadmin/sbin/omconfig /usr/bin/omconfig
4、启动cli模式omsa
service dataeng start 或者 /opt/dell/srvadmin/sbin/srvadmin-services.sh start
Ps: 如果启动报以下错误,需要安装openipmi服务 yum -y install OpenIPMI
报错信息:
[root@xxxxx/]# /opt/dell/srvadmin/sbin/srvadmin-services.sh start
StartingSystems Management Device Drivers:
Startingdell_rbu: Already started [ OK ]
Startingipmi driver: [FAILED]
StartingSystems Management Device Drivers:
Startingdell_rbu: Already started [ OK ]
Startingipmi driver: [FAILED]
DSM SAShared Services is already started
StartingDSM SA Connection Service: [ OK ]
DSM SAConnection Service stopped successfully.
5、zabbix客户端的配置
vim /usr/local/zabbix/etc/zabbix_agentd.conf.d/check_hardware.conf
UserParameter=hardware_cpu,omreport chassis processors|awk '/^Health/{if($NF=="Ok") {print 1} else {print 0}}'
UserParameter=hardware_cpu_model,awk -v hardware_cpu_crontol=`omreport chassis biossetup|awk '/CState/{if($NF=="Enabled") {print 0} else {print 1}}'` -v hardware_cpu_c1=`omreport chassis biossetup|awk '/C1[-|E]/{if($NF=="Enabled") {print 0} else{print 1}}'` 'BEGIN{if(hardware_cpu_crontol==0 && hardware_cpu_c1==0){print 0} else {print 1}}'
UserParameter=hardware_raid_health,awk -v vdisk_total_num=`omreport storage vdisk controller=0 | grep -c "^ID"` -v vdisk_ok_num=`omreport storage vdisk controller=0 |awk '/^Status/ {if($NF == "Ok") {print 1}else{print 0}}'` 'BEGIN{if(vdisk_total_num == vdisk_ok_num) {print 1} else {print 0}}'
UserParameter=hardware_memory_health,awk -v hardware_memory=`omreport chassis memory|awk '/^Health/{print $NF}'` 'BEGIN{if(hardware_memory=="Ok") {print 1} else {print 0}}'
UserParameter=hardware_temp,awk -v temperature_total_num=`omreport chassis temps | grep -c "^Index"` -v temperature_ok_num=`omreport chassis temps | awk '/^Status/{if($NF == "Ok") count=count+1}END{print count}'` 'BEGIN{if(temperature_total_num == temperature_ok_num) {print 1}else{print 0}}'
UserParameter=hardware_physics_health,awk -v pdisk_total_num=`omreport storage pdisk controller=0 | grep -c "^ID"` -v pdisk_ok_num=`omreport storage pdisk controller=0 | awk '/^Status/ {if($NF == "Ok") count=count+1}END{print count}'` 'BEGIN{if(pdisk_total_num == pdisk_ok_num) {print 1} else {print 0}}'
UserParameter=hardware_power_health,awk -v power_total_num=`omreport chassis pwrsupplies | grep -c "Index"` -v power_ok_num=`omreport chassis pwrsupplies | awk '/^Status/ {if($NF == "Ok") count=count+1}END{print count}'` 'BEGIN{if(power_total_num == power_ok_num){print 1}else{print 0}}'
UserParameter=hardware_battery,omreport chassis batteries|awk '/^Status/{if($NF=="Ok") {print 1} else {print 0}}'
UserParameter=hardware_nic_health,awk -v hardware_nic_number=`omreport chassis nics |grep -c "Interface Name"` -v hardware_nic=`omreport chassis nics |awk '/^Connection Status/{print$NF}'|wc -l` 'BEGIN{if(hardware_nic_number == hardware_nic) {print 1} else {print0}}'
UserParameter=hardware_fan_health,awk -v hardware_fan_number=`omreport chassis fans|grep -c "^Index"` -v hardware_fan=`omreport chassis fans|awk '/^Status/{if($NF=="Ok")count+=1}END{print count}'` 'BEGIN{if(hardware_fan_number == hardware_fan) {print 1} else {print 0}}'
6、重启zabbix_agentd服务
/etc/init.d/zabbix_agentd restart
7、测试获取数据:出现值为正常
[root@xxxxxx]# zabbix_get -s 127.0.0.1 -k hardware_memory_health
1
另,如需nagios监控,需要安装相关插件check_openmange
Zabbix使用Omsa来监控Dell服务器的硬件状态的更多相关文章
- Zabbix通过SNMPv2监控DELL服务器的硬件信息
(一)zabbix监控DELL服务器 (1)简述:监控DELL服务器硬件一般有两种途径:1.操作系统上安装OMSA,编写脚本调用omreport命令进行监控(需要在操作系统上安装比较麻烦):2.使用i ...
- zabbix通过ipmi传感器监控浪潮服务器的硬件信息
一:实验对象 操作系统版本:centos7.6 监控对象:通过服务器传感器获取到的所有在使用的硬件信息 zabbix版本: 4.0.14二:zabbix介绍 zabbix适合中小型企业.大型企业的用户 ...
- zabbix Server 4.0 监控TCP的12种状态
zabbix Server 4.0 监控TCP的12种状态 作者:尹正杰 版权声明:原创作品,谢绝转载!否则将追究法律责任. 大家对TCP三次握手比较熟悉了,都知道当发生DOSS攻击时,客户端发送 ...
- Zabbix监控Dell服务器相关硬件资源
一.安装dell服务器硬件监控工具OMSA 1.安装dell的yum源 [root@push-- ~]# wget -q -O - http://linux.dell.com/repo/hardwar ...
- Zabbix 3.2.6通过SNMP和iDRAC监控DELL服务器
https://www.cnblogs.com/saneri/p/7772641.html
- 转 Zabbix 3.2.6通过SNMP和iDRAC监控DELL服务器
https://www.cnblogs.com/saneri/p/7772641.html
- zabbix snmp 协议监控 dell iRDAC
转摘:http://blog.csdn.net/wanglei_storage/article/details/52789921 http://blog.csdn.net/wanglei_storag ...
- zabbix企业级监控dell硬件服务状态
监控dell服务的硬件状态,一般有两种方式 第一,在操作熊上安装OMSA,编写脚本调用omreport命令进行监控 第二.使用IDRAC,只需开启在IARAC上的SNMP,zabbix通过snmp进行 ...
- DELL服务器管理工具和RACADM介绍
DELL服务器管理工具和RACADM介绍 一.Dell服务器管理工具介绍 Dell对服务器(DELL PowerEdge)的管理主要提供了三种管理工具,分别是Dell Remote Access Co ...
随机推荐
- [UE4]把枪打飞addImpulse
一.武器如果没有开启模拟物理,会漂浮在空中 二.武器开启模拟物理,运行游戏的时候就会掉到地上了.之所以要加“Delay”延迟,是因为创建武器在先(没有持有人),持有武器动作在后,加上“delay”延迟 ...
- keepalived主备节点都配置vip,vip切换异常案例分析
原文地址:http://blog.51cto.com/13599730/2161622 参考地址:https://blog.csdn.net/qq_14940627/article/details/7 ...
- 超实用!9个目前流行的MATERIAL DESIGN前端框架
http://www.uisdc.com/material-design-frameworks-top-9 谷歌推出的Material Design风格已见有一些APP UI采用,视觉和交互体验都很棒 ...
- IDEA远程调试
问题: 通常在java打成可运行的Jar项目时,运行jar时调试很不方便,特别是要在linux上面执行jar包的情况.此时需要将这个项目打成Jar包(如果是maven项目,直接使用pa ...
- Google App Engine10年,支持更多你喜欢的编程语言
2008年4月7日google推出Google App Engine(GAE),时间过得真快,10年过去了,2010年3月google退出中国,一转眼也过去7年了.早在2009年的时候GAE就在中国内 ...
- DateTimepicker中的星期问题
开发机:win10 64+VS2013 客户机:win7 32bit 在项目中使用DateTimepicker,需要将时间获取到,然后转换为string,然后再转换为DateTime类型.开发机器上测 ...
- Failed to execute request because the App-Domain could not be created. Error: 0x80070002 系统找不到指定的文件。
360更新补丁后,网站就打不开aspx文件了,后来一查是framework2.0的KB2844285这个补丁引起的.把它卸载掉就ok了!
- 字符串格式化+json解析
java String.formate("xxx%sxxx", "yyy") python "xxx%sxxx" % "yyy& ...
- python ftp文件夹文件递归上传推送
- 432 4.3.2 STOREDRV.Deliver; recipient thread limit exceeded
最近几天Hub-Mailbox服务器时不时就CPU超过90%.在任务管理器里面看到edgetransport占用大量CPU.进入EMC的队列查看器,看到邮箱数据库堵塞,队列上万. 堵塞的邮件大多是收件 ...