filebeat端配置

#----------------------------- Kafka output --------------------------------
output.kafka:
# initial brokers for reading cluster metadata
hosts: ["10.88.128.88:9092"]
version: "0.8.2" topic: 'abc'
#partition.round_robin:
# reachable_only: false required_acks:
compression: none
#max_message_bytes:

报错如下:

// ::24.060269 log.go:: WARN producer/broker/ state change to [closing] because dial tcp: lookup test43 on 172.16.2.1:: no such host
// ::24.060361 log.go:: WARN producer/leader/rokid/ state change to [retrying-]
// ::24.060405 log.go:: WARN producer/leader/rokid/ abandoning broker
// ::24.060450 log.go:: WARN producer/broker/ shut down
x2017// ::24.160582 log.go:: WARN client/metadata fetching metadata for [rokid] from broker 10.88.128.88:
// ::24.164350 log.go:: WARN producer/broker/ starting up
// ::24.164388 log.go:: WARN producer/broker/ state change to [open] on rokid/
// ::24.164405 log.go:: WARN producer/leader/rokid/ selected broker
// ::24.164505 log.go:: WARN producer/leader/rokid/ state change to [flushing-]
// ::24.164516 log.go:: WARN producer/leader/rokid/ state change to [normal]
i2017// ::24.185439 log.go:: WARN Failed to connect to broker test43:: dial tcp: lookup test43 on 172.16.2.1:: no such host
// ::24.185488 log.go:: WARN producer/broker/ state change to [closing] because dial tcp: lookup test43 on 172.16.2.1:: no such host
// ::24.185534 log.go:: WARN producer/leader/rokid/ state change to [retrying-]
// ::24.185552 log.go:: WARN producer/leader/rokid/ abandoning broker
// ::24.185592 log.go:: WARN producer/broker/ shut down
// ::24.285740 log.go:: WARN client/metadata fetching metadata for [rokid] from broker 10.88.128.88:
// ::24.287170 log.go:: WARN producer/broker/ starting up
// ::24.287191 log.go:: WARN producer/broker/ state change to [open] on rokid/
// ::24.287205 log.go:: WARN producer/leader/rokid/ selected broker
// ::24.287300 log.go:: WARN producer/leader/rokid/ state change to [flushing-]
// ::24.287311 log.go:: WARN producer/leader/rokid/ state change to [normal]
// ::24.304521 log.go:: WARN Failed to connect to broker test43:: dial tcp: lookup test43 on 172.16.2.1:: no such host

上网查,filebeat解析的时候要解析到主机名,

所以绑定hosts如下

  10.88.128.88 test43

问题搞定

按照报错,filebeat应该是先以配置的IP获取hostname,然后按照hostname连接kafka,如果通过hostname找不到对方服务器,则报错,所以需要在filebeat机器上绑定对方机器的hosts,暂不理解filebeat为什么要这么做。

如果目标机器中hosts文件书写有误,也会报错(filebeat向kafka中传递数据的时候还会检查目标机器的hosts文件)

 

开始还以为kafka版本太新,修改为filebeat目前支持的稳定版0.8.2都出问题,反复查,绑定hosts问题搞定。

参考网址:http://www.iyunv.com/thread-350295-1-1.html

filebeat+kafka失败的更多相关文章

  1. Zookeeper、Kafka集群与Filebeat+Kafka+ELK架构

    Zookeeper.Kafka集群与Filebeat+Kafka+ELK架构 目录 Zookeeper.Kafka集群与Filebeat+Kafka+ELK架构 一.Zookeeper 1. Zook ...

  2. ELK+Filebeat+Kafka+ZooKeeper 构建海量日志分析平台(elk5.2+filebeat2.11)

    ELK+Filebeat+Kafka+ZooKeeper 构建海量日志分析平台 参考:http://www.tuicool.com/articles/R77fieA 我在做ELK日志平台开始之初选择为 ...

  3. ELK+Filebeat+Kafka+ZooKeeper 构建海量日志分析平台

    日志分析平台,架构图如下: 架构解读 : (整个架构从左到右,总共分为5层) 第一层.数据采集层 最左边的是业务服务器集群,上面安装了filebeat做日志采集,同时把采集的日志分别发送给两个logs ...

  4. 本机spark 消费kafka失败(无法连接)

    本机spark 消费kafka失败(无法连接) 终端也不报错 就特么不消费:  但是用console的consumer  却可以 经过各种改版本 ,测试配置,最后发现 只要注释掉 kafka 配置se ...

  5. 完整的ELK+filebeat+kafka笔记

    之前有写过elasticsearch集群和elk集群的博客, 都是基于docker的,使用docker-compose进行编排(K8S暂未掌握) 三台服务器搭建es集群:https://www.cnb ...

  6. 基于Filebeat+Kafka+Flink仿天猫双11实时交易额

    1. 写在前面 在大数据实时计算方向,天猫双11的实时交易额是最具权威性的,当然技术架构也是相当复杂的,不是本篇博客的简单实现,因为天猫双11的数据是多维度多系统,实时粒度更微小的.当然在技术的总体架 ...

  7. Filebeat+Kafka+Logstash+ElasticSearch+Kibana搭建完整版

    1. 了解各个组件的作用 Filebeat是一个日志文件托运工具,在你的服务器上安装客户端后,filebeat会监控日志目录或者指定的日志文件,追踪读取这些文件(追踪文件的变化,不停的读) Kafka ...

  8. Filebeat+Kafka+Logstash+ElasticSearch+Kibana 日志采集方案

    前言 Elastic Stack 提供 Beats 和 Logstash 套件来采集任何来源.任何格式的数据.其实Beats 和 Logstash的功能差不多,都能够与 Elasticsearch 产 ...

  9. filebeat kafka java日志收集

    filebeat.modules:- module: kafka log: enabled: truefilebeat.prospectors:- type: log enabled: true pa ...

随机推荐

  1. Tomcat与Servlet工作流程

    什么是Tomcat? Tomcatserver是一个免费的开放源码的Web 应用server,属于轻量级应用server. 什么是Servlet? Servlet是在server上执行的小程序.,说白 ...

  2. Informatica 常用组件Source Qualifier之四 SQL Query

    源限定符转换提供 SQL 查询选项以覆盖默认的查询.您可以输入您的源数据库支持的 SQL 语句.输入查询之前,请连接您要在映射中使用的所有输入和输出端口. 编辑 SQL 查询时,您可以生成并编辑默认查 ...

  3. Linux下Oracle 10g DataGuard配置(主从同步及切换)

    环境描述:主库: IP: 10.8.3.191 主机名:primaryORACLE_SID=afcORACLE_BASE=/u01/oracleORACLE_HOME=/u01/oracle/10g备 ...

  4. C#对.zip 存档读取和写入【转】

    Framework4.5支持 引用: System.IO.Compression.dll,System.IO.Compression.FileSystem.dll 提取压缩文件 ZipFile.Ext ...

  5. Nicescroll滚动条插件的用法

    Nicescroll滚动条插件是一个非常强大的基于jQuery的滚动条插件,不需要增加额外的css,几乎全浏览器兼容.ie6+,实现只需要一段代码,侵入性非常小,样式可完全自定义,支持触摸事件,可在触 ...

  6. Python mongoHelper模块

    #!/usr/bin/env python3 # -*- coding: utf-8 -*- ''' Defines a MongoOperator class and allows you to m ...

  7. DevExpressComponents-14.2.5 破解过程,正在编写,未完

    首先,批评一下cnblogs,在win10的环境下,需要加入到兼容视图列表方可正常编辑内容, 声明,本人在14.2.3 的源代码环境下,编译未通过,相关功能报错,索性选择破解,在此,只是学习测试使用, ...

  8. 14.2 事务的ACID属性

    14.2 事务的ACID属性正在更新内容.请稍后

  9. python发送邮件实例1

    文件形式的邮件 #!/usr/bin/env python3 #coding: utf-8 import smtplib from email.mime.text import MIMEText fr ...

  10. js Object.defineProperty 使用

    语法 Object.defineProperty(obj, prop, descriptor) 参数说明: obj:必需.目标对象 prop:必需.需定义或修改的属性的名字descriptor:必需. ...