问题:
[root@localhost ~]# systemctl status neutron-server
● neutron-server.service - OpenStack Neutron Server
Loaded: loaded (/usr/lib/systemd/system/neutron-server.service; disabled; vendor preset: disabled)
Active: inactive (dead)
[root@localhost ~]# systemctl restart neutron-server
Job for neutron-server.service failed because the control process exited with error code. See "systemctl status neutron-server.service" and "journalctl -xe" for details.
[root@localhost ~]# systemctl status neutron-server.service
● neutron-server.service - OpenStack Neutron Server
Loaded: loaded (/usr/lib/systemd/system/neutron-server.service; disabled; vendor preset: disabled)
Active: failed (Result: exit-code) since Wed 2016-09-21 02:24:59 EDT; 5s ago
Process: 3304 ExecStart=/usr/bin/neutron-server --config-file /usr/share/neutron/neutron-dist.conf --config-dir /usr/share/neutron/server --config-file /etc/neutron/neutron.conf --config-file /etc/neutron/plugin.ini --config-dir /etc/neutron/conf.d/common --config-dir /etc/neutron/conf.d/neutron-server --log-file /var/log/neutron/server.log (code=exited, status=1/FAILURE)
Main PID: 3304 (code=exited, status=1/FAILURE)
 
Sep 21 02:24:56 localhost systemd[1]: Starting OpenStack Neutron Server...
Sep 21 02:24:57 localhost neutron-server[3304]: Guru mediation now registers SIGUSR1 and SIGUSR2 by defau...rts.
Sep 21 02:24:58 localhost neutron-server[3304]: Option "verbose" from group "DEFAULT" is deprecated for r...ure.
Sep 21 02:24:58 localhost neutron-server[3304]: Option "notification_driver" from group "DEFAULT" is depr...ns".
Sep 21 02:24:59 localhost systemd[1]: neutron-server.service: main process exited, code=exited, status=1/FAILURE
Sep 21 02:24:59 localhost systemd[1]: Failed to start OpenStack Neutron Server.
Sep 21 02:24:59 localhost systemd[1]: Unit neutron-server.service entered failed state.
Sep 21 02:24:59 localhost systemd[1]: neutron-server.service failed.
 
 
1.分析:
logs看问题:
cd /var/log/neutron/
tail -f *.log
 
2016-09-21 02:36:52.236 5132 INFO neutron.common.config [-] Logging enabled!
2016-09-21 02:36:52.236 5132 INFO neutron.common.config [-] /usr/bin/neutron-server version 8.1.2
2016-09-21 02:36:52.237 5132 INFO neutron.common.config [-] Logging enabled!
2016-09-21 02:36:52.237 5132 INFO neutron.common.config [-] /usr/bin/neutron-server version 8.1.2
2016-09-21 02:36:52.252 5132 INFO neutron.manager [-] Loading core plugin: neutron.plugins.ml2.plugin.Ml2Plugin
2016-09-21 02:36:52.453 5132 INFO neutron.plugins.ml2.managers [-] Configured type driver names: ['flat', 'local']
2016-09-21 02:36:52.457 5132 INFO neutron.plugins.ml2.drivers.type_flat [-] Arbitrary flat physical_network names allowed
2016-09-21 02:36:52.458 5132 INFO neutron.plugins.ml2.drivers.type_local [-] ML2 LocalTypeDriver initialization complete
2016-09-21 02:36:52.458 5132 INFO neutron.plugins.ml2.managers [-] Loaded type driver names: ['flat', 'local']
2016-09-21 02:36:52.458 5132 INFO neutron.plugins.ml2.managers [-] Registered types: ['flat', 'local']
2016-09-21 02:36:52.459 5132 ERROR neutron.plugins.ml2.managers [-] No type driver for tenant network_type: vlan. Service terminated!
 
查看配置文件:
/etc/neutron/plugins/ml2/ml2_conf.ini
[ml2]
 
#
# From neutron.ml2
#
 
# List of network type driver entrypoints to be loaded from the
# neutron.ml2.type_drivers namespace. (list value)
#type_drivers = local,flat,vlan,gre,vxlan,geneve
type_drivers = flat,local
 
# Ordered list of network_types to allocate as tenant networks. The default
# value 'local' is useful for single-box testing but provides no connectivity
# between hosts. (list value)
#tenant_network_types = local
tenant_network_types = vlan
 
driver支持flat和local两种,但是tenant_network_type却使用vlan类型导致:
No type driver for tenant network_type: vlan. Service terminated!
 
解决方法:
type_drivers = flat,vlan,local
 
结果:
[root@localhost ml2]# systemctl restart neutron-server
[root@localhost ml2]# systemctl status neutron-server
● neutron-server.service - OpenStack Neutron Server
Loaded: loaded (/usr/lib/systemd/system/neutron-server.service; disabled; vendor preset: disabled)
Active: active (running) since Wed 2016-09-21 02:38:28 EDT; 6min ago
Main PID: 5384 (neutron-server)
CGroup: /system.slice/neutron-server.service
├─5384 /usr/bin/python2 /usr/bin/neutron-server --config-file /usr/share/neutron/neutron-dist.conf...
├─5400 /usr/bin/python2 /usr/bin/neutron-server --config-file /usr/share/neutron/neutron-dist.conf...
├─5401 /usr/bin/python2 /usr/bin/neutron-server --config-file /usr/share/neutron/neutron-dist.conf...
├─5402 /usr/bin/python2 /usr/bin/neutron-server --config-file /usr/share/neutron/neutron-dist.conf...
├─5403 /usr/bin/python2 /usr/bin/neutron-server --config-file /usr/share/neutron/neutron-dist.conf...
└─5404 /usr/bin/python2 /usr/bin/neutron-server --config-file /usr/share/neutron/neutron-dist.conf...
 
Sep 21 02:38:24 localhost systemd[1]: Starting OpenStack Neutron Server...
Sep 21 02:38:24 localhost neutron-server[5384]: Guru mediation now registers SIGUSR1 and SIGUSR2 by defau...rts.
Sep 21 02:38:26 localhost neutron-server[5384]: Option "verbose" from group "DEFAULT" is deprecated for r...ure.
Sep 21 02:38:26 localhost neutron-server[5384]: Option "notification_driver" from group "DEFAULT" is depr...ns".
Sep 21 02:38:28 localhost systemd[1]: Started OpenStack Neutron Server.
Hint: Some lines were ellipsized, use -l to show in full.
 

Fail to start neutron-server的更多相关文章

  1. 理解 Neutron Server 分层模型 - 每天5分钟玩转 OpenStack(69)

    本节开始讨论 Neutron 的各个服务组件,首先学习 Neutron Server . 上图是 Neutron Server 的分层结构,至上而下依次为: Core API对外提供管理 networ ...

  2. Neutron server的运行原理(未完待续)

    1.Neutron server首先是一个web server, 对于http和https协议的报文进行响应. 2.Neutron server进程里面包含了一个WSGI 应用程序,以及不同模块的pl ...

  3. 【打印机】无法连接 fail to connect to server cups 服务器错误 打印机

       打印机     fail to connect to server cups 服务器错误兆芯 打印机 连不上了####message可知 服务fail## systemd: cups.servi ...

  4. neutron full stack

    1.  通读一下 neutron的那个文档.  里面介绍了, db怎么隔离的, amqp怎么隔离的. 2.  记住文档中,那个full stack的图. 3.  走读代码      从TestOvsC ...

  5. 持续集成:CruiseControl.NET + VisualSVN.Server

    刚换了工作,有需要搭建一套持续集成的平台,做一下总结. 首先是我用到的工具: 上面缺少了Microsoft Fxcop,可以用来做代码校验,不过实际情况暂时还没有用到.主要的需求目前是,使用已发布的稳 ...

  6. 两张图总结 Neutron 架构 - 每天5分钟玩转 OpenStack(74)

    前面我们详细讨论了 Neutron 架构,包括 Neutron Server,Core 和 Service Agent.现在用两张图做个总结.先看第一张: 与 OpenStack 其他服务一样,Neu ...

  7. Neutron 如何支持多种 network provider - 每天5分钟玩转 OpenStack(70)

    Neutron 的架构是非常开放的,可以支持多种 network provider,只要遵循一定的设计原则和规范.本节我们将开始讨论这个主题. 先讨论一个简单的场景:在 Neutorn 中使用 lin ...

  8. Neutron 物理部署方案 - 每天5分钟玩转 OpenStack(68)

    前面我们讨论了 Neutron 的架构,本节讨论 Neutron 的物理部署方案:不同节点部署不同的 Neutron 服务组件. 方案1:控制节点 + 计算节点 在这个部署方案中,OpenStack ...

  9. Neutron 架构 - 每天5分钟玩转 OpenStack(67)

    前面我们讨论了 Neutron 的基本概念,今天我们开始分析 Neutron 的架构. Neutron 架构 与 OpenStack 的其他服务的设计思路一样,Neutron 也是采用分布式架构,由多 ...

  10. Neutron 理解 (1): Neutron 所实现的虚拟化网络 [How Netruon Virtualizes Network]

    学习 Neutron 系列文章: (1)Neutron 所实现的虚拟化网络 (2)Neutron OpenvSwitch + VLAN 虚拟网络 (3)Neutron OpenvSwitch + GR ...

随机推荐

  1. 基于netty的微服务架构

    基于netty的微服务架构 微服务一篇好文章 http://san-yun.iteye.com/blog/1693759 教程 http://udn.yyuap.com/doc/essential-n ...

  2. 静态局部变量(面向过程的static关键字)

    对于一个完整的程序,在内存中的分布情况如下图: 一般程序的由new产生的动态数据存放在堆区,函数内部的自动变量存放在栈区.自动变量一般会随函数的退出而释放空间,静态数据(即使是函数内部的静态局部变量) ...

  3. http://www.cnblogs.com/baizhanshi/p/5593431.html

    http://www.cnblogs.com/baizhanshi/p/5593431.html

  4. COGS738 [网络流24题] 数字梯形(最小费用最大流)

    题目这么说: 给定一个由n 行数字组成的数字梯形如下图所示.梯形的第一行有m 个数字.从梯形的顶部的m 个数字开始,在每个数字处可以沿左下或右下方向移动,形成一条从梯形的顶至底的路径.规则1:从梯形的 ...

  5. The 2015 China Collegiate Programming Contest K Game Rooms hdu 5550

    Game Rooms Time Limit: 4000/4000 MS (Java/Others)    Memory Limit: 65535/65535 K (Java/Others)Total ...

  6. BZOJ 1475 & 1324 && 建图最小割

    题意: 给一个矩阵,取其中一方格中的数,满足所有所取方格不相邻. SOL: 典型一个二分图,染色后不相邻的连边即可.跑个最大流,裸裸哒. Code: 代码没什么时间写了...并不是很想贴...都是贴板 ...

  7. 3801. String LD

    Description Stringld (left delete) is a function that gets a string and deletes its leftmost charact ...

  8. thinkphp 联表查询,排序

    $info =M('productbase'); $info= $info->alias('a')->field('a.id,cid,title,address,protype,time, ...

  9. vsfptd

    如果想通过vsftpd来在主机和虚拟机之间拿数据,可以通过这种方法: 在主机的资源管理器中输入:ftp://虚拟机里面Linux的IP(如192.168.2.112)/ 如果反过来,需要如下:ftp: ...

  10. Android studio 签名使用转

    来自http://www.cnblogs.com/xiwix/archive/2012/04/15/2447910.html 本文主要讲解Android应用程序签名相关的理论知识,包括:什么是签名.为 ...