---恢复内容开始---

arcsde10 安装在windows server2008 R2 X64 上。

从.gdb文件数据库 拷贝40W多的数据到ArcSDE ,然后postgresql就停止了,arcsde服务还没停止。真是够呛的。

到底是为什么啊?我先看看postgresql的日志吧:

pg的日志文件位于:C:\Program Files (x86)\PostgreSQL\8.3\data\pg_log

打开里现在最近的那个:这个是刚刚开启服务的

2013-08-05 17:33:45 HKT LOG:  database system was interrupted; last known up at 2013-08-05 17:27:08 HKT
2013-08-05 17:33:45 HKT LOG: database system was not properly shut down; automatic recovery in progress
2013-08-05 17:33:45 HKT LOG: loaded library "$libdir/plugins/plugin_debugger.dll"
2013-08-05 17:33:45 HKT FATAL: the database system is starting up
2013-08-05 17:33:45 HKT LOG: loaded library "$libdir/plugins/plugin_debugger.dll"
2013-08-05 17:33:45 HKT LOG: redo starts at 2/3D3C9FB8
2013-08-05 17:33:45 HKT FATAL: the database system is starting up
2013-08-05 17:33:45 HKT LOG: loaded library "$libdir/plugins/plugin_debugger.dll"
2013-08-05 17:33:45 HKT FATAL: the database system is starting up
2013-08-05 17:33:45 HKT LOG: loaded library "$libdir/plugins/plugin_debugger.dll"
2013-08-05 17:33:45 HKT FATAL: the database system is starting up
2013-08-05 17:33:45 HKT LOG: loaded library "$libdir/plugins/plugin_debugger.dll"
2013-08-05 17:33:45 HKT FATAL: the database system is starting up
2013-08-05 17:33:45 HKT LOG: loaded library "$libdir/plugins/plugin_debugger.dll"
2013-08-05 17:33:45 HKT FATAL: the database system is starting up
2013-08-05 17:33:45 HKT LOG: record with zero length at 2/3DFBDFA0
2013-08-05 17:33:45 HKT LOG: redo done at 2/3DFBDF70
2013-08-05 17:33:45 HKT LOG: last completed transaction was at log time 2013-08-05 17:31:09.121+08
2013-08-05 17:33:45 HKT LOG: loaded library "$libdir/plugins/plugin_debugger.dll"
2013-08-05 17:33:45 HKT FATAL: the database system is starting up
2013-08-05 17:33:46 HKT LOG: loaded library "$libdir/plugins/plugin_debugger.dll"
2013-08-05 17:33:46 HKT FATAL: the database system is starting up
2013-08-05 17:33:46 HKT LOG: loaded library "$libdir/plugins/plugin_debugger.dll"
2013-08-05 17:33:46 HKT FATAL: the database system is starting up
2013-08-05 17:33:46 HKT LOG: loaded library "$libdir/plugins/plugin_debugger.dll"
2013-08-05 17:33:46 HKT FATAL: the database system is starting up
2013-08-05 17:33:46 HKT LOG: database system is ready to accept connections
2013-08-05 17:33:46 HKT LOG: loaded library "$libdir/plugins/plugin_debugger.dll"
2013-08-05 17:33:46 HKT FATAL: the database system is starting up
2013-08-05 17:33:46 HKT LOG: autovacuum launcher started
2013-08-05 17:33:46 HKT LOG: loaded library "$libdir/plugins/plugin_debugger.dll"
2013-08-05 17:33:46 HKT ERROR: SAVEPOINT can only be used in transaction blocks
2013-08-05 17:33:46 HKT STATEMENT: SAVEPOINT sp_sde_1375695226_0_183466
2013-08-05 17:33:46 HKT NOTICE: there is no transaction in progress
2013-08-05 17:33:46 HKT LOG: loaded library "$libdir/plugins/plugin_debugger.dll"
2013-08-05 17:33:46 HKT ERROR: SAVEPOINT can only be used in transaction blocks
2013-08-05 17:33:46 HKT STATEMENT: SAVEPOINT sp_sde_1375695226_0_183469
2013-08-05 17:33:46 HKT NOTICE: there is no transaction in progress
2013-08-05 17:33:46 HKT LOG: loaded library "$libdir/plugins/plugin_debugger.dll"
2013-08-05 17:33:47 HKT ERROR: relation "sde.sch_dataset" does not exist
2013-08-05 17:33:47 HKT STATEMENT: SELECT 1 FROM sde.sde.SCH_DATASET WHERE 1 = 0
2013-08-05 17:34:01 HKT LOG: loaded library "$libdir/plugins/plugin_debugger.dll"
2013-08-05 17:36:29 HKT ERROR: relation "sde.sch_dataset" does not exist
2013-08-05 17:36:29 HKT STATEMENT: SELECT 1 FROM sde.sde.SCH_DATASET WHERE 1 = 0

刚开启服务,里面就有 ERROR的错误,这不是FATAL错误,就没关系。

看看出现FATAL错误的这个日志:

2013-08-05 17:30:04 HKT ERROR:  relation "sde.sde_logfiles" does not exist
2013-08-05 17:30:04 HKT STATEMENT: SELECT logfile_name, logfile_id, logfile_data_id, registration_id, flags, session_tag, column_name, logfile_data_db, logfile_data_owner, logfile_data_table FROM sde.sde.sde_logfiles WHERE flags%2 = 0
2013-08-05 17:30:13 HKT ERROR: relation "sde.pnamehenan_none" does not exist
2013-08-05 17:30:13 HKT STATEMENT: select sde.sde.pnamehenan_none.* from sde.sde.PNamehenan_none
2013-08-05 17:30:13 HKT ERROR: index "r178_sde_rowid_uk" does not exist
2013-08-05 17:30:13 HKT STATEMENT: drop index sde.r178_sde_rowid_uk
2013-08-05 17:30:13 HKT ERROR: function sde.sde.i178_get_ids(integer, integer) does not exist at character 8
2013-08-05 17:30:13 HKT HINT: No function matches the given name and argument types. You might need to add explicit type casts.
2013-08-05 17:30:13 HKT STATEMENT: SELECT sde.sde.i178_get_ids ($1,$2)
2013-08-05 17:30:13 HKT NOTICE: CREATE TABLE / PRIMARY KEY will create implicit index "i178_pk" for table "i178"
2013-08-05 17:30:13 HKT ERROR: column "shape" does not exist at character 52
2013-08-05 17:30:13 HKT STATEMENT: SELECT COUNT(*) FROM sde.sde.pnamehenan_none WHERE Shape IS NOT NULL
2013-08-05 17:31:09 HKT LOG: server process (PID 5688) was terminated by exception 0xC0000005
2013-08-05 17:31:09 HKT HINT: See C include file "ntstatus.h" for a description of the hexadecimal value.
2013-08-05 17:31:09 HKT LOG: terminating any other active server processes
2013-08-05 17:31:09 HKT WARNING: terminating connection because of crash of another server process
2013-08-05 17:31:09 HKT DETAIL: The postmaster has commanded this server process to roll back the current transaction and exit, because another server process exited abnormally and possibly corrupted shared memory.
2013-08-05 17:31:09 HKT HINT: In a moment you should be able to reconnect to the database and repeat your command.
2013-08-05 17:31:09 HKT WARNING: terminating connection because of crash of another server process
2013-08-05 17:31:09 HKT DETAIL: The postmaster has commanded this server process to roll back the current transaction and exit, because another server process exited abnormally and possibly corrupted shared memory.
2013-08-05 17:31:09 HKT HINT: In a moment you should be able to reconnect to the database and repeat your command.
2013-08-05 17:31:09 HKT WARNING: terminating connection because of crash of another server process
2013-08-05 17:31:09 HKT DETAIL: The postmaster has commanded this server process to roll back the current transaction and exit, because another server process exited abnormally and possibly corrupted shared memory.
2013-08-05 17:31:09 HKT HINT: In a moment you should be able to reconnect to the database and repeat your command.
2013-08-05 17:31:09 HKT WARNING: terminating connection because of crash of another server process
2013-08-05 17:31:09 HKT DETAIL: The postmaster has commanded this server process to roll back the current transaction and exit, because another server process exited abnormally and possibly corrupted shared memory.
2013-08-05 17:31:09 HKT HINT: In a moment you should be able to reconnect to the database and repeat your command.
2013-08-05 17:31:09 HKT WARNING: terminating connection because of crash of another server process
2013-08-05 17:31:09 HKT DETAIL: The postmaster has commanded this server process to roll back the current transaction and exit, because another server process exited abnormally and possibly corrupted shared memory.
2013-08-05 17:31:09 HKT HINT: In a moment you should be able to reconnect to the database and repeat your command.
2013-08-05 17:31:09 HKT WARNING: terminating connection because of crash of another server process
2013-08-05 17:31:09 HKT DETAIL: The postmaster has commanded this server process to roll back the current transaction and exit, because another server process exited abnormally and possibly corrupted shared memory.
2013-08-05 17:31:09 HKT HINT: In a moment you should be able to reconnect to the database and repeat your command.
2013-08-05 17:31:09 HKT WARNING: terminating connection because of crash of another server process
2013-08-05 17:31:09 HKT DETAIL: The postmaster has commanded this server process to roll back the current transaction and exit, because another server process exited abnormally and possibly corrupted shared memory.
2013-08-05 17:31:09 HKT HINT: In a moment you should be able to reconnect to the database and repeat your command.
2013-08-05 17:31:09 HKT LOG: loaded library "$libdir/plugins/plugin_debugger.dll"
2013-08-05 17:31:09 HKT FATAL: the database system is in recovery mode
2013-08-05 17:31:09 HKT LOG: all server processes terminated; reinitializing
2013-08-05 17:31:19 HKT FATAL: pre-existing shared memory block is still in use
2013-08-05 17:31:19 HKT HINT: Check if there are any old server processes still running, and terminate them.

在ntstatus.h中,有一行:

#define STATUS_ACCESS_VIOLATION          ((NTSTATUS)0xC0000005L)    // winnt

就是这个错误了。尼玛,查了一下 这就是段错误(segmentation fault)啊。PostGreSQL居然段错误停止了。。不过我安装的arcsde10 for windows自带的pg,8.3不是最新版本的PostGreSQL。可能新版本解决了bug呢。8.x最新的是8.4 我试试?应该可以安全升级才是的。9.x的估计与8.x的相差很大。

---恢复内容结束---

arcsde10 安装在windows server2008 R2 X64 上。

从.gdb文件数据库 拷贝40W多的数据到ArcSDE ,然后postgresql就停止了,arcsde服务还没停止。真是够呛的。

到底是为什么啊?我先看看postgresql的日志吧:

pg的日志文件位于:C:\Program Files (x86)\PostgreSQL\8.3\data\pg_log

打开里现在最近的那个:这个是刚刚开启服务的

2013-08-05 17:33:45 HKT LOG:  database system was interrupted; last known up at 2013-08-05 17:27:08 HKT
2013-08-05 17:33:45 HKT LOG: database system was not properly shut down; automatic recovery in progress
2013-08-05 17:33:45 HKT LOG: loaded library "$libdir/plugins/plugin_debugger.dll"
2013-08-05 17:33:45 HKT FATAL: the database system is starting up
2013-08-05 17:33:45 HKT LOG: loaded library "$libdir/plugins/plugin_debugger.dll"
2013-08-05 17:33:45 HKT LOG: redo starts at 2/3D3C9FB8
2013-08-05 17:33:45 HKT FATAL: the database system is starting up
2013-08-05 17:33:45 HKT LOG: loaded library "$libdir/plugins/plugin_debugger.dll"
2013-08-05 17:33:45 HKT FATAL: the database system is starting up
2013-08-05 17:33:45 HKT LOG: loaded library "$libdir/plugins/plugin_debugger.dll"
2013-08-05 17:33:45 HKT FATAL: the database system is starting up
2013-08-05 17:33:45 HKT LOG: loaded library "$libdir/plugins/plugin_debugger.dll"
2013-08-05 17:33:45 HKT FATAL: the database system is starting up
2013-08-05 17:33:45 HKT LOG: loaded library "$libdir/plugins/plugin_debugger.dll"
2013-08-05 17:33:45 HKT FATAL: the database system is starting up
2013-08-05 17:33:45 HKT LOG: record with zero length at 2/3DFBDFA0
2013-08-05 17:33:45 HKT LOG: redo done at 2/3DFBDF70
2013-08-05 17:33:45 HKT LOG: last completed transaction was at log time 2013-08-05 17:31:09.121+08
2013-08-05 17:33:45 HKT LOG: loaded library "$libdir/plugins/plugin_debugger.dll"
2013-08-05 17:33:45 HKT FATAL: the database system is starting up
2013-08-05 17:33:46 HKT LOG: loaded library "$libdir/plugins/plugin_debugger.dll"
2013-08-05 17:33:46 HKT FATAL: the database system is starting up
2013-08-05 17:33:46 HKT LOG: loaded library "$libdir/plugins/plugin_debugger.dll"
2013-08-05 17:33:46 HKT FATAL: the database system is starting up
2013-08-05 17:33:46 HKT LOG: loaded library "$libdir/plugins/plugin_debugger.dll"
2013-08-05 17:33:46 HKT FATAL: the database system is starting up
2013-08-05 17:33:46 HKT LOG: database system is ready to accept connections
2013-08-05 17:33:46 HKT LOG: loaded library "$libdir/plugins/plugin_debugger.dll"
2013-08-05 17:33:46 HKT FATAL: the database system is starting up
2013-08-05 17:33:46 HKT LOG: autovacuum launcher started
2013-08-05 17:33:46 HKT LOG: loaded library "$libdir/plugins/plugin_debugger.dll"
2013-08-05 17:33:46 HKT ERROR: SAVEPOINT can only be used in transaction blocks
2013-08-05 17:33:46 HKT STATEMENT: SAVEPOINT sp_sde_1375695226_0_183466
2013-08-05 17:33:46 HKT NOTICE: there is no transaction in progress
2013-08-05 17:33:46 HKT LOG: loaded library "$libdir/plugins/plugin_debugger.dll"
2013-08-05 17:33:46 HKT ERROR: SAVEPOINT can only be used in transaction blocks
2013-08-05 17:33:46 HKT STATEMENT: SAVEPOINT sp_sde_1375695226_0_183469
2013-08-05 17:33:46 HKT NOTICE: there is no transaction in progress
2013-08-05 17:33:46 HKT LOG: loaded library "$libdir/plugins/plugin_debugger.dll"
2013-08-05 17:33:47 HKT ERROR: relation "sde.sch_dataset" does not exist
2013-08-05 17:33:47 HKT STATEMENT: SELECT 1 FROM sde.sde.SCH_DATASET WHERE 1 = 0
2013-08-05 17:34:01 HKT LOG: loaded library "$libdir/plugins/plugin_debugger.dll"
2013-08-05 17:36:29 HKT ERROR: relation "sde.sch_dataset" does not exist
2013-08-05 17:36:29 HKT STATEMENT: SELECT 1 FROM sde.sde.SCH_DATASET WHERE 1 = 0

刚开启服务,里面就有 ERROR的错误,这不是FATAL错误,就没关系。

看看出现FATAL错误的这个日志:

2013-08-05 17:30:04 HKT ERROR:  relation "sde.sde_logfiles" does not exist
2013-08-05 17:30:04 HKT STATEMENT: SELECT logfile_name, logfile_id, logfile_data_id, registration_id, flags, session_tag, column_name, logfile_data_db, logfile_data_owner, logfile_data_table FROM sde.sde.sde_logfiles WHERE flags%2 = 0
2013-08-05 17:30:13 HKT ERROR: relation "sde.pnamehenan_none" does not exist
2013-08-05 17:30:13 HKT STATEMENT: select sde.sde.pnamehenan_none.* from sde.sde.PNamehenan_none
2013-08-05 17:30:13 HKT ERROR: index "r178_sde_rowid_uk" does not exist
2013-08-05 17:30:13 HKT STATEMENT: drop index sde.r178_sde_rowid_uk
2013-08-05 17:30:13 HKT ERROR: function sde.sde.i178_get_ids(integer, integer) does not exist at character 8
2013-08-05 17:30:13 HKT HINT: No function matches the given name and argument types. You might need to add explicit type casts.
2013-08-05 17:30:13 HKT STATEMENT: SELECT sde.sde.i178_get_ids ($1,$2)
2013-08-05 17:30:13 HKT NOTICE: CREATE TABLE / PRIMARY KEY will create implicit index "i178_pk" for table "i178"
2013-08-05 17:30:13 HKT ERROR: column "shape" does not exist at character 52
2013-08-05 17:30:13 HKT STATEMENT: SELECT COUNT(*) FROM sde.sde.pnamehenan_none WHERE Shape IS NOT NULL
2013-08-05 17:31:09 HKT LOG: server process (PID 5688) was terminated by exception 0xC0000005
2013-08-05 17:31:09 HKT HINT: See C include file "ntstatus.h" for a description of the hexadecimal value.
2013-08-05 17:31:09 HKT LOG: terminating any other active server processes
2013-08-05 17:31:09 HKT WARNING: terminating connection because of crash of another server process
2013-08-05 17:31:09 HKT DETAIL: The postmaster has commanded this server process to roll back the current transaction and exit, because another server process exited abnormally and possibly corrupted shared memory.
2013-08-05 17:31:09 HKT HINT: In a moment you should be able to reconnect to the database and repeat your command.
2013-08-05 17:31:09 HKT WARNING: terminating connection because of crash of another server process
2013-08-05 17:31:09 HKT DETAIL: The postmaster has commanded this server process to roll back the current transaction and exit, because another server process exited abnormally and possibly corrupted shared memory.
2013-08-05 17:31:09 HKT HINT: In a moment you should be able to reconnect to the database and repeat your command.
2013-08-05 17:31:09 HKT WARNING: terminating connection because of crash of another server process
2013-08-05 17:31:09 HKT DETAIL: The postmaster has commanded this server process to roll back the current transaction and exit, because another server process exited abnormally and possibly corrupted shared memory.
2013-08-05 17:31:09 HKT HINT: In a moment you should be able to reconnect to the database and repeat your command.
2013-08-05 17:31:09 HKT WARNING: terminating connection because of crash of another server process
2013-08-05 17:31:09 HKT DETAIL: The postmaster has commanded this server process to roll back the current transaction and exit, because another server process exited abnormally and possibly corrupted shared memory.
2013-08-05 17:31:09 HKT HINT: In a moment you should be able to reconnect to the database and repeat your command.
2013-08-05 17:31:09 HKT WARNING: terminating connection because of crash of another server process
2013-08-05 17:31:09 HKT DETAIL: The postmaster has commanded this server process to roll back the current transaction and exit, because another server process exited abnormally and possibly corrupted shared memory.
2013-08-05 17:31:09 HKT HINT: In a moment you should be able to reconnect to the database and repeat your command.
2013-08-05 17:31:09 HKT WARNING: terminating connection because of crash of another server process
2013-08-05 17:31:09 HKT DETAIL: The postmaster has commanded this server process to roll back the current transaction and exit, because another server process exited abnormally and possibly corrupted shared memory.
2013-08-05 17:31:09 HKT HINT: In a moment you should be able to reconnect to the database and repeat your command.
2013-08-05 17:31:09 HKT WARNING: terminating connection because of crash of another server process
2013-08-05 17:31:09 HKT DETAIL: The postmaster has commanded this server process to roll back the current transaction and exit, because another server process exited abnormally and possibly corrupted shared memory.
2013-08-05 17:31:09 HKT HINT: In a moment you should be able to reconnect to the database and repeat your command.
2013-08-05 17:31:09 HKT LOG: loaded library "$libdir/plugins/plugin_debugger.dll"
2013-08-05 17:31:09 HKT FATAL: the database system is in recovery mode
2013-08-05 17:31:09 HKT LOG: all server processes terminated; reinitializing
2013-08-05 17:31:19 HKT FATAL: pre-existing shared memory block is still in use
2013-08-05 17:31:19 HKT HINT: Check if there are any old server processes still running, and terminate them.

在ntstatus.h中,有一行:

#define STATUS_ACCESS_VIOLATION          ((NTSTATUS)0xC0000005L)    // winnt

就是这个错误了。尼玛,查了一下 这就是段错误(segmentation fault)啊。PostGreSQL居然段错误停止了。。不过我安装的arcsde10 for windows自带的pg,8.3不是最新版本的PostGreSQL。可能新版本解决了bug呢。8.x最新的是8.4 我试试?应该可以安全升级才是的。9.x的估计与8.x的相差很大。

------------------------------------------------------

安装好了 ArcSDE SP1 补丁后,这个问题算是解决了,顺便把 SP2-SP5 都安装了。要顺序安装,SP5 不包括SP1 的内容的。

SP补丁下载地址:

http://support.esrichina.com.cn/support/download/ServicePack/

http://support.esri.com/en/downloads/patches-servicepacks/list/productid/66

其中ArcSDE SP1-5 所有补丁 解决的问题列表有:

http://gisupdates.esri.com/10sp5/ArcSDE/ArcSDE10sp5-issues.htm

arcsde10 postgresql8.3 服务停止问题的更多相关文章

  1. C#操作注册服务卸载服务启动服务停止服务.. .

    using Microsoft.Win32; using System; using System.Collections; using System.Collections.Generic; usi ...

  2. 监控windows服务,当服务停止后自动重启服务

    近期花时间研究了一下windows和linux下某服务停了后自动重启的功能,在网上收集了些资料,并经过测试,在此整理一下.这里介绍的是windows服务的监控,是通过批处理来实现的.本例是监控wind ...

  3. 启动和启动和停止MySQL服务停止MySQL服务

    1.  启动MySQL服务 启动MySQL服务的命令为: /etc/init.d/mysqld start 命令执行后如图7-5所示,表示启动MySQL服务成功.   (点击查看大图)图7-5  启动 ...

  4. Nginx+Keepalived主备切换(包含nginx服务停止)

    原文地址:http://blog.sina.com.cn/s/blog_79ac6aa80101bmed.html Nginx+Keepalived主备切换(包含nginx服务停止) 环境: VM中4 ...

  5. 子线程导致 Windows 服务停止的情况(Topshelf 结合 Quartz.NET)

    Ø  前言 本文主要记录子线程导致 Topshelf 和 Quartz.NET 的 Windows 服务停止的现象,以及使用几种常用子线程的注意事项.因为我们有时可能需要开启多个线程执行复杂的逻辑,如 ...

  6. mysql服务停止

    mysql链接方式分为 tcp链接和 sock链接,   你刚才看到服务停止了还能链接 那种会员是 sock的会话模式   所以需要把所有链接mysql的进程结束掉,才能启动起来的   windows ...

  7. 因Window服务器自动更新并重启导致WebSphere服务停止服务故障一例

    最近公司购买了两台Windows Server 2008 R2服务器用于提供提供Web服务,A机器安装了IHS+DM+WAS8.5集群,B机器安装了Oracle11gR2用于数据存储,两台机器均可连接 ...

  8. Redis服务停止报错解决方案[NOAUTH Authentication required]

    Redis服务器设置密码后,使用service redis stop 会出现以下信息: service redis stop Stopping ... OK (error) NOAUTH Authen ...

  9. C#管理服务停止启动

    由于机器性能问题,把许多服务关闭了,需要用的时候再开启,这样每次都打开服务管理或cmd命令比较麻烦.就自己写了工具显示在桌面上; 声明:ServiceController myController = ...

随机推荐

  1. jenkins 整合maven,svn(配置钩子程序实现提交代码自动构建),tomcat实现热部署(windows+linux分别实现)

    springboot : https://blog.csdn.net/zjh_746140129/article/details/80904876 1 准备工作: (1)运行jenkins的tomca ...

  2. css实现自适应正方形

    这里介绍7种方法,仅供参考. 1.vm单位 <div class="square-shape">这是一个可以自适应的正方形,此法适用于移动端web页面.</div ...

  3. Tecnomatix Process Designer & Process Simulate用法

    1. 删除项目 在AdminConsole->Project Action中,点击Delete project即可.

  4. ehcache 在web项目中使用

    无论是servlet web项目还是spring web项目,使用ehcache添加3个jre包以及配置 ehcache.xml即可.

  5. 添加第一个控制器(Controllers)

    在MVC体系架构中,输入请求是由控制器Controller来处理的(负责处理浏览器请求,并作出响应).在ASP.NET MVC中Controller本身是一个类(Class)通常继承于System.W ...

  6. BZOJ.3932.[CQOI2015]任务查询系统(主席树 差分)

    题目链接 对于这一区间的操作,我们可以想到差分+前缀和(感觉也没什么别的了..). 同时对于本题我们能想到主席树,而主席树正是利用前一个节点建树的. 所以离散化.按时间排序,把操作拆成单点加和减即可. ...

  7. VMware vmdk文件打开方法

    打开虚拟机设置——硬盘——映射,把虚拟机磁盘文件vmdk映射到系统中即可!

  8. mysql函数的使用

    最近总感觉sql语句不对劲,所以就看了一些官方文档发现了一些以前没有注意的函数:感觉在查询的时候可以用得上,毕竟是内置函数,用起来效率应该会好一些的: FIND_IN_SET(str,strlist) ...

  9. GEF最简单的入门-helloword(1)

    最近做插件项目.主要负责GEF这块. 好吧.资料真少的可以.特别是入门.都是一大堆一大堆的.网上最火的八进制的文章但对于我这种菜鸟级别看了还是一头雾水.各种资料折腾了半天.终于折腾出一个真正的入门例子 ...

  10. Modbus TCP和Modbus Rtu协议的区别 转

    http://blog.csdn.net/educast/article/details/9177679   Modbus rtu和Modbus tcp两个协议的本质都是MODBUS协议,都是靠MOD ...