转载 http://www.dotblogs.com.tw/dorlis.tsao/archive/2011/01/17/20860.aspx

在自己Windows 7 professional的電腦上,把 Reporting Services組態管理員啟用後點選報表管理員的URL,會發生如下圖的錯誤

相同地,Web服務URL也是無法正常啟用,訊息也是權限不足無法執行

乍看之下,似乎是UAC(使用者帳戶控制)影響,筆者試過把UAC等級關閉,但仍然會有權限不足的問題

(UAC:從Vista以後OS有的功能,預設會在你開啟程式、設定系統功能時先跳出來,問使用者是否授權這個存取動作,然後才能繼續執行)

後來Derrick建議我們在IE的選項,將網站加到「信任的網站」,並將安全性等級設為「低」之後,再到「開始」→「所有程式」的「Internet Explorer」點選右鍵,以「系統管理員身份執行」瀏覽報表管理員URL即可。(前兩天筆者在試時是不需要以系統管理員身份執行也可以,真怪)

若沒有將網站設為低安全等級時,瀏覽報表管理員URL會跳出輸入帳號密碼,但登入後仍然會有權限不足的回應

(提醒一下,習慣OS登入沒有設密碼的人,在Windows 7跳出這個畫面是沒法接受不打或空白密碼)

如果不想老是去點選IE以「系統管理員身份執行」瀏覽報表管理員,可以連進報表管理員後,點選「資料夾設定」

點選「新增角色指派」後,將users指派「內容管理員」的角色,點選「確認」,之後IE直接瀏覽該頁面即可

(也可將IE設定「信任的網站」的安全性恢復為預設值)

由於2008的Reporting Services不像2005一樣,已完全脫離IIS的虛擬目錄來存取Web服務,是透過SQL Server CLR以及OS內建的http.sys元件來處理服務。如果報表需要作匿名存取(Anonymous),但不想每一台瀏覽的電腦都作這樣的設定,可能就要寫Security Extension的程式碼來作驗證與授權了。(2008預設是以Windows 整合驗證, 2005的驗證方式可以在IIS上面去作設定)

詳請可參考百敬老師的文章http://byronhu.wordpress.com/2010/05/30/sql-2008-reporting-%e5%8c%bf%e5%90%8d%e5%ad%98%e5%8f%96/

[小技巧]設定Reporting Services 2008 發生報表管理員權限不足的更多相关文章

  1. 免安裝、免設定的 Hadoop 開發環境 - cloudera 的 QuickStart VM

    cloudera 的 QuickStart VM,為一種免安裝.免設定 Linux 及 Hadoop,已幫你建好 CDH 5.x.Hadoop.Eclipse 的一個虛擬機環境.下載後解壓縮,可直接以 ...

  2. 【Reporting Services 报表开发】— 数据表的使用

    一.打开 SQL Server Business Intelligence Development Studio,新建项目—>商业智能项目—> 报表服务器项目,命名为CH3 二.在报表文件 ...

  3. 【Reporting Services 报表开发】— 数据表存储格式修改

    文本框 Format属性:日期:输入d(表示简易日期).2007/5/1 0:00:00   输入d之后 变成 2007/5/1 金额:输入C0(表示货币),系统会根据设定值产生对应的货币符号,至于0 ...

  4. 【小技巧】限制windows server 2008的最大用户登录数

    把云服务器单纯当作自己一个云端主机的人大有人在.本人就是其中一位. 由于windows server 2008的会话保持机制,导致你关闭掉当前远程桌面连接,并从另外一台电脑上开启远程连接之后,另外一台 ...

  5. Display Database Image using MS SQL Server 2008 Reporting Services

    原文 Display Database Image using MS SQL Server 2008 Reporting Services With the new release of MS SQL ...

  6. (转载)SQL Reporting Services (Expression Examples)

    https://msdn.microsoft.com/en-us/library/ms157328(v=SQL.100).aspx Expressions are used frequently in ...

  7. [转]Creating Mailing Labels in SQL Server Reporting Services (rdlc 数据1页 2竖排 显示)

    本文转自:http://blogs.wrox.com/article/creating-mailing-labels-in-sql-server-reporting-services/ Most wo ...

  8. Reporting Services 配置工具

    使用 Reporting Services 配置管理器可配置 Reporting Services 安装.如果使用“仅文件”选项安装报表服务器,则必须使用此工具来配置服务器,才能使用该服务器.如果使用 ...

  9. sharepoint 2013 reporting services 远程server返回错误: (500) 内部server错误。

    在sharepoint 2013部署reporting services过程中,点击管理中心,server上的服务.系统配置.提示了一个错误: 远程server返回错误: (500) 内部server ...

随机推荐

  1. 【Struts】服务器文件的上传和下载

    Java中获得文件的文件后缀 import java.io.*; public class FileTest{ public static void main(String args[]){ File ...

  2. 【转】Git 少用 Pull 多用 Fetch 和 Merge

    原文网址:http://www.cnblogs.com/flying_bat/p/3408634.html 本文有点长而且有点乱,但就像Mark Twain Blaise Pascal的笑话里说的那样 ...

  3. TCP/IP详解学习笔记(8)-DNS域名系统

    前面已经提到了访问一台机器要靠IP地址和MAC地址,其中,MAC地址可以通过ARP协议得到,所以这对用户是透明的,但是IP地址就不行,无论如何用户都需要用一个指定的IP来访问一台计算机,而IP地址又非 ...

  4. JavaEE参考示例 SpringSide 4.0 GA版杀青

    SpringSide是以Spring Framework为核心的,Pragmatic风格的JavaEE应用参考示例,是JavaEE世界中的主流技术选型,较佳实践的总结与演示. 经过漫长的7个月和6个R ...

  5. HDU 2056 Rectangles

    Rectangles Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)Total ...

  6. redis错误汇总

    1.redis因为内存不够而启动失败 Microsoft Open Tech group 在 GitHub上开发了一个REDIS Win64的版本,项目地址是:https://github.com/M ...

  7. Devexpress GridControl z

    http://minmin86121.blog.163.com/blog/static/4968115720144194923578/ 1 AllowNullInput=False; --Devexp ...

  8. VS2010生成Qt程序图标修改方法

    转自:http://blog.csdn.net/simeone18/article/details/7344547 1.准备ico文件,nuistcard.ico 2.在nuistcard工程目录,建 ...

  9. 【C++对象模型】构造函数语意学之一 默认构造函数

    默认构造函数,如果程序员没有为类定义构造函数,那么编译器会在[需要的时候]为类合成一个构造函数,而[需要的时候]分为程序员需要的时候和编译器需要的时候,程序员需要的时候应该由程序员来做工作,编译器需要 ...

  10. Tkinter教程之Grid篇

    本文转载自:http://blog.csdn.net/jcodeer/article/details/1813196 '''Tkinter教程之Grid篇'''# Tkinter参考中最推荐使用的一个 ...