因Istio官网自带的bookinfo服务依赖关系较少,因此想部署sock-shop进行进一步的实验。

kubectl apply -f <(istioctl kube-inject -f sockshop-demo.yaml)

  在部署完以后,rabbitmq一直处于CrashLoopBackOff和Error的状态

  查看状态并没有特别明显的报错

root@R740--:~# kubectl describe pod -n sock-shop rabbitmq-759fbc775f-s575d
Name: rabbitmq-759fbc775f-s575d
Namespace: sock-shop
Node: 192.168.199.191/192.168.199.191
Start Time: Sun, Sep :: +
Labels: name=rabbitmq
pod-template-hash=
Annotations: sidecar.istio.io/status={"version":"55ca84b79cb5036ec3e54a3aed83cd77973cdcbed6bf653ff7b4f82659d68b1e","initContainers":["istio-init"],"containers":["istio-proxy"],"volumes":["istio-envoy","istio-certs...
Status: Running
IP: 172.20.5.51
Controlled By: ReplicaSet/rabbitmq-759fbc775f
Init Containers:
istio-init:
Container ID: docker://b180f64c1589c3b8aae32fbcc3dcfbcb75bc758a78c4b22b538d0fda447aee9b
Image: docker.io/istio/proxy_init:1.0.
Image ID: docker-pullable://istio/proxy_init@sha256:345c40053b53b7cc70d12fb94379e5aa0befd979a99db80833cde671bd1f9fad
Port: <none>
Args:
-p -u -m
REDIRECT
-i
*
-x -b
,
-d State: Terminated
Reason: Completed
Exit Code:
Started: Sun, Sep :: +
Finished: Sun, Sep :: +
Ready: True
Restart Count:
Environment: <none>
Mounts:
/var/run/secrets/kubernetes.io/serviceaccount from default-token-9lxtp (ro)
Containers:
rabbitmq:
Container ID: docker://9f9062c0457bfb23d3cf8c5bbc62bff198a68dd2bbae9ef2738920650abfbe3d
Image: rabbitmq:3.6.
Image ID: docker-pullable://rabbitmq@sha256:a9f4923559bbcd00b93b02e61615aef5eb6f1d1c98db51053bab0fa6b680db26
Port: /TCP
State: Waiting
Reason: CrashLoopBackOff
Last State: Terminated
Reason: Error
Exit Code:
Started: Sun, Sep :: +
Finished: Sun, Sep :: +
Ready: False
Restart Count:
Limits:
cpu: 1024m
memory: 1Gi
Requests:
cpu:
memory:
Environment: <none>
Mounts:
/var/run/secrets/kubernetes.io/serviceaccount from default-token-9lxtp (ro)
istio-proxy:
Container ID: docker://d96548f938c41552450cd026eba5b7ff7915feb0cc058b8ecff3959896afed90
Image: docker.io/istio/proxyv2:1.0.
Image ID: docker-pullable://istio/proxyv2@sha256:77915a0b8c88cce11f04caf88c9ee30300d5ba1fe13146ad5ece9abf8826204c
Port: <none>
Args:
proxy
sidecar
--configPath
/etc/istio/proxy
--binaryPath
/usr/local/bin/envoy
--serviceCluster
istio-proxy
--drainDuration
45s
--parentShutdownDuration
1m0s
--discoveryAddress
istio-pilot.istio-system:
--discoveryRefreshDelay
1s
--zipkinAddress
zipkin.istio-system:
--connectTimeout
10s
--statsdUdpAddress
istio-statsd-prom-bridge.istio-system:
--proxyAdminPort --controlPlaneAuthPolicy
NONE
State: Running
Started: Sun, Sep :: +
Ready: True
Restart Count:
Requests:
cpu: 10m
Environment:
POD_NAME: rabbitmq-759fbc775f-s575d (v1:metadata.name)
POD_NAMESPACE: sock-shop (v1:metadata.namespace)
INSTANCE_IP: (v1:status.podIP)
ISTIO_META_POD_NAME: rabbitmq-759fbc775f-s575d (v1:metadata.name)
ISTIO_META_INTERCEPTION_MODE: REDIRECT
Mounts:
/etc/certs/ from istio-certs (ro)
/etc/istio/proxy from istio-envoy (rw)
/var/run/secrets/kubernetes.io/serviceaccount from default-token-9lxtp (ro)
Conditions:
Type Status
Initialized True
Ready False
PodScheduled True
Volumes:
istio-envoy:
Type: EmptyDir (a temporary directory that shares a pod's lifetime)
Medium: Memory
istio-certs:
Type: Secret (a volume populated by a Secret)
SecretName: istio.default
Optional: true
default-token-9lxtp:
Type: Secret (a volume populated by a Secret)
SecretName: default-token-9lxtp
Optional: false
QoS Class: Burstable
Node-Selectors: beta.kubernetes.io/os=linux
Tolerations: <none>
Events:
Type Reason Age From Message
---- ------ ---- ---- -------
Normal SuccessfulMountVolume 38m kubelet, 192.168.199.191 MountVolume.SetUp succeeded for volume "istio-envoy"
Normal SuccessfulMountVolume 38m kubelet, 192.168.199.191 MountVolume.SetUp succeeded for volume "istio-certs"
Normal SuccessfulMountVolume 38m kubelet, 192.168.199.191 MountVolume.SetUp succeeded for volume "default-token-9lxtp"
Normal Scheduled 38m default-scheduler Successfully assigned rabbitmq-759fbc775f-s575d to 192.168.199.191
Normal Started 38m kubelet, 192.168.199.191 Started container
Normal Pulled 38m kubelet, 192.168.199.191 Container image "docker.io/istio/proxy_init:1.0.0" already present on machine
Normal Created 38m kubelet, 192.168.199.191 Created container
Normal Pulled 38m kubelet, 192.168.199.191 Container image "docker.io/istio/proxyv2:1.0.0" already present on machine
Normal Started 38m kubelet, 192.168.199.191 Started container
Normal Created 38m kubelet, 192.168.199.191 Created container
Normal Pulled 37m (x4 over 38m) kubelet, 192.168.199.191 Container image "rabbitmq:3.6.8" already present on machine
Normal Started 37m (x4 over 38m) kubelet, 192.168.199.191 Started container
Normal Created 37m (x4 over 38m) kubelet, 192.168.199.191 Created container
Warning BackOff 2m (x160 over 38m) kubelet, 192.168.199.191 Back-off restarting failed container

  后来看istio的github的issue发现其他人也有遇到这个问题。其原因是在rabbitmq的service中没有加入epmd pod

apiVersion: v1
kind: Service
metadata:
name: rabbitmq
labels:
name: rabbitmq
namespace: sock-shop
spec:
ports:
# the port that this service should serve on
- port:
targetPort:
name: amqp
- port: //4369时sock-shop的epmd默认端口
name: epmd
selector:
name: rabbitmq

  然后再apply一次就发现问题解决了

[Istioc]Istio部署sock-shop时rabbitmq出现CrashLoopBackOff的更多相关文章

  1. istio部署

    Istio的部署介绍 目录 Istio的部署介绍 部署模型 集群模式 单集群 多集群 网络模型 单网络 多网络 控制面模型 身份和信任模型 网格中的信任 网格之间的信任 网格模型 单网格 多网格 租户 ...

  2. 部署Qt程序时plugins相关问题

    部署qt程序时,经常涉及到Qt5.5.0\5.5\msvc2013\plugins目录下的一些动态链接库 例如数据库sqldrivers,操作系统类型platforms,读取各种图片imageform ...

  3. IIS7或者IIS7.5部署MVC项目时出现404错误

    IIS7或者IIS7.5部署MVC项目时出现404错误 服务器上需要安装Windows 补丁 kb980368  下载链接:http://support.microsoft.com/kb/980368

  4. 往服务器部署thinkphp5代码时要注意 pathinfo的问题

    往服务器部署thinkphp5代码时要注意 pathinfo的问题 如果nginx没有做任何设置 要使用?s=/的方式访问地址 只需要修改3个地方就可以了,亲测成功,看代码有注解 location ~ ...

  5. activiti部署流程定义时出错:INSERT INTO ACT_GE_BYTEARRAY,修改数据库编码

    activiti部署流程定义时出错 // 部署流程定义 Deployment deployment = deploymentBuilder.deploy(); 错误信息:(有乱码的...没留下截图.. ...

  6. 我们在部署 HTTPS 网站时,该如何选择SSL证书?

    我们在部署 HTTPS 网站时,该如何选择SSL证书? 首次部署HTTPS网站的同学对选择什么样的SSL证书多多少少都有点迷茫. 这里考虑的因素确实不少:是否支持多域名.泛域名,价格,信息泄露的保额, ...

  7. Windows Server 部署WEB API时内部错误

    Windows Server 部署WEB API时,发生HTTP 错误 500.21 - Internal Server Error,如图所示: 错误原因:IIS注册Framework4.0 解决方法 ...

  8. idea部署tomcat项目时,在项目里打断点不能拦截

    以下内容都是基于我自己的项目(如未解决道友们的问题,请别介意) idea部署tomcat项目时,在项目里打断点不能拦截,工作中遇到的问题,记录一下(tomcat6) 当项目的以下内容配置完毕后,启动项 ...

  9. hexo部署到github时,提示typeError [ERR_INVALID_ARG_TYPE] The “mode“ argument must be integer. Receive

    hexo部署到github时,提示typeError [ERR_INVALID_ARG_TYPE]: The "mode" argument must be integer. Re ...

随机推荐

  1. JAVA常用知识总结(二)

    JAVA中的参数传递总结先看两道笔试题: public class Test2 { public static void main (String [] args) { StringBuffer a ...

  2. 2018微软实习笔试一道dp题目总结

    题意大概是说在一维数轴上起点和终点的距离是d,现在我们要从起点走到终点.每走一个单位长度消耗一个单位能量,初始时有K单位能量.同时在起点和终点之间分布一些加油站a1,a2,...an,给你加油站数量. ...

  3. scrollTop、offsetTop、clientTop

    1.offsetTop: obj.offsetTop 指 obj 相对于版面或由 offsetParent 属性指定的父坐标的计算上侧位置. 2.clientTop: 这个返回的是元素周围边框的厚度, ...

  4. 【js数据结构】图的深度优先搜索与广度优先搜索

    图类的构建 function Graph(v) {this.vertices = v;this.edges = 0;this.adj = []; for (var i = 0; i < this ...

  5. Mac上面不能安装Homebrew

    这个stackoverflow的答案解决了我的问题: http://stackoverflow.com/questions/18039029/mac-can-t-install-homebrew 问题 ...

  6. PL/SQL学习笔记(三)

    -----创建一个序列,再创建一个表(主键是数字),通过序列生成该表的主键值. create table mytb1( m_id number primary key, m_name ) not nu ...

  7. Mac上安装Homebrew和wget

    实际上是使用Homebrew来安装wget 安装Homebrew Homebrew一般称为brew,是Mac OSX上的软件包管理工具,能在Mac中方便的安装软件或者卸载软件, 只需要一个命令, 非常 ...

  8. sql 删除重复数据

    DELETE a FROM tbBuilding a WHERE EXISTS (SELECT 1 FROM tbBuilding b WHERE b.Province = a.Province AN ...

  9. 51nod 1417 天堂里的游戏

    基准时间限制:1 秒 空间限制:131072 KB 分值: 10 难度:2级算法题  收藏  关注 多年后,每当Noder看到吉普赛人,就会想起那个遥远的下午. Noder躺在草地上漫无目的的张望,二 ...

  10. [Github筆記] 清除所有 Commit 紀錄

    # 把原來的 git 移除掉 sudo rm .git -r # 初始化 git init git remote add origin https://github.com/username/repo ...