Error : The specified component was not reported by the VSS writer (Error 517) in Windows Server 2012 Backup

In Windows Server, it is possible to perform Backup of your system and even Virtual Machine in production. Yes Windows Server Backup is a really good solution for backup the Hyper-V virtual machines. But “The specified component was not reported by the VSS writer” error can sometime appear and failed all scheduled backup.

Today most of the company are using visualization solution (Microsoft, Citrix, Vmware …) in their infrastructure. I’m personally using the Microsoft solution named Hyper-V, due to the fact that it is included in Windows Server. After many hours of hard-working in my lab, I wanted to backup all my virtual machines. But one day, the error 517 came.

ERROR DESCRIPTION

One day, without any reason, an error message appeared “The specified component was not reported by the VSS writer” for all my virtual machines.

WINDOWS SERVER BACKUP LOG

 

WINDOWS SERVER LOG

 
1
2
3
4
5
6
Writer Id: {66841CD4-6DED-4F4B-8F17-FD23F8DDC3DE}
   Component: 3B38B9C6-7232-4C65-85D0-E7447589A94F
   Caption     : Backup Using Child Partition Snapshot\VM Name
   Logical Path:
   Error           : 80780176
   Error Message   : The specified component was not reported by the VSS writer.

EVENT VIEWER LOG

 
1
2
3
4
5
Event id : 517
Level : Error
Source : Backup
 
The backup operation that started at '‎2013‎-‎07‎-‎07T00:00:17.716937900Z' has failed with following error code '0x80780049' (None of the items included in backup were backed up.). Please review the event details for a solution, and then rerun the backup operation once the issue is resolved.

RESOLUTION AND DOWNLOAD.

After some research, I found that the problem was connected with Microsoft Shadow copy Service. I decided to delete all shadow copy in my host and I was able to backup all my server again.

I used those commands line in a Powershell window:

Order
Command
Description
 
1 DiskShadow Connect to DiskShadow tool
2 Delete Shadows all Delete all shadows copy
3 list shadows all check that the list is empty
4 Exit Disconnect to DiskShadow tool  

Once, the command has been executed, you should be able to relaunch your backup.

HOWEVER, THIS ERROR CAN STILL COMEBACK!

You have to delete again manually the Shadows copy or you can execute my script (DeleteShadows). The instruction are include in the rar file.

Error : The specified component was not reported by the VSS writer (Error 517) in Windows Server 2012 Backup的更多相关文章

  1. Using Windows Server 2012 Backup for Hyper-V Virtual Machines. Error 80780176 - The specified component was not reported by the VSS writer.

    https://social.technet.microsoft.com/Forums/windowsserver/en-US/1a1e0066-f421-43d6-970b-1e20e674cdf9 ...

  2. 解决Windows server 2012 R2 系统使用IIS8浏览Asp程序出现"An error occurred on the server when processing the URL"错误

    进入IIS并将ASP里的“Send Error To Browser”设置为True后点击Appley保存即可 原因是IIS里的Asp设置禁用上当错误信息发送给浏览器,只要启用即可 如果没有Asp选项 ...

  3. HTTP 错误 500.19 - Internal Server Error(Windows Server 2012)

    错误页面: 解决办法:重新添加角色和功能web服务器(IIS),选择应用程序开发下的相关.net4.5的选项

  4. Install SharePoint 2013 with SP1 on Windows Server 2012 R2 error - This Product requires .NF 4.5

    博客地址:http://blog.csdn.net/FoxDave 最近因为项目需要要搭建SharePoint 2013的开发环境. 准备了Windows Server 2012 R2系统和Sha ...

  5. SQL Server 2012安装错误案例:Error while enabling Windows feature: NetFx3, Error Code: -2146498298

    案例环境: 服务器环境 :    Windows Server 2012 R2 Standard 数据库版本 :    SQL Server 2012 SP1 案例介绍:   在Windows Ser ...

  6. Apache Error: Invalid command ‘Allow’, perhaps misspelled or defined by a module not included in the server configuration

    在一个Window Server 2008R2系统上使用Apache架设了一个PHP的网站项目 在配置Apache的过程中出现了以下问题   根据上面的提示说是没有相应的权限,那就在虚拟主机里进行了配 ...

  7. Spark Shell启动时遇到<console>:14: error: not found: value spark import spark.implicits._ <console>:14: error: not found: value spark import spark.sql错误的解决办法(图文详解)

    不多说,直接上干货! 最近,开始,进一步学习spark的最新版本.由原来经常使用的spark-1.6.1,现在来使用spark-2.2.0-bin-hadoop2.6.tgz. 前期博客 Spark ...

  8. SQL Error (1130): Host '192.168.1.126' is not allowed to connect to this MySQL server

    通过HeidiSQL连接MYSQL数据库报错: SQL Error (1130): Host '192.168.1.126' is not allowed to connect to this MyS ...

  9. 通过navicat连接mysql服务器提示SQL Error (1130): Host '192.168.1.100' is not allowed to connect to this MySQL server

    新装一个mysql,尝试用通过navicat连接mysql服务器的时候提示: SQL Error (1130): Host '192.168.1.100' is not allowed to conn ...

随机推荐

  1. hihoCoder #1185 : 连通性·三(强联通分量+拓扑排序)

    #1185 : 连通性·三 时间限制:10000ms 单点时限:1000ms 内存限制:256MB 描述 暑假到了!!小Hi和小Ho为了体验生活,来到了住在大草原的约翰家.今天一大早,约翰因为有事要出 ...

  2. 多线程 or I/O复用select/epoll

    1:多线程模型适用于处理短连接,且连接的打开关闭非常频繁的情形,但不适合处理长连接.线程模型默认情况下,在Linux下每个线程会开8M的栈空间,在TCP长连接的情况下,以2000/分钟的请求为例,几乎 ...

  3. LeetCode282. Expression Add Operators

    Given a string that contains only digits 0-9 and a target value, return all possibilities to add bin ...

  4. 利用CE手动破解百度云下载限速!

    一步,你需要打开百度云<ignore_js_op> 第二步,你需要用上面附送的工具选择百度云进程<ignore_js_op> 第三点,不多说,看图<ignore_js_o ...

  5. node模拟socket

    什么是Socket?网络上的两个程序通过一个双向的通信连接实现数据的交换,这个连接的一端称为一个socket. Socket通信流程 基于net模块实现socket 服务端SocketServer.j ...

  6. spring boot 之使用mapstruct

    最近在阅读swagger源码,当看到 springfox.documentation.swagger2.mappers.ModelMapper 类时,无意中看到该类上面使用的 org.mapstruc ...

  7. 【LOJ】#2244. 「NOI2014」起床困难综合症

    题解 写水题放松一下心情 二进制有个很好的性质是每一位是独立的,我们按位贪心,先看这一位能不能填1,然后看看如果这一位填0那么运算后最后这一位是不是1,是的话就退出,然后看看这一位如果填1最后是1这一 ...

  8. CentOS 使用命令设置代理

    全局的代理设置, vim /etc/profile 添加下面内容 http_proxy = http://username:password@yourproxy:8080/ ftp_proxy = h ...

  9. 导出Excel超过65535条限制解决方案

    使用poi导出excel的时候如果数据过多,超过65535条会报错,因为excel2003一个sheet表最多导出65535条,excel2007是10万4000多条限制. 因此遇到这种excel导出 ...

  10. Kotlin in Action 笔记

    Kotlin 参考 官网 reference kotlin实战 Try Kotlin Kotlin China Github 简介 Kotlin是一门把Java平台作为目标的新的编程语言.它简洁.安全 ...