发生症状: 先是服务器挂掉,之后服务器可以登陆,但是实例却不能登陆进去(部分)。出现的错误日志如下:

2014-01-24 09:37:00.14 Server      Microsoft SQL Server 2008 R2 (SP2) - 10.50.4000.0 (X64)
Jun 28 2012 08:36:30
Copyright (c) Microsoft Corporation
Enterprise Edition (64-bit) on Windows NT 6.1 <X64> (Build 7600: ) 2014-01-24 09:37:00.15 Server (c) Microsoft Corporation.
2014-01-24 09:37:00.15 Server All rights reserved.
2014-01-24 09:37:00.15 Server Server process ID is 5732.
2014-01-24 09:37:00.15 Server System Manufacturer: 'Dell Inc.', System Model: 'PowerEdge R410'.
2014-01-24 09:37:00.15 Server Authentication mode is MIXED.
2014-01-24 09:37:00.15 Server Logging SQL Server messages in file 'D:\SQL_2K8\MSSQL10_50.XXXXXXX\MSSQL\Log\ERRORLOG'.
2014-01-24 09:37:00.15 Server This instance of SQL Server last reported using a process ID of 5360 at 2014/1/24 9:36:44 (local) 2014/1/24 1:36:44 (UTC). This is an informational message only; no user action is required.
2014-01-24 09:37:00.15 Server Registry startup parameters:
-d D:\SQL_2K8\MSSQL10_50.XXXXXXX\MSSQL\DATA\master.mdf
-e D:\SQL_2K8\MSSQL10_50.XXXXXXX\MSSQL\Log\ERRORLOG
-l D:\SQL_2K8\MSSQL10_50.XXXXXXX\MSSQL\DATA\mastlog.ldf
2014-01-24 09:37:00.16 Server SQL Server is starting at normal priority base (=7). This is an informational message only. No user action is required.
2014-01-24 09:37:00.16 Server Detected 8 CPUs. This is an informational message; no user action is required.
2014-01-24 09:37:00.16 Server Large Page Extensions enabled.
2014-01-24 09:37:00.16 Server Large Page Granularity: 2097152
2014-01-24 09:37:00.17 Server Large Page Allocated: 32MB
2014-01-24 09:37:00.17 Server Large Page Allocated: 32MB
2014-01-24 09:37:00.18 Server Using locked pages for buffer pool.
2014-01-24 09:37:00.23 Server Using dynamic lock allocation. Initial allocation of 2500 Lock blocks and 5000 Lock Owner blocks per node. This is an informational message only. No user action is required.
2014-01-24 09:37:00.25 Server Node configuration: node 0: CPU mask: 0x00000000000000f0:0 Active CPU mask: 0x00000000000000f0:0. This message provides a description of the NUMA configuration for this computer. This is an informational message only. No user action is required.
2014-01-24 09:37:00.25 Server Node configuration: node 1: CPU mask: 0x000000000000000f:0 Active CPU mask: 0x000000000000000f:0. This message provides a description of the NUMA configuration for this computer. This is an informational message only. No user action is required.
2014-01-24 09:37:00.28 spid6s Starting up database 'master'.
2014-01-24 09:37:00.33 spid6s Resource governor reconfiguration succeeded.
2014-01-24 09:37:00.33 spid6s SQL Server Audit is starting the audits. This is an informational message. No user action is required.
2014-01-24 09:37:00.33 spid6s SQL Server Audit has started the audits. This is an informational message. No user action is required.
2014-01-24 09:37:00.33 spid6s FILESTREAM: effective level = 0, configured level = 0, file system access share name = 'XXXXXXX'.
2014-01-24 09:37:00.34 spid6s SQL Trace ID 1 was started by login "sa".
2014-01-24 09:37:00.34 spid6s Starting up database 'mssqlsystemresource'.
2014-01-24 09:37:00.35 spid6s Error: 17204, Severity: 16, State: 1.
2014-01-24 09:37:00.35 spid6s FCB::Open failed: Could not open file C:\Program Files\Microsoft SQL Server\MSSQL10_50.XXXXXXX\MSSQL\Binn\mssqlsystemresource.mdf for file number 1. OS error: 2(系统找不到指定的文件。).
2014-01-24 09:37:00.35 spid6s Error: 5120, Severity: 16, State: 101.
2014-01-24 09:37:00.35 spid6s Unable to open the physical file "C:\Program Files\Microsoft SQL Server\MSSQL10_50.XXXXXXX\MSSQL\Binn\mssqlsystemresource.mdf". Operating system error 2: "2(系统找不到指定的文件。)".
2014-01-24 09:37:00.35 spid6s Error: 17207, Severity: 16, State: 1.
2014-01-24 09:37:00.35 spid6s FileMgr::StartLogFiles: Operating system error 2(系统找不到指定的文件。) occurred while creating or opening file 'C:\Program Files\Microsoft SQL Server\MSSQL10_50.XXXXXXX\MSSQL\Binn\mssqlsystemresource.ldf'. Diagnose and correct the operating system error, and retry the operation.
2014-01-24 09:37:00.35 spid6s File activation failure. The physical file name "C:\Program Files\Microsoft SQL Server\MSSQL10_50.XXXXXXX\MSSQL\Binn\mssqlsystemresource.ldf" may be incorrect.
2014-01-24 09:37:00.35 spid6s Error: 945, Severity: 14, State: 2.
2014-01-24 09:37:00.35 spid6s Database 'mssqlsystemresource' cannot be opened due to inaccessible files or insufficient memory or disk space. See the SQL Server errorlog for details.
2014-01-24 09:37:00.35 spid6s SQL Trace was stopped due to server shutdown. Trace ID = ''. This is an informational message only; no user action is required.

从上面可以看到是系统启动的时候找不到文件,而有一部分的系统文件是在迁移在D盘了的。

解决办法: 因为mssqlsystemresource这个数据库存放的是系统存储过程之类的东东,相同的版本都是相同的,所以可以拿版本一样的替换就可以了。
原因: 估计是装 service package, 或者系统补丁, 有些东西要重启才生效,而且控制得有问题,所以重启后要让某些东西生效,但是这个东东被删除了没有恢复
其它知识补充:  mssqlsystemresource database is removed after SQL Server 2008 R2 SP1 installation

SQL Server 2005的Resource数据库

SQL SERVER 服务启动后停止,某些服务由其它服务或程序使用时将自动停止的更多相关文章

  1. 本地计算机 上的 Redis Server 服务启动后停止

    服务器上Redis服务安装正常..却启动不了.. 报错  :   本地计算机 上的 Redis Server 服务启动后停止.某些服务在未由其他服务或程序使用时将自动停止. 最后发现是Redis的配置 ...

  2. win10出现"本地计算机上的MySQL57服务启动后停止"

    在window10下mysql57出现"本地计算机上的MySQL57服务启动后停止.某些服务在未由其他服务或程序使用时将自动停止"错误 环境:win10.MySQL Communi ...

  3. 本地计算机上的SQLServer(MSSQLSERVER)服务启动后停止,某些服务在未由其他服务或程序使用时将自动停止

    SQLServer的服务启动问题: 本地计算机上的SQLServer(MSSQLSERVER)服务启动后停止,某些服务在未由其他服务或程序使用时将自动停止 出现这个问题导致无法启动SQLServer服 ...

  4. MySQL 安装和启动服务,“本地计算机 上的 MySQL 服务启动后停止。某些服务在未由其他服务或程序使用时将自动停止。”

    MySQL 安装和启动服务,以及遇到的问题 MySQL版本: mysql-5.7.13-winx64.zip (免安装,解压放到程序文件夹即可,比如 C:\Program Files\mysql-5. ...

  5. 本地计算机上的XXX服务启动后停止。某些服务在未由其它服务或程序使用时将自动停止。咋整?

    用C#写个windows服务,安装部署后去启动时,提示说“本地计算机上的XXX服务启动后停止.某些服务在未由其它服务或程序使用时将自动停止”.咋整?就像下面酱紫: 度娘说不知道咋整,我想把程序附加到w ...

  6. MySQL 5.7.19 忘记密码 重置密码 配置文件my.ini示例 服务启动后停止 log配置

    [参考]java 项目 存入mysql后 变问号 MySql 5.6 (X64) 解压版 1067错误与编码问题的解决方案 一.my.ini 的mysqld下添加 skip-grant-tables ...

  7. SQL Server(MSSQLSERVER)启动失败,提示“请求失败或服务未及时响应

    1.SQL Server(MSSQLSERVER)启动失败,提示“请求失败或服务未及时响应. --------------------------- SQL Server 配置管理器 -------- ...

  8. 本地计算机 上的 OracleOraDb11g_home1TNSListener 服务启动后停止

    今天玩oracle的时候突然遇到一个问题:本地计算机 上的 OracleOraDb11g_home1TNSListener 服务启动后停止.某些服务在未由其他服务或程序使用时将自动停止. 在网上找解决 ...

  9. (转)解决:本地计算机 上的 OracleOraDb10g_home1TNSListener服务启动后停止

    原文地址:http://justsee.iteye.com/blog/1320059 手动启动一个问题:本地计算机 上的 OracleOraDb10g_home1TNSListener服务启动后停止. ...

  10. 本地计算机上的OracleOraDb11g_home1TNSListener服务启动后停止。某些服务在未由其他服务或程序使用时将自动停止。——Oracle监听器服务无法启动!

    问题: oracle服务设置为手动启动.但是开机后手动启动监听服务后弹出框,提示“本地计算机上的OracleOraDb11g_home1TNSListener服务启动后停止.某些服务在未由其他服务或程 ...

随机推荐

  1. windows小技巧 从文件夹直接打开命令行位置

    windows下从命令行打开某个目录下的东东时,会一直cd  ~~~~,更简单的是: 直接用鼠标找到该文件夹或者文件,按住Shift键然后点击鼠标右键,选择"在此处打开命令行"即可 ...

  2. hdu 4651 - Partition(五边形数定理)

    定理详见维基百科....http://zh.wikipedia.org/wiki/%E4%BA%94%E9%82%8A%E5%BD%A2%E6%95%B8%E5%AE%9A%E7%90%86 代码如下 ...

  3. 真实世界:使用WCF扩展在方法调用前初始化环境

    OperationInvoker 介绍 OperationInvoker 是 WCF 运行时模型中在调用最终用户代码前的最后一个扩展点,OperationInvoker 负责最终调用 Service ...

  4. Microsoft 家族新成员 Datazen 移动BI 介绍

    开篇介绍 Microsoft 在上个月即 2015年4月份收购了 Datazen www.datazen.com, Datazen 专注于移动 BI 和数据可视化领域,并且它的基本部署与配置架构都是基 ...

  5. NBIbatis web/winform框架

    Web框架 调用Bussiness和DataAccess可参考微信框架的后台. Pages/Meeting/MeetingList.aspx Pages/Meeting/MeetingEdit.asp ...

  6. php后台开发(二)Laravel框架

    php后台开发(二)Laravel框架 为了提高后台的开发效率,往往需要选择一套适合自己的开发框架,因此,选择了功能比较完善的Laravel框架,仔细学来,感觉和Python语言的框架Django非常 ...

  7. [新概念51单片机C语言教程·郭天祥] 1、 基础知识必备

    目录: 单片机的大致介绍         1-1.通俗定义         1-2.51系列产品         1-3.标号意思         1-4.引脚介绍         1-5.用C语言开 ...

  8. paip.java UrlRewrite 的原理and实现 htaccess正则表达式转换

    paip.java UrlRewrite 的原理and实现 htaccess正则表达式转换 #---KEYWORD #-正则表达式 正则表达式 表示 非指定字符串开头的正则 排除指定目录.. 作者 老 ...

  9. javaweb学习总结(二十三)——jsp自定义标签开发入门

    一.自定义标签的作用 自定义标签主要用于移除Jsp页面中的java代码. 二.自定义标签开发和使用 2.1.自定义标签开发步骤 1.编写一个实现Tag接口的Java类(标签处理器类) 1 packag ...

  10. C#程序中注释过多的8条理由

    程序中中的注释,一般是有益处的,可以知晓程序的一些逻辑说明,或是参数解释.但是有些程序,因为注释太多,反而引起维护上的不方便,删掉了怕以后不能出现问题不好查找原因,不删除留在代码中,对程序的维护人员, ...