今天在做备份时发现了这个报错。经过ping, nslookup, bpclntcmd命令检查没有发现连接或域名解析存在问题。

参考文档http://www.symantec.com/docs/TECH59927,在检查时发现/use/openv/netbackup/db/client/<client_name>目录下存在一个名为fi_info.<client_backup_policy>.class的文件,而并不存在名为host_info的文件或目录。为了安全起见,我没有直接删除<client_name>这个目录,而是做了重命名。

mv /use/openv/netbackup/db/client/<client_name> /use/openv/netbackup/db/client/<client_name_bk>

然后重新执行备份,备份成功完成。

 

附参考文档:http://www.symantec.com/docs/TECH59927

Problem

STATUS CODE 48: Backups of a UNIX client fail with a NetBackup Status Code 48 (client hostname could not be found), but hostname lookup and DNS issues are not the problem

Error

client hostname could not be found

Solution

Overview:
A NetBackup client backup fails with NetBackup Status Code 48 (client hostname could not be found), even when no hostname lookup issues exist.  Traditional troubleshooting techniques using bpclntcmd, bptestbpcd, telnet, ping, nslookup, all show good connectivity and name resolution.  Other clients are backing up correctly.
Troubleshooting:
Review the contents of the /usr/openv/netbackup/db/client/<client_name> directory on the master server.  
This directory should contain client attribute information, and by default is not present under the db/clientdirectory.   Client attributes may be added under the master server host properties in the NetBackup Administration Console, or by command line using the bpclient command.  When client attributes are set correctly, the <client_name> directory should contain the client attributes in a subdirectory called host_info.
Log files:  
The bpbrm log file shows the following:
18:02:08.516 [21626] <2> verify_client: bpbrm.c.32914: Could not find a host name for DHCP client: <client_name>
18:02:08.516 [21626] <2> bpbrm process_start_backup_msg: bpbrm.c.11705: verify_client failed: 48 48 0x00000030
Resolution:
The above symptoms and error messages are seen if the/usr/openv/netbackup/db/client/<client_name> directory on the master server does not contain any client attribute information, or contains otherwise corrupt information.  
If the client directory is empty, the directory may be removed manually in one of three ways:

1. Using the rm -r command. 

2. Using the NetBackup Administration Console to remove the client from the client attributes in the master server host properties.

3. By running bpclient -client <client_name> -delete.   If the client directory is not empty, the directory may be renamed to eliminate any data corruption as the cause of the issue.

NBU客户端备份失败,报错error 48 client hostname could not be found的更多相关文章

  1. 运行开源项目,报错Error:(48, 37) 错误: -source 1.6 中不支持 diamond 运算符,请使用-source 7或者更高版本已启用diamond运算符

    错误定位 当时并没有弄明白为什么会出错,一脸懵逼相 解决办法: 将source compatibility和target compatibility都改为1.7,重新build就ok了. 错误原因: ...

  2. xtrabackup备份MySQL报错:InnoDB: Error number 24 means 'Too many open files'

    xtrabackup备份MySQL报错:InnoDB: Error number 24 means 'Too many open files' 1.使用xtrabackup备份MySQL时出现如下报错 ...

  3. mysql报错"ERROR 1206 (HY000): The total number of locks exceeds the lock table size"的解决方法

    1. 问题背景         InnoDB是新版MySQL(v5.5及以后)默认的存储引擎,之前版本的默认引擎为MyISAM,因此,低于5.5版本的mysql配置文件.my.cnf中,关于InnoD ...

  4. 【MySQL笔记】mysql报错"ERROR 1206 (HY000): The total number of locks exceeds the lock table size"的解决方法

    step1:查看 1.1 Mysql命令行里输入"show engines:"查看innoddb数据引擎状态, 1.2 show variables "%_buffer% ...

  5. open数据库报错ERROR at line 1: ORA-03113: end-of-file on communication channel Process ID: 3880 Session ID: 125 Serial number: 3

    1.今天打开数据时,失败,报错 ERROR at line 1:ORA-03113: end-of-file on communication channelProcess ID: 3880Sessi ...

  6. redis集群报错:(error) CLUSTERDOWN Hash slot not served

    百度上坑太多,如果你遇到搭建redis集群的时候出现这个错误在百度上找到解决办法基本上都是坑. 首先集群搭建完成后,你肯定去登陆redis进行测试 1.redis01/redis-cli -h &qu ...

  7. Android stdio 报错 error invoking main method

    打开Android stdio失败 报错:error invoking main method 想想前一天做了什么事?? 昨天把企图把Android Stdio文件包移盘,但是中途截止了,也就是说移动 ...

  8. Git fetch和git pull的区别, 解决Git报错:error: You have not concluded your merge (MERGE_HEAD exists).

    Git fetch和git pull的区别, 解决Git报错:error: You have not concluded your merge (MERGE_HEAD exists). Git fet ...

  9. mybatis报错 Error instantiating interface com.atguigu.mybatis.dao.DepartmentMapper with invalid types () or values ()

    mybatis报错 Error instantiating interface com.atguigu.mybatis.dao.DepartmentMapper with invalid types ...

随机推荐

  1. openssl——初了解

    Openssl OpenSSL是一个开源的.用于SSL/TLS协议的加密工具,是互联网加密传输的核心基础组件,由加拿大的Eric Yang等发起编写的,当前互联网安全传输的大部分场景(如HTTPS)均 ...

  2. javascript的宿主环境

    关于javascript语言,最有意思的是它必须要在一个宿主环境中运行,其中受欢迎的宿主环境当然就是浏览器了,但这并不是我们唯一的选择, javascript完全可以运行在服务器端,桌面以及富媒体环境 ...

  3. pdf2swf+flexpaper解决pdf在线阅读(类百度文库)

    1:工具准备swftools.exe 下载 http://www.swftools.org/download.html 安装至D盘 SWFTools提供了一系列将各种文件转成swf的工具: font2 ...

  4. 防止xss,sql攻击函数

    <?php //php防注入和XSS攻击通用过滤. //by qq:831937 $_GET && SafeFilter($_GET); $_POST && Sa ...

  5. RocketMQ原理讲解系列文章

    [RocketMQ原理解析][http://blog.csdn.net/quhongwei_zhanqiu/article/category/2548637] [消息的可靠性.顺序和重复][https ...

  6. wpf 界面平级之间设置上下顺序关系(ZIndex)

    只能用于平级之间设置上下顺序 this.grid1.SetValue(Grid.ZIndexProperty, 9999);                    Panel.SetZIndex(th ...

  7. 【译】:lxml.etree官方文档

    本文翻译自:http://lxml.de/tutorial.html, 作者:Stefan Behnel 这是一个关于使用lxml.etree进行XML处理的教程.它简要介绍了ElementTree ...

  8. 51nod 1099 贪心/思维

    http://www.51nod.com/onlineJudge/questionCode.html#!problemId=1099 1099 任务执行顺序 基准时间限制:1 秒 空间限制:13107 ...

  9. Idea_学习_09_Idea 方法自动生成参数默认名

    一.方法 1.快捷键 生成方法后,还空着参数,可以使用 ctrl + alt + 空格 ,列出参数,然后选择参数即可. 2.使用插件 二.参考资料 1.Intellij Idea 方法自动生成参数默认 ...

  10. 远程激活.NET REFLECTOR(不能断网)

    由于是远程连接的服务器,使用.Net Reflector注册机激活时,不能断网. 如何禁止Reflector连接她的激活服务器,可进行如下操作: 1.添加hosts: 0.0.0.0 red-gate ...