ArcGIS for Server使用AD中的用户配置
ArcGIS for Server使用AD中的用户配置
1、概述
默认情况下,ArcGIS Server使用内置存储模式来管理用户和角色。该模式使用基于文件格式来存储信息。当然,ArcGIS Server也支持将用户和角色信息由第三方接管,如使用企业系统中的用户和角色。目前支持的企业用户系统有LDAP和Windows AD。LDAP是一种标准的目录服务协议,有开源实现版本和商业版本可供选择。windows AD其实也是一种目录服务。如果使用第三方的用户体系,ArcGIS Server只能以只读模式管理用户和角色。
第三方用户体系接管的方式有两种:同时接管用户和角色;只接管用户,角色仍用ArcGIS Server自带的内置存储。
2、AD接管ArcGIS Server用户配置
2.1、安装环境说明
ArcGIS for Server安装版本:10.2.2,安装在非域环境下的机器上,默认方式安装。安装完成后,将机器添加到域环境中。
如果是在域环境下的机器上,使用本地账号安装ArcGIS Server应该也是可行的,这种情况未做测试。
注意:在测试中发现,如果Server所在的机器未添加到域环境中,使用域账号可正常访问域中共享的目录,但设置Server由AD接管用户时,始终提示连接失败。
2.2、AD接管用户信息配置
登陆ArcGIS for Server Manager站点,打开安全性à设置,修改配置设置信息。
(1)选择使用AD接管用户,角色仍用默认方式

(2)选择Windows域

(3)输入域管理员账号

(4)ArcGIS Server的身份验证有两种方式:ArcGIS Server令牌身份验证证和Web服务器身份验证。对应这里的GIS服务器层验证和Web层验证。Web层验证需要Web Adaptor支持。简单点,这里选择GIS服务器层验证。

(5)设置完成,打开用户信息,可查看读取自AD中的用户

注意:上述用户只有hany和xinli是我自定义的用户,其他用户来自AD机器上默认用户。在AD用户下却未找到krbtgt用户。

2.2、AD同时接管用户和角色信息配置
ArcGIS Server配置使用AD中的用户和角色与上述步骤一样。配置完成可查看角色信息。

注意:Server中读取的角色来自AD中Builtin和Users下的本地域安全组、全局安全组和通用安全组。
3、其他配置注意事项(来自帮助)
3.1、配置支持AD中的嵌套组
ArcGIS Server 提供了自定义 ASP.NET 提供程序来支持嵌套组。
(1)验证 ArcGIS Server .NET 扩展模块支持要素是否安装在托管服务器的计算机上。可通过启动 ArcGIS Server 安装程序,并检查所选的待安装功能列表来执行此操作。
(2)打开 ArcGIS Server admin目录。
(3)选择securityàconfigàupdateIdentityStore。
在User Store Configuration下输入:
{
"type": "ASP_NET",
"class": "AGSMembershipProvider.AGSADMembershipProvider",
"properties": {
"adminUserPassword": "[user password]",
"adminUser": "[domain]\\[user name]"
}
}
在Role Store Configuration下输入:
{
"type": "ASP_NET",
"class": "AGSMembershipProvider.AGSADRoleProvider",
"properties": {
"adminUserPassword": "[user password]",
"adminUser": "[domain]\\[user name]"
}
}
(4)点update即可。
3.2、登陆设置拒绝登陆托管AD的计算机
(1)设置Server以支持AD 中的嵌套组。
(2)登陆托管AD的机器,打开服务器管理器下的AD用户信息。
(3)找到Server安全配置中指定的域账号的组织单位,打开账号属性。
(4)在账号下,打开登陆到,将Server所在的机器添加进去。
注意:这方式只允许该账号访问指定机器。
ArcGIS for Server使用AD中的用户配置的更多相关文章
- SharePoint自动化部署,利用PowerShell 导出/导入AD中的用户
这几个月一直在帮客户改需求,部署.我已经心力憔悴,经过一段时间的摸索,我对用PowerShell实现自动化部署也有了一些心得,比如说利用PowerShell导出导入AD中的User.在基于ShareP ...
- Windows Server 2008 R2中IIS7.5配置完网站权限不足问题的解决办法:
Windows Server 2008 R2中IIS7.5配置完网站权限不足问题的解决办法:常见问题:HTTP 错误 500.0 - Internal Server Error无法显示页面,因为发生内 ...
- Linux中普通用户配置sudo权限(带密或免密)
配置步骤如下: 1.登陆或切换到root用户下: 2.添加sudo文件的写权限,命令是:chmod u+w /etc/sudoers 3.编辑sudoers文件:vi /etc/sudoers 找到这 ...
- 2013Esri全球用户大会之ArcGIS for Server&Portal for ArcGIS
Q1:ArcGIS 10.2 for Server有哪些新特性? ArcGIS 10.2对于ArcGIS for Server来说是一个引人注目的版本.它建立在ArcGIS 10.1扎实雄厚的基础上, ...
- ArcGIS for Server安全与LDAP配置
ArcGIS for Server安全与LDAP配置 1.安全性概述 ArcGIS Server使用基于角色的访问控制来管理对受保护资源的访问.访问GIS资源的权限只能分配给角色.单独的用户只能通过从 ...
- 你所不知道的SQL Server数据库启动过程(用户数据库加载过程的疑难杂症)
前言 本篇主要是上一篇文章的补充篇,上一篇我们介绍了SQL Server服务启动过程所遇到的一些问题和解决方法,可点击查看,我们此篇主要介绍的是SQL Server启动过程中关于用户数据库加载的流程, ...
- 将Dynamics 365中的用户及其角色、角色导出到Excel中
关注本人微信和易信公众号: 微软动态CRM专家罗勇 ,回复240或者20161204可方便获取本文,同时可以在第一间得到我发布的最新的博文信息,follow me!我的网站是 www.luoyong. ...
- (4.21)SQL Server数据库启动过程(用户数据库加载过程的疑难杂症)
转自:指尖流淌 http://www.cnblogs.com/zhijianliutang/p/4100103.html SQL Server数据库启动过程(用户数据库加载过程的疑难杂症) 前言 本篇 ...
- SQL Server 数据库启动过程(用户数据库加载过程的疑难杂症)
前言 本篇主要是上一篇文章的补充篇,上一篇我们介绍了SQL Server服务启动过程所遇到的一些问题和解决方法,可点击查看,我们此篇主要介绍的是SQL Server启动过程中关于用户数据库加载的流程, ...
随机推荐
- c#几种数据库的大数据批量插入(SqlServer、Oracle、SQLite和MySql)
这篇文章主要介绍了c#几种数据库的大数据批量插入(SqlServer.Oracle.SQLite和MySql),需要的朋友可以了解一下. 在之前只知道SqlServer支持数据批量插入,殊不知道Ora ...
- 启动Tomcat报错
如果发现引入jar包有问题时,看jar包是否损坏,变成了0kb.如果是这样,在网上试尽解决办法也是有问题的. 一般Tomcat启动报错,要引入这两个jar包.
- mysql 5.7.22 解压缩安装
1.下载地址:https://dev.mysql.com/downloads/mysql/5.7.html#downloads 直接点击下载项 下载后: 2.可以把解压的内容随便放到一个目录,我的是如 ...
- Go 语言 基础 【第一篇】:package fmt导入
package main 解释:只要你 一个可执行 程序
- bzoj2212 Tree Rotations 线段树合并+动态开点
题目传送门 思路: 区间合并线段树的题,第一次写,对于一颗子树,无论这个子树怎么交换,都不会对其他子树的逆序对造成影响,所以就直接算逆序对就好. 注意叶子节点是1到n的全排列,所以每个权值都只会出现1 ...
- UVALive - 2678 二分/尺取
题意:求最小的长度L满足该长度上的元素和大于等于S 最近dp做多了总有一种能用dp解决一切的错觉 二分长度解决 #include<iostream> #include<algorit ...
- UVA - 10589 构造最优化函数 DP好题
题意:给定一个图,节点可以放灯,要求用最少的灯覆盖所有的边(每盏灯能覆盖该节点邻接的边),满足条件的同时求该前提下尽量多的被两盏灯照亮的边数 条件二转化为求尽量少的被一盏灯照亮的边数,两个条件都是求m ...
- android 无线调试 [无需数据线][无需root]
无线调试首要条件在同一网段,打开开发者模式 1,打开 5555 端口 使用数据线链接手机,在命令窗口执行:adb tcpip 5555 2,adb 链接手机调试 这时无需数据线了,在命令窗口执行:ad ...
- jenkins显示发送邮件发送成功但是邮箱没收到
jenkins显示发送邮件发送成功但是邮箱没收到 解决方案: 重新配置一下系统管理-系统设置-Extended E-mail Notification
- oracle 基础知识(三)--SCN
一,SCN的介绍 SCN(System Change Number),也就是通常所说的系统改变号或者系统提交号,是数据库中非常重要的一个数据结构. SCN用以标识数据库在某个确切时刻提交的版本 ...