转:ORA-15186: ASMLIB error function = [asm_open], error = [1], 2009-05-24 13:57:38

http://space.itpub.net/471666/viewspace-406996

ORA-15186: ASMLIB error function = [asm_open], error = [1], mesg = [Operation not permitted]

参考 Metalink   Note:398622.1

Subject:    ORA-15186: ASMLIB error function = [asm_open], error = [1], mesg = [Operation not permitted]
     Doc ID:    Note:398622.1    Type:    PROBLEM
     Last Revision Date:    06-MAY-2008    Status:    PUBLISHED

In this Document
  Symptoms
  Cause
  Solution
  References

Applies to:
Oracle Server - Enterprise Edition - Version: 10.1.0
This problem can occur on any platform.
Oracle Database ASM (Automatic Storage Management) instance
Oracle ASMLib
Raw devices
Symptoms
The Oracle Database ASM instance reports ORA-15186 error in the alert.log, for example:

ORA-15186: ASMLIB error function = [asm_open], error = [1], mesg = [Operation not permitted].

The error occurs periodically, most notably during ASM instance startup and as a result of V$ASM_... view queries, as well as during RMAN backup.

Despite the error, however, no adverse affects are observed.

Cause
By default, Oracle Database ASM instance parameter 'ASM_DISKSTRING' is unset and therefore uses a default value of '*'. This means that the ASM instance scans both/dev/raw/and/dev/oracleasm/disks/directories when searching for oracle ASM disks.

When using a combination of oracleasm disks (/dev/oracleasm/disks/*) with raw devices (/dev/raw/*), in particular where some raw devices are not owned by or accessible to the oracle user) as well as ASM instance parameter 'ASM_DISKSTRING' with an unspecified value, error ORA-15186 is likely to occur.

Solution
The solution is to explictly set Oracle ASM instance parameter 'ASM_DISKSTRING' such that it only scans for  oracleasm disks (e.g. with label ORCL:*) or to set the value to scan only intended oracleasm devices known to be oracleasm disks.

Explicitly setting 'ASM_DISKSTRING' is recommended as it increases oracle ASM disk scan performance by restricting the number of devices scanned to only those marked with the default provisioned 'ORCL:' label prefix or scanning only a given subset of devices.

Examples of setting ASM_DISKSTRING parameter include:

SQL> alter system set asm_diskstring='ORCL:*' scope=both;
...

SQL> alter system set asm_diskstring='/dev/raw/raw6,/dev/raw/raw7,/dev/raw/raw8' scope=both;
...

SQL> alter system set asm_diskstring='/dev/mapper/mpath0,/dev/mapper/mpath1,/dev/mapper/mpath2' scope=both;
...

Note: whilst limiting the 'ASM_DISKSTRING' value to a specific list of disks ensures optimal ASM instance scan performance, the parameter value must be modified to include any new devices whenever oracleasm disks are added or removed.

References
Note 391136.1- New ASMLib / oracleasm Disk Gets "header_status=Unknown" - Cannot be Added to Diskgroup
Keywords
AUTOMATIC~STORAGE~MANAGEMENT; RAW~DEVICE; ORACLEASM; ASMLIB;

转:ORA-15186: ASMLIB error function = [asm_open], error = [1], 2009-05-24 13:57:38的更多相关文章

  1. complementary error function

    首先正态分布的概率密度函数为: P{|X-μ|<σ}=2Φ(1)-1=0.6826,  P{|X-μ|<2σ}=2Φ(2)-1=0.9544,  P{|X-μ|<3σ}=2Φ(3)- ...

  2. MySQL 从 5.5 升级到 5.6,启动时报错 [ERROR] Plugin 'InnoDB' init function returned error

    MySQL 从 5.5 升级到 5.6,启动时报错: [ERROR] Plugin 'InnoDB' init function returned error. [ERROR] Plugin 'Inn ...

  3. 【caffe】loss function、cost function和error

    @tags: caffe 机器学习 在机器学习(暂时限定有监督学习)中,常见的算法大都可以划分为两个部分来理解它 一个是它的Hypothesis function,也就是你用一个函数f,来拟合任意一个 ...

  4. MySQL Plugin 'InnoDB' init function returned error

    . . 在MySQL的配置文件中,设定default-table-type=InnoDB,发现MySQL无法正常的启动,错误日志中给出了如下的信息: 150210 18:11:19 mysqld_sa ...

  5. [ERROR] Plugin 'InnoDB' init function returned error

    今天一大早到公司,计划把开发环境的mysql升级到5.7.15,干净关闭系统后,把目录从5.6指向到5.7,一切正常,重新指向5.6启动时,报下列错误: 2016-10-31 08:13:14 869 ...

  6. MySQL Plugin 'InnoDB' init function returned error一例

    早上上班后,测试说演示环境挂了,维护上去看了下,启动报错了: XXXXXX08:30:47 mysqld_safe Starting mysqld daemon with databases from ...

  7. MariaDB报错Plugin 'InnoDB' init function returned error.解决方案

    重新安装MariaDB后,服务一直启动不起来,查看日志有以下错误: InnoDB: No valid checkpoint found. InnoDB: If you are attempting d ...

  8. Mysql drop function xxxx ERROR 1305 (42000): FUNCTION (UDF) xxxx does not exist

    mysql> drop function GetEmployeeInformationByID;ERROR 1305 (42000): FUNCTION (UDF) GetEmployeeInf ...

  9. Gauss error function

    0. error function erf(x)=1π∫−xxe−t2dt" role="presentation">erf(x)=1π−−√∫x−xe−t2dte ...

随机推荐

  1. B树——算法导论(25)

    B树 1. 简介 在之前我们学习了红黑树,今天再学习一种树--B树.它与红黑树有许多类似的地方,比如都是平衡搜索树,但它们在功能和结构上却有较大的差别. 从功能上看,B树是为磁盘或其他存储设备设计的, ...

  2. ASP.NET Core应用的错误处理[3]:ExceptionHandlerMiddleware中间件如何呈现“定制化错误页面”

    DeveloperExceptionPageMiddleware中间件利用呈现出来的错误页面实现抛出异常和当前请求的详细信息以辅助开发人员更好地进行纠错诊断工作,而ExceptionHandlerMi ...

  3. SDWebImage源码解读之SDWebImageDownloaderOperation

    第七篇 前言 本篇文章主要讲解下载操作的相关知识,SDWebImageDownloaderOperation的主要任务是把一张图片从服务器下载到内存中.下载数据并不难,如何对下载这一系列的任务进行设计 ...

  4. 恢复SQL Server被误删除的数据(再扩展)

    恢复SQL Server被误删除的数据(再扩展) 大家对本人之前的文章<恢复SQL Server被误删除的数据> 反应非常热烈,但是文章里的存储过程不能实现对备份出来的日志备份里所删数据的 ...

  5. ifconfig: command not found(CentOS专版,其他的可以参考)

    ifconfig: command not found 查看path配置(echo相当于c中的printf,C#中的Console.WriteLine) echo $PATH 解决方案1:先看看是不是 ...

  6. 使用etree.HTML的编码问题

    title: 使用etree.HTML的编码问题 date: 2015-10-07 17:56:47 categories: [Python] tags: [Python, lxml, Xpath] ...

  7. .net 分布式架构之分布式缓存中间件

    开源git地址: http://git.oschina.net/chejiangyi/XXF.BaseService.DistributedCache 分布式缓存中间件  方便实现缓存的分布式,集群, ...

  8. jsp页面无法识别el表达式的解决方案

    今天在写一个springmvc的小demo时,碰到一个问题,在jsp页面中书写为${user.username}的表达式语言,在浏览器页面中仍然显示为${user.username},说明jsp根本不 ...

  9. Greenplum 的分布式框架结构

    Greenplum 的分布式框架结构 1.基本架构 Greenplum(以下简称 GPDB)是一款典型的 Shared-Nothing 分布式数据库系统.GPDB 拥有一个中控节点( Master ) ...

  10. linux-centos6.5之ssh配置

    查询\安装SSH服务 #rpm -qa |grep ssh 检查是否装了SSH包 #yum install openssh-server 没有的话,安装SSH服务 #chkconfig --list ...