环境:RHEL6.4 + Oracle 11.2.0.3
问题:需求是文件系统迁移到ASM,在安装GI后,运行roothas.pl脚本报错

1.运行root.sh后,按提示运行roothas.pl报错

2.Google搜索得知是缺少compat-libcap1,安装这个包

3.重新运行roothas.pl,按提示重新配置roothas

4.用asmca创建ASM磁盘组成功

1.运行root.sh后,按提示运行roothas.pl报错:

[root@JY-DB mnt]# /u01/app/11.2.0/grid/crs/install/roothas.pl
Using configuration parameter file: /u01/app/11.2./grid/crs/install/crsconfig_params
User ignored Prerequisites during installation
/u01/app/11.2./grid/bin/crsctl query crs activeversion ... failed rc= with message:
/u01/app/11.2./grid/bin/crsctl.bin: error while loading shared libraries: libcap.so.: cannot open shared object file: No such file or directory Improper Oracle Grid Infrastructure configuration found on this host
Deconfigure the existing cluster configuration before starting
to configure a new Grid Infrastructure
run '/u01/app/11.2.0/grid/crs/install/roothas.pl -deconfig'
to configure existing failed configuration and then rerun root.sh
[root@JY-DB mnt]#

2.Google搜索得知是缺少compat-libcap1,安装这个包

[root@JY-DB lib]# yum install compat-libcap1
Loaded plugins: product-id, subscription-manager
This system is not registered to Red Hat Subscription Management. You can use subscription-manager to register.
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package compat-libcap1.x86_64 :1.10- will be installed
--> Finished Dependency Resolution Dependencies Resolved ======================================================================================================================================================================
Package Arch Version Repository Size
======================================================================================================================================================================
Installing:
compat-libcap1 x86_64 1.10- ISO k Transaction Summary
======================================================================================================================================================================
Install Package(s) Total download size: k
Installed size: k
Is this ok [y/N]: y
Downloading Packages:
Running rpm_check_debug
Running Transaction Test
Transaction Test Succeeded
Running Transaction
Installing : compat-libcap1-1.10-.x86_64 /
Verifying : compat-libcap1-1.10-.x86_64 / Installed:
compat-libcap1.x86_64 :1.10- Complete!
[root@JY-DB lib]# rpm -qa |grep compat-libcap1
compat-libcap1-1.10-.x86_64

3.重新运行roothas.pl,按提示重新配置roothas

[root@JY-DB lib]# /u01/app/11.2.0/grid/crs/install/roothas.pl
Using configuration parameter file: /u01/app/11.2./grid/crs/install/crsconfig_params
User ignored Prerequisites during installation
Improper Oracle Grid Infrastructure configuration found on this host
Deconfigure the existing cluster configuration before starting
to configure a new Grid Infrastructure
run '/u01/app/11.2.0/grid/crs/install/roothas.pl -deconfig'
to configure existing failed configuration and then rerun root.sh
[root@JY-DB lib]# /u01/app/11.2.0/grid/crs/install/roothas.pl -deconfig
Using configuration parameter file: /u01/app/11.2./grid/crs/install/crsconfig_params
Oracle Restart stack is not active on this node
Restart the SIHA stack (use /u01/app/11.2./grid/bin/crsctl start has) and retry
Failed to write the checkpoint:'' with status:FAIL.Error code is
Failed to verify HA resources
[root@JY-DB lib]# /u01/app/11.2.0/grid/bin/crsctl status res -t
CRS-: Could not contact Oracle High Availability Services
CRS-: Command Status failed, or completed with errors. [root@JY-DB lib]# /u01/app/11.2.0/grid/bin/crsctl start has
CRS-: Oracle High Availability Services startup failed.
CRS-: Command Start failed, or completed with errors.
[root@JY-DB lib]# /u01/app/11.2.0/grid/crs/install/roothas.pl
Using configuration parameter file: /u01/app/11.2./grid/crs/install/crsconfig_params
User ignored Prerequisites during installation
Improper Oracle Grid Infrastructure configuration found on this host
Deconfigure the existing cluster configuration before starting
to configure a new Grid Infrastructure
run '/u01/app/11.2.0/grid/crs/install/roothas.pl -deconfig'
to configure existing failed configuration and then rerun root.sh [root@JY-DB config]# /u01/app/11.2.0/grid/crs/install/roothas.pl -h
Option hahome requires an argument
Usage:
roothas.pl [-verbose] [-upgrade | -patch]
[-paramfile <parameter-file>] [-deconfig] [-force]
[-unlock [-hahome <path to Oracle Restart home>]] Options:
-verbose Run this script in verbose mode
-upgrade Oracle HA is being upgraded from previous version
-patch Oracle HA is being upgraded to a patch version
-paramfile Complete path of file specifying HA parameter values
-deconfig To deconfigure Oracle Restart
-force To deconfigure Oracle Restart when configuration
is in a good condition
-unlock Unlock Oracle Restart home
-hahome Complete path of Oracle HA home If neither -upgrade nor -patch is supplied, a new install is performed To see the full manpage for this program, execute:
perldoc roothas.pl [root@JY-DB config]# /u01/app/11.2.0/grid/crs/install/roothas.pl -verbose -deconfig -force
Using configuration parameter file: /u01/app/11.2./grid/crs/install/crsconfig_params
CRS-: Could not contact Oracle High Availability Services
CRS-: Command Stop failed, or completed with errors.
CRS-: Could not contact Oracle High Availability Services
CRS-: Command Delete failed, or completed with errors.
CRS-: Unable to connect to OHAS
CRS-: Command Stop failed, or completed with errors.
Failure in execution (rc=-, , 没有那个文件或目录) for command /etc/init.d/ohasd deinstall
Successfully deconfigured Oracle Restart stack
[root@JY-DB config]# /u01/app/11.2.0/grid/root.sh
Performing root user operation for Oracle 11g The following environment variables are set as:
ORACLE_OWNER= grid
ORACLE_HOME= /u01/app/11.2./grid Enter the full pathname of the local bin directory: [/usr/local/bin]:
The contents of "dbhome" have not changed. No need to overwrite.
The contents of "oraenv" have not changed. No need to overwrite.
The contents of "coraenv" have not changed. No need to overwrite. Entries will be added to the /etc/oratab file as needed by
Database Configuration Assistant when a database is created
Finished running generic part of root script.
Now product-specific root actions will be performed. To configure Grid Infrastructure for a Stand-Alone Server run the following command as the root user:
/u01/app/11.2./grid/perl/bin/perl -I/u01/app/11.2./grid/perl/lib -I/u01/app/11.2./grid/crs/install /u01/app/11.2./grid/crs/install/roothas.pl To configure Grid Infrastructure for a Cluster execute the following command:
/u01/app/11.2./grid/crs/config/config.sh
This command launches the Grid Infrastructure Configuration Wizard. The wizard also supports silent operation, and the parameters can be passed through the response file that is available in the installation media. [root@JY-DB config]# /u01/app/11.2.0/grid/perl/bin/perl -I/u01/app/11.2.0/grid/perl/lib -I/u01/app/11.2.0/grid/crs/install /u01/app/11.2.0/grid/crs/install/roothas.pl
Using configuration parameter file: /u01/app/11.2./grid/crs/install/crsconfig_params
User ignored Prerequisites during installation
LOCAL ADD MODE
Creating OCR keys for user 'grid', privgrp 'oinstall'..
Operation successful.
LOCAL ONLY MODE
Successfully accumulated necessary OCR keys.
Creating OCR keys for user 'root', privgrp 'root'..
Operation successful.
CRS-: Node jy-db successfully pinned.
Adding Clusterware entries to upstart jy-db // :: /u01/app/11.2./grid/cdata/jy-db/backup_20140719_182302.olr
Successfully configured Oracle Grid Infrastructure for a Standalone Server
[root@JY-DB config]#
[root@JY-DB config]#
[root@JY-DB config]# ps -ef |grep has
grid Jul18 pts/ :: /u01/app/11.2./grid/jdk/jre/bin/java -Doracle.installer.not_bootstrap=true -DORACLE_HOME=/u01/app/11.2./grid -Dsun.java2d.font.DisableAlgorithmicStyles=true -DDISPLAY=localhost:11.0 -DIGNORE_PREREQS= -DJDBC_PROTOCOL=thin -mx128m -classpath /u01/app/11.2./grid/assistants/asmca/jlib/asmca.jar:/u01/app/11.2./grid/assistants/jlib/assistantsCommon.jar:/u01/app/11.2./grid/jlib/ewt3.jar:/u01/app/11.2./grid/jlib/ewtcompat-3_3_15.jar:/u01/app/11.2./grid/jlib/share.jar:/u01/app/11.2./grid/jlib/help4.jar:/u01/app/11.2./grid/jlib/jewt4.jar:/u01/app/11.2./grid/jlib/oracle_ice5.jar:/u01/app/11.2./grid/jlib/kodiak.jar:/u01/app/11.2./grid/lib/xmlparserv2.jar:/u01/app/11.2./grid/jlib/orai18n.jar:/u01/app/11.2./grid/jlib/ldapjclnt11.jar:/u01/app/11.2./grid/jlib/netcfg.jar:/u01/app/11.2./grid/jlib/ojmisc.jar:/u01/app/11.2./grid/jlib/oraclepki103.jar:/u01/app/11.2./grid/jlib/opm.jar:/u01/app/11.2./grid/jdbc/lib/ojdbc5.jar:/u01/app/11.2./grid/jlib/srvm.jar:/u01/app/11.2./grid/jlib/srvmhas.jar:/u01/app/11.2./grid/jlib/srvmasm.jar:/u01/app/11.2./grid/classes:/u01/app/11.2./grid/jlib/oemlt.jar:/u01/app/11.2./grid/jlib/emca.jar:/u01/app/11.2./grid/sysman/jlib/emCORE.jar:/u01/app/11.2./grid/oc4j/j2ee/home/oc4j.jar:/u01/app/11.2./grid/oc4j/j2ee/home/db_oc4j_deploy.jar:/u01/app/11.2./grid/jlib/emConfigInstall.jar:/u01/app/11.2./grid/oui/jlib/OraInstaller.jar:/u01/app/11.2./grid/oui/jlib/OraPrereq.jar:/u01/app/11.2./grid/inventory/prereqs/oui/OraPrereqChecks.jar:/u01/app/11.2./grid/oui/jlib/OraPrereqChecks.jar:/u01/app/11.2./grid/oui/jlib/OraCheckPoint.jar:/u01/app/11.2./grid/jlib/cvu.jar:/u01/app/11.2./grid/assistants/asmca/doc/asmcahelp.jar:/u01/app/11.2./grid/oc4j/j2ee/home/lib/http_client.jar oracle.sysman.assistants.usmca.Usmca
grid : ? :: /u01/app/11.2./grid/bin/ohasd.bin reboot
grid : ? :: /u01/app/11.2./grid/bin/ohasd.bin reboot
grid : ? :: /u01/app/11.2./grid/bin/ohasd.bin reboot
root : ? :: /bin/sh /etc/init.d/init.ohasd run
grid : ? :: /u01/app/11.2./grid/bin/ohasd.bin reboot
root : pts/ :: grep has

4.用asmca创建ASM磁盘组成功

[root@JY-DB config]# su - grid
sq[grid@JY-DB ~]$ sqlplus / as sysdba SQL*Plus: Release 11.2.0.3. Production on Sat Jul :: Copyright (c) , , Oracle. All rights reserved. Connected to an idle instance. SQL> exit
Disconnected
[grid@JY-DB ~]$ echo $ORACLE_SID
+ASM
--此时正在图形界面创建ASM磁盘组中。
[grid@JY-DB ~]$ sqlplus / as sysdba SQL*Plus: Release 11.2.0.3. Production on Sat Jul :: Copyright (c) , , Oracle. All rights reserved. Connected to:
Oracle Database 11g Enterprise Edition Release 11.2.0.3. - 64bit Production
With the Automatic Storage Management option SQL> select status, instance_name from v$instance;
select status, instance_name from v$instance
*
ERROR at line :
ORA-: connection lost contact
Process ID:
Session ID: Serial number: SQL> exit
Disconnected from Oracle Database 11g Enterprise Edition Release 11.2.0.3. - 64bit Production
With the Automatic Storage Management option --创建ASM磁盘组成功后再看+ASM实例的状态
[grid@JY-DB ~]$ sqlplus / as sysdba SQL*Plus: Release 11.2.0.3. Production on Sat Jul :: Copyright (c) , , Oracle. All rights reserved. Connected to:
Oracle Database 11g Enterprise Edition Release 11.2.0.3. - 64bit Production
With the Automatic Storage Management option SQL> select status, instance_name from v$instance; STATUS INSTANCE_NAME
------------ ----------------
STARTED +ASM SQL>
SQL> desc v$asm_diskgroup
Name Null? Type
----------------------------------------- -------- ----------------------------
GROUP_NUMBER NUMBER
NAME VARCHAR2()
SECTOR_SIZE NUMBER
BLOCK_SIZE NUMBER
ALLOCATION_UNIT_SIZE NUMBER
STATE VARCHAR2()
TYPE VARCHAR2()
TOTAL_MB NUMBER
FREE_MB NUMBER
HOT_USED_MB NUMBER
COLD_USED_MB NUMBER
REQUIRED_MIRROR_FREE_MB NUMBER
USABLE_FILE_MB NUMBER
OFFLINE_DISKS NUMBER
COMPATIBILITY VARCHAR2()
DATABASE_COMPATIBILITY VARCHAR2()
VOTING_FILES VARCHAR2() SQL> select GROUP_NUMBER, NAME, STATE, TOTAL_MB, FREE_MB from v$asm_diskgroup; GROUP_NUMBER NAME STATE TOTAL_MB FREE_MB
------------ ------------------------------ ----------- ---------- ----------
DATA MOUNTED SQL>

Oracle 11g安装GI后,运行roothas.pl脚本报错libcap.so.1找不到的更多相关文章

  1. Oracle 11g 数据库 shutdown 后立即执行 startup mount 报错的解决办法

    最新文章:Virson's Blog 今天在配置Goldengate时Capture进程提示未开启归档日志,然后立即用sys用户登录orcl数据库,然后执行了“shutdown immediate”命 ...

  2. 借鉴别人的Oracle 11g安装和卸载图文教程

    Oracle 11g安装 1.解压下载的包,然后进入包内,点击setup.exe开始安装 . 2.出现如下:一般把那个小对勾取消,点击下一步进行, 弹出下图这个后点‘是' 3.下图后,选择创建和配置数 ...

  3. Oracle 11g安装步骤以及Oracle11g创建表空间和用户,并授权

    Oracle 11g安装步骤详解 一.Oracle 下载 注意Oracle分成两个文件,下载完后,将两个文件解压到同一目录下即可. 路径名称中,最好不要出现中文,也不要出现空格等不规则字符. 官方下地 ...

  4. Linux上Oracle 11g安装步骤图解

    Oracle 11g下载地址: http://www.oracle.com/technetwork/database/enterprise-edition/downloads/index.html 选 ...

  5. Centos 下oracle 11g 安装部署及手动建库过程

    Oracle 11g 手动建库,在虚拟环境中,不使用DBCA工具进行创建数据库 1.Linux环境的基本配置 2.ip  10.11.30.60 3.Oracle 11g安装过程 ---------- ...

  6. Oracle 11g安装攻略

    Oracle 11g安装攻略 本攻略是以Win7-32位系统中安装Oracle 11g为示例,安装前大家需要确认以下几点: 你的内存足够大且没有问题,因为Oracle非常吃内存. 你的系统已经激活. ...

  7. SUSE11虚拟机安装与Oracle 11g安装

    SUSE11虚拟机安装与Oracle 11g安装 本文中所需所有参数均位于文末附录中 新建虚拟机,选择SUSE11 64位 启动虚拟机后,选择第二项安装 选择语言 跳过CD检查 选择全新安装 选择默认 ...

  8. centOS学习part5:oracle 11g安装之环境准备

    0 前几篇依次向大家介绍了centOS的基本安装以及常用软件的安装配置,接下来我们将挑战的是oracle 11g的安装配置.与之前安装的软件不一样的是,由于oracle并非开源免费软件(需要向orac ...

  9. Oracle 11g 安装

    1.Oracle 11g安装: http://www.cnblogs.com/qianyaoyuan/archive/2013/05/05/3060471.html 2.安装完Oracle数据库,给s ...

随机推荐

  1. Smart3D系列教程7之 《手动配置S3C索引加载全部的瓦片数据》

    一.前言 迄今为止,Wish3D已经出品推出了6篇系列教程,从倾斜摄影的原理方法.采集照片的技巧.Smart3D各模块的功能应用.小物件的照片重建.大区域的地形重建到DSM及正射影像的处理生产,立足于 ...

  2. LabVIEW 吸星大法 - 看见的好东西都是我的(下篇)

    前言 写了多年的LabVIEW程序,你是否面临这样的问题 总是在做一些重复的工作,感觉很没有意思: 总在不停的写代码,做类似的控件,实现相同的功能,丝毫没有成就感: 总在天加班,没有时间去提高自己; ...

  3. MySQL Can't connect to MySQL server on 'localhost' (10061)

    run > services.msc > rightclick MySQL > properties >start 搞定

  4. 四则运算项目git统计

    GitHub统计 1.Git文档目录 图 1文档结构预览 2.Git提交进度图 图 2 9月12日-10月3日 图 3 10月3日-10月14日 图 4 10月14日-10月21日 图 5 10月21 ...

  5. 利用js来实现文字的滚动(也就是我们常常见到的新闻版块中的公示公告)

    首先先看一下大致效果图(因为是动态的,在页面无法显示出来) 具体的实现代码如下: 1.首先是css代码: <style type="text/css"> body,ul ...

  6. reactjs 接入数据模型以及markdown语法的支持

    页面如下: reactjs 数据接入,直接定义数据(json),如下: reactjs 数据接入,从服务器抓取数据(json),如下:  

  7. Android课程---序列化与反序列化(转)

    ava序列化与反序列化是什么?为什么需要序列化与反序列化?如何实现Java序列化与反序列化?本文围绕这些问题进行了探讨. 1.Java序列化与反序列化 Java序列化是指把Java对象转换为字节序列的 ...

  8. PHP的FastCGI

    CGI全称是“通用网关接口”(Common Gateway Interface), 它可以让一个客户端,从网页浏览器向执行在Web服务器上的程序请求数据. CGI描述了客户端和这个程序之间传输数据的一 ...

  9. io.js入门(二)—— 所支持的ES6(上)

    io.js的官网上有专门介绍其所支持的ES6特性的页面(点我查看),上面介绍到,相比nodeJS,io.js已从根本上支持了新版V8引擎上所支持的ES6特性,无需再添加任何运行时标志(如 --harm ...

  10. jdbc在mysql下一次执行多条sql脚本

    默认连接mysql的时候一次只能执行一条sql.要批量执行sql需要在jdbcUrl中增加“allowMultiQueries=true”参数,完整jdbcUrl如下:  jdbc:mysql://l ...