转自:http://worms.blog.51cto.com/969144/1293265

Sqlplus 登陆oracle时报错ORA-12560:TNS: 协议适配器错误

如下:C:\Users\Administrator>setORACLE_SID=DDBC

C:\Users\Administrator>SQLPLUS/ AS SYSDBA

SQL*Plus:Release 11.2.0.1.0 Production on 星期一 9月 9 16:41:392013

Copyright (c)1982, 2010, Oracle. All rights reserved.

ERROR:
ORA-12560:TNS: 协议适配器错误

请输入用户名:

先查看下oracle官方对12560的解释:

ORA-12560:TNS:protocol adapter error
Cause: A generic protocol adapter error occurred.

Action: Check addresses used for proper protocolspecification. Before reporting this error, look at the error stack and checkfor lower level transport errors. For further details, turn on tracing andreexecute the operation. Turn off tracing when the operation is complete.

那么在看看当前的数据库,因为数据库服务器上同时装有oracle client端,所以,setORACLE_SID=sid时候,应该是到了client端的目录中,那么可以确认下,直接到server端的目录中查看:

C:\Users\Administrator>cdC:\app\Administrator\product\11.2.0\dbhome_1\BIN

C:\app\Administrator\product\11.2.0\dbhome_1\BIN>setORACLE_SID=DDBC

C:\app\Administrator\product\11.2.0\dbhome_1\BIN>sqlplus/ as sysdba

SQL*Plus:Release 11.2.0.1.0 Production on 星期一 9月 9 16:47:002013

Copyright (c)1982, 2010, Oracle. All rights reserved.

连接到:
OracleDatabase 11g Enterprise Edition Release 11.2.0.1.0 - 64bit Production
With thePartitioning, OLAP, Data Mining and Real Application Testing options

SQL> selectstatus from v$instance;

STATUS
------------
OPEN

SQL>
这就说明,这是在sqlplus登陆时用的是client端登陆的,可是在环境变量administrator中设置server端的变量,但是还是不行,结果查看环境变量SET:
Path=E:\app\Administrator\product\11.2.0\client_1\bin;C:\app\Administrator\product\11.2.0\dbhome_1\bin;………………
原来是因为在系统中设置了path,其优先级高,所以才会出现这种现象,修改后就可以了。

另外要说的是在网上搜索ORA-1256090%的都是那4步,但是99%没有解决问题。所以在针对问题上,还要细心的思考,才能找到解决问题的思路。

Sqlplus 登陆oracle时报错ORA-12560:TNS: 协议适配器错误

如下:C:\Users\Administrator>setORACLE_SID=DDBC

C:\Users\Administrator>SQLPLUS/ AS SYSDBA

SQL*Plus:Release 11.2.0.1.0 Production on 星期一 9月 9 16:41:392013

Copyright (c)1982, 2010, Oracle. All rights reserved.

ERROR:
ORA-12560:TNS: 协议适配器错误

请输入用户名:

先查看下oracle官方对12560的解释:

ORA-12560:TNS:protocol adapter error
Cause: A generic protocol adapter error occurred.

Action: Check addresses used for proper protocolspecification. Before reporting this error, look at the error stack and checkfor lower level transport errors. For further details, turn on tracing andreexecute the operation. Turn off tracing when the operation is complete.

那么在看看当前的数据库,因为数据库服务器上同时装有oracle client端,所以,setORACLE_SID=sid时候,应该是到了client端的目录中,那么可以确认下,直接到server端的目录中查看:

C:\Users\Administrator>cdC:\app\Administrator\product\11.2.0\dbhome_1\BIN

C:\app\Administrator\product\11.2.0\dbhome_1\BIN>setORACLE_SID=DDBC

C:\app\Administrator\product\11.2.0\dbhome_1\BIN>sqlplus/ as sysdba

SQL*Plus:Release 11.2.0.1.0 Production on 星期一 9月 9 16:47:002013

Copyright (c)1982, 2010, Oracle. All rights reserved.

连接到:
OracleDatabase 11g Enterprise Edition Release 11.2.0.1.0 - 64bit Production
With thePartitioning, OLAP, Data Mining and Real Application Testing options

SQL> selectstatus from v$instance;

STATUS
------------
OPEN

SQL>
这就说明,这是在sqlplus登陆时用的是client端登陆的,可是在环境变量administrator中设置server端的变量,但是还是不行,结果查看环境变量SET:
Path=E:\app\Administrator\product\11.2.0\client_1\bin;C:\app\Administrator\product\11.2.0\dbhome_1\bin;………………
原来是因为在系统中设置了path,其优先级高,所以才会出现这种现象,修改后就可以了。

另外要说的是在网上搜索ORA-1256090%的都是那4步,但是99%没有解决问题。所以在针对问题上,还要细心的思考,才能找到解决问题的思路。

[转]ORA-12560: TNS: 协议适配器错误的更多相关文章

  1. Oracle用imp导入dmp 提示遇到 ORACLE 错误 12560 TNS: 协议适配器错误 解决方法

    用imp命令导入dmp文件时提示以下错误: IMP-00058: 遇到 ORACLE 错误 12560 : ORA-12560: TNS: 协议适配器错误 : IMP-00000: 未成功终止导入 : ...

  2. TNS-12541: TNS: 无监听程序 TNS-12560: TNS: 协议适配器错误 TNS-00511: 无监听程序

    文章转自:http://www.luocs.com/archives/464.html 此文版权归作者 – yaogang所有,转载请注明yaogang©www.luocs.com. Luocs说:这 ...

  3. TNS-12560: TNS: 协议适配器错误

    TNS-12560: TNS: 协议适配器错误   Microsoft Windows [版本 5.2.3790] (C) 版权所有 1985-2003 Microsoft Corp. C:\Docu ...

  4. ORA-12560: TNS: 协议适配器错误的解决方法

    ORA-12560: TNS: 协议适配器错误的解决方法 造成ORA-12560: TNS: 协议适配器错误的问题的原因有三个: 1.监听服务没有起起来.windows平台个一如下操作:开始---程序 ...

  5. 安装完ODTwithODAC112012,出现ORA-12560:TNS:协议适配器错误

    参考:http://blog.csdn.net/tan_yixiu/article/details/6762357 操作系统:windows2008 Enterprise 64位 开发工具:VS201 ...

  6. oracle:ora-12560 tns 协议适配器错误

    今天新安装了一个oracle server,实例启动了,监听状态也正常. [oracle@db ~]$ lsnrctl status LSNRCTL for Linux: Version 11.2.0 ...

  7. ORACLE中的Net Configuration Assistant 点击后无反应, sqlplus登录数据库提示Oracle11g ORA-12560: TNS: 协议适配器错误

    首先是对于点击无反应问题: 如果是客户端下的Net Configuration Assistant可用,而服务器端的Net Configuration Assistant等工具不可用的原因如下. 环境 ...

  8. ORA-12560: TNS: 协议适配器错误 ORA-12154: TNS: 无法解析指定的连接标识符

    在国庆期间,数据库存储过程在通过dblink跨库调用存储过程时,错误日志中记录了ORA-12560: TNS: 协议适配器错误的异常日志. 偶尔用PL/SQL连接数据库时,又频繁提示:ORA-1215 ...

  9. 安装完ODAC,出现ORA-12560:TNS:协议适配器错误 12541 无监听程序的解决

    进入系统环境变量设置,查看Path路径,发现D:\oracle\product\11.2.0\client_1等路径放到了oracle11g数据库路径前面,将新加入的路径置后即可解决ORA-12560 ...

随机推荐

  1. Go 缓冲信道和非缓冲信道

    非缓冲信道是一个进一个出,再一个进再一个出,信道内是不保存数据的 缓冲信道是可以很多个依次进去,存储在信道里,然后一个一个的按次序取出来. 不过缓冲信道如果超过了预期的存入个数,会发生信道阻塞,只有把 ...

  2. ubuntu-docker入门到放弃(一)docker的安装

    基于ubuntu14.04系统 安装参考官网:https://docs.docker.com 1.首先检查是否安装过docker,如果安装过,卸载: sudo apt-get remove docke ...

  3. [蓝桥杯]ALGO-81.算法训练_动态数组使用

    从键盘读入n个整数,使用动态数组存储所读入的整数,并计算它们的和与平均值分别输出.要求尽可能使用函数实现程序代码.平均值为小数的只保留其整数部分. 样例输入: 样例输出: 样例输入: 样例输出: 题目 ...

  4. vue-router总结

    之前写过一篇关于vue-router的文章,主要是介绍怎么结合cli2在项目中使用vue-router,比较的简单,今天想结合cli3来总结一下vue-router的具体用法. cli3 在介绍vue ...

  5. python-selenium并发执行测试用例(方法一 各模块每一条并发执行)

    总执行代码: # coding=utf-8import unittest,os,timeimport HTMLTestRunnerimport threadingimport syssys.path. ...

  6. HDOJ 2001 ASCII码排序

    #include<set> #include<iostream> using namespace std; int main() { char a, b, c; while ( ...

  7. 事件之父View和子view的点击事件的执行过程

    Android中的事件类型分为按键事件和屏幕触摸事件,Touch事件是屏幕触摸事件的基础事件,有必要对它进行深入的了解. 一个最简单的屏幕触摸动作触发了一系列Touch事件:ACTION_DOWN-& ...

  8. 智行火车票免费加速到VIP最高速抢票(不用朋友积攒或者购买加速包)

    更新: 2018.11.07, 昨天我买火车票,已经不行了,这个bug已经没有了,被修复了, 望大家知悉!!! 智行火车票免费加速到VIP最高速抢票(不用朋友积攒或者购买加速包) 1)下过单后选择抢到 ...

  9. [UE4]世界坐标、本地坐标

    本地坐标 世界坐标

  10. Postgres 主从复制搭建步骤

    系统版本: CentOS Linux release 7.5.1804 (Core) 数据库 psql (PostgreSQL) 10.5 2台机器ip : 172.17.0.3 /172.17.0. ...