windows 开启 nginx 监听80 端口 以及 禁用 http 服务后,无法重启 HTTP 服务,提示 系统错误 123,文件目录、卷标出错
1. 正常情况直接运行 start nginx.exe 不能开启成功,因为 80 端口被占用。提示: bind() to 0.0.0.0:80 failed (10013: An attempt was made to access a socket in a way forbidden by its access permissions) 可以查看 ngxin 的日志,Logs/errors.log 文件
2. 查看 端口占用情况:netstat -ano | findstr 0.0.0.0:80 发现是 PID=4 ,这个是系统进程中的 http 服务。所以需要关闭 HTTP服务
3. 管理员 cmd: sc config http start= disabled (注意等号右侧的空格)。
这一项主要修改的实质地方是注册表:HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\HTTP
修改前:
修改后:
有的电脑运行完命令可能 imagePath,也会被修改掉:例如变成这样:\SystemRoot\\SystemRoot\\SystemRoot\system32\drivers\HTTP.sys 这个路径显然是错误的,这个键主要关联的是 system32\drivers\HTTP.sys 这个文件。所以在开启 http 服务的时候会遇到 系统错误 123,文件目录、卷标出错
4. 重启电脑
5. 开启 ngixn ,start nginx.exe ,会提示 开启成功
6. 然后 开启 http 服务,否则 IIS 不能使用,命令:sc config http start=demand & net start http
7. 打开 IIS 修改所有原来绑定 80 端口的网站,更换为 8001.。..等等随便
8. 打开 服务(services.msc)找到 World Wide Web Publishing Service 这个服务。点击启动。(这个服务就是 IIS 的主服务) 如果启动失败,提示缺少 依赖或组,那么右键属性查看依赖的服务是否都开启成功。 这个服务 依赖于系统 HTTP 服务, 可能在依赖列表没有,这就是第6步必须操作的原因。
或者也可以从 ”服务器“这个软件进行操作,开启 W3SVC 服务 和 IIS-ADMIN。(这个可选把?)
9. 这样就实现了 windows 中ngixn和IIS 共存,然后使用 ngixn 监听80 然后转发到不同端口进行处理。
可能会遇到的问题:
1. 配置好的电脑突然重启,这时候只要 start nginx.exe 然后 net start http 服务 然后 启动 W3SVC 服务
2. 多次运行了 sc config http start= disabled 这个命令,导致注册表错乱。 demand 对应的注册表 Start 项的 3, disabled 对应 4.
3. 还有一种解决IIS占用 80为题就是,直接打开 IIS 找到 绑定 80 端口的网站,点击右侧绑定,修改端口,然后保存重启。就 不占用了。
参考网址:
https://blog.csdn.net/wh_forever/article/details/51734244
https://blog.csdn.net/u010792238/article/details/22661767
windows 开启 nginx 监听80 端口 以及 禁用 http 服务后,无法重启 HTTP 服务,提示 系统错误 123,文件目录、卷标出错的更多相关文章
- 【转载】windows 开启 nginx 监听80 端口 以及 禁用 http 服务后,无法重启 HTTP 服务,提示 系统错误 123,文件目录、卷标出错
https://www.cnblogs.com/TianyuSu/p/9509873.html location / { proxy_set_header Host $Host; proxy_set_ ...
- windows下nodejs监听80端口
windows下nodejs监听80端口时提示端口被占用报错,解决方案如下: 1.cmd---netstat -ano查看是什么程序占用了80端口: 2.控制面板--管理工具--服务--停止 SQL ...
- Linux centosVMware 配置Tomcat监听80端口、配置Tomcat虚拟主机、Tomcat日志
一.配置Tomcat监听80端口 关闭tomcat报错 [root@davery src]# /usr/local/tomcat/bin/shutdown.sh 重装tomcat即可 vim /usr ...
- 配置Tomcat监听80端口、配置Tomcat虚拟主机、Tomcat日志
6月27日任务 16.4 配置Tomcat监听80端口16.5/16.6/16.7 配置Tomcat虚拟主机16.8 Tomcat日志扩展邱李的tomcat文档 https://www.linuser ...
- 【网络通信】服务器端Socket监听80端口,建立连接传输数据时也是使用的80端口么?
1. 服务器端Socket监听80端口,建立连接传输数据时也是使用的80端口么? 答:对.建立连接时服务器会分配一个新的Socket,但是用的源端口号还是80端口.套接字是由协议类型.源IP.目的IP ...
- Tomcat介绍、安装jdk、安装Tomcat、配置Tomcat监听80端口
1.Tomcat介绍 2.安装jdk下载:wget -c http://download.oracle.com/otn-pub/java/jdk/10.0.1+10/fb4372174a714e6b8 ...
- 配置Tomcat监听80端口 配置Tomcat虚拟主机 Tomcat日志
配置Tomcat监听80端口 • vim /usr/local/tomcat/conf/server.xml Connector port=" protocol="HTTP/1.1 ...
- nginx监听相同端口,根据域名请求不同的server
nginx监听相同端口,根据域名请求不同的server 学习了:https://blog.csdn.net/liaosiqian/article/details/54861270 注意其中用的是rew ...
- 普通用户从非80端口启动tomcat,通过端口转发监听80端口
linux下小于1024的端口都需要root去绑定. root权限启动tomcat是不明智的,可以使用非root权限启动tomcat监听8080端口,然后利用端口转发实现对80端口的监听. 端口转发: ...
随机推荐
- 学习总结(一)java web连接池
大家都知道,在访问数据库时要与数据库建立连接.在jdbc中,用户与数据库建立连接后,取完数据或操作完数据后,就会断开这个连接.当下次还要访问数据库时,就会重新创建连接.这样很浪费资源,尤其是网页上有数 ...
- 初识Socket通信:基于TCP和UDP协议学习网络编程
学习笔记: 1.基于TCP协议的Socket网络编程: (1)Socket类构造方法:在客户端和服务器端建立连接 Socket s = new Socket(hostName,port);以主机名和端 ...
- Thrift笔记(六)--单端口 多服务
多个服务,使用监听一个端口.先上一个demo Test.thrift namespace java com.gxf.thrift enum RequestType { SAY_HELLO, //问好 ...
- 设计模式之职责链模式(JAVA实现)
学习netty框架时,看到有人说netty用到了设计模式的职责链模式,学习一下职责链模式,主要参考大话设计模式. 主要场景: 小菜想要加薪,向经理提出加薪请求,经理没有权限,经理交由总监处理,总监也没 ...
- 1.HTML小结
HTML 基本文档 <!DOCTYPE html> <html> <head> <meta charset="UTF-8"> < ...
- vuejs源码摘抄(二)
创建一个用来观察对象的observe类,这个类会附加在被观察的对象上,并且把被观察对象的属性值转换成getter/setter,同时,收集依赖和分发更新,实现代码如下: /* * not type c ...
- PLSQL Developer中几个功能
1,登录后默认自动选中My Objects 默认情况下,PLSQL Developer登录后,Brower里会选择All objects,如果你登录的用户是dba,要展开tables目录,正常情况都需 ...
- matlab练习程序(单源最短路径Dijkstra)
图的相关算法也算是自己的一个软肋了,当年没选修图论也是一大遗憾. 图像处理中,也有使用图论算法作为基础的相关算法,比如图割,这个算法就需要求最大流.最小割.所以熟悉一下图论算法对于图像处理还是很有帮助 ...
- SharePoint中遇到Timeout
使用SharePoint时会遇到不止一种的timeout(即超时)错误. 如果遇到了timeout, 该怎么区分呢? 大致上SharePoint可以控制和影响的timeout地方如下: 1. Shar ...
- 2014-2015 ACM-ICPC East Central North America Regional Contest (ECNA 2014) A、Continued Fractions 【模拟连分数】
任意门:http://codeforces.com/gym/100641/attachments Con + tin/(ued + Frac/tions) Time Limit: 3000/1000 ...