OGG-00446

2019-02-12T14:57:57.668+0800 ERROR OGG-00446 Oracle GoldenGate Delivery for MySQL, r1.prm: .
2019-02-12T14:57:57.668+0800 ERROR OGG-01668 Oracle GoldenGate Delivery for MySQL, r1.prm: PROCESS ABENDING.
2019-02-12T14:59:24.221+0800 INFO OGG-00987 Oracle GoldenGate Command Interpreter for MySQL: GGSCI command (root): info r1 detail.

GGSCI (dbwuliao02 DBLOGIN as dbamng_wuliao) > info r1 detail

REPLICAT   R1        Last Started -- :   Status ABENDED
Checkpoint Lag :: (updated :: ago)
Log Read Checkpoint File /data/ogg/dirdat/r1000000001
-- ::03.590825 RBA Current Log BSN value: (no data) Last Committed Transaction CSN value: (no data) Extract Source Begin End /data/ogg/dirdat/r1000000001 * Initialized * -- :
/data/ogg/dirdat/r1000000000 * Initialized * First Record Current directory /data/ogg Report file /data/ogg/dirrpt/R1.rpt
Parameter file /data/ogg/dirprm/r1.prm
Checkpoint file /data/ogg/dirchk/R1.cpr
Checkpoint table ad_dianjing.checkpoint
Process file /data/ogg/dirpcs/R1.pcr
Error log /data/ogg/ggserr.log

实际上这个OGG年前做了进程中断重新同步操作,只处理了抽取与推送进程,没有处理这个复制进程;下面重新指定复制进程的起点,以可重复执行的方式重新启动复制进程后,复制进程恢复正常

alter replicat r1 extseqno 3, extrba 0
start r1 NOFILTERDUPTRANSACTIONS

OGG-01004

2019-02-12T15:25:45.543+0800 WARNING OGG-01004 Oracle GoldenGate Delivery for MySQL, r1.prm: Aborted grouped transaction on vodb.test, Database error 1062 ([SQL error 1062]Duplicate entry '5451326' for key 'PRIMARY').
2019-02-12T15:25:45.543+0800 WARNING OGG-01003 Oracle GoldenGate Delivery for MySQL, r1.prm: Repositioning to rba 2235 in seqno 1.
2019-02-12T15:25:45.543+0800 WARNING OGG-01154 Oracle GoldenGate Delivery for MySQL, r1.prm: SQL error 1062 mapping vodb.test to vodb.test [SQL error 1062]Duplicate entry '5451326' for key 'PRIMARY'.
2019-02-12T15:25:45.553+0800 ERROR OGG-01296 Oracle GoldenGate Delivery for MySQL, r1.prm: Error mapping from vodb.test to vodb.test.
2019-02-12T15:25:45.554+0800 ERROR OGG-01668 Oracle GoldenGate Delivery for MySQL, r1.prm: PROCESS ABENDING.

主键重复,删除目标的相关数据即可。

OGG-01031

ERROR   OGG-01031  Oracle GoldenGate Capture for MySQL, p1.prm:  There is a problem in the communication with the Collector/Receiver Server. (Reply received is 'Unable to open file "/data/ogg/dirdat/r1000000000" (error 11, Resource temporarily unavailable)').

/data/ogg/dirdat/r1000000000文件打不开,这是配置在目标端上的文件,安装OGG时使用了非root用户,该文件生成了,但内容为空,重新配置目标端OGG,步骤如下

停止目标端OGG所有进程

将目标端OGG目录授权为 root.root 权限

由于是刚配置启动目标端OGG,远程的同步文件为空文件,此处删除该空文件,然后为重装为dump进程设置推送的起点

p1为推送进程,设置p1重新从第一个抽取进程生成文件的最开始的位置,重新开始推送文件;因为抽取进程一直运行正常,在不断地从日志中抽取文件,所以不需要重新配置抽取进程

alter p1 extseqno 0,extrba 0

start extract p1

之后可以看到远程文件可以正常写入了

[root@db02 /data/ogg/dirdat]# ll
total 616888
-rw-r----- 1 root root 499999777 Jan 29 11:33 r1000000000
-rw-r----- 1 root root 131686696 Jan 29 11:33 r1000000001

OGG-02760

WARNING OGG-02760  Oracle GoldenGate Delivery for MySQL, r1.prm:  ASSUMETARGETDEFS is ignored because trail file /data/ogg/dirdat/r1000000000 contains table definitions.

ASSUMETARGETDEFS 参数在OGG12中已经不再使用了,可以去掉该参数

my27_OGG MySQL To MySQL错误汇总的更多相关文章

  1. MySQL Cluster测试过程中的错误汇总--ERROR 1296 (HY000)等等

    参考资料: http://dev.mysql.com/doc/refman/5.1/en/mysql-cluster-privilege-distribution.html http://www.cl ...

  2. mysql 案例 ~ mysql常见日志错误

    一 简介: mysql note级别日志汇总二错误系列  1 Aborted connection    1 [Note] Aborted connection 61 to db: 'unconnec ...

  3. Linux上通过MySQL命令访问MySQL数据库时常见问题汇总

    Linux上通过mysql命令访问MySQL数据库时常见问题汇总 1)创建登录账号 #创建用户并授权 #允许本地访问 create user 'test'@'localhost' identified ...

  4. mysql主主复制汇总整理

    mysql主主复制汇总整理 一.Mysql主主.主从复制主要思路: 1.mysql复制实质: 就是其他的MySQL数据库服务器将这个数据变更的二进制日志在本机上再执行一遍,因此非常重要的一点是mysq ...

  5. MySQL修改密码方法汇总

    本文给大家汇总介绍了MySQL修改密码的方法,分为MySQL5.7版本之前以及MySQL5.7版本之后的修改方法,有需要的小伙伴可以参考下 MySQL5.7版本之前修改密码的方法: 方法1: 用SET ...

  6. 关于MySql的1045错误修正

    很多情况数据库很久没有使用,偶尔打开会出现一系列错误,例如1045错误即是 mysql ERROR 1045 : Access denied for user‘root’@localhost(usin ...

  7. mysql 在windows下,使用 net start mysql 命令发生错误 服务名无效 或 1067

    mysql 在windows下,使用 net start mysql 命令发生错误 :服务名无效 或 1067  先使用mysqld -install安装一下 删除data目录下的日志等文件(因为之前 ...

  8. service mysql start出错,mysql启动不了,解决mysql: unrecognized service错误

    service mysql start出错,mysql启动不了,解决mysql: unrecognized service错误的方法如下: [root@ctohome.com ~]# service ...

  9. Windows无法启动MySQL服务,错误 1053

    解决方法: 正常重启电脑试试看,如果不行,在用下面试试 MYSQL 1053错误 解决方法: 在DOS命令行使用 第一步: 运行 -> cmd + 回车 (输入下面的命令) mysqld-nt ...

  10. MySQL安装常见错误及解决方案

    错误1:wizard安装最后一页,出现cannot create Windows service for mysql.error:0 错误 解决方法:打开命令行 输入 sc delete mysql ...

随机推荐

  1. 算法Sedgewick第四版-第1章基础-1.4 Analysis of Algorithms-005计测试算法

    1. package algorithms.analysis14; import algorithms.util.StdOut; import algorithms.util.StdRandom; / ...

  2. noi.ac day5t1 count

    传送门 分析 首先一个很重要的性质是每个数至少出现一次 所以只有一个数会出现两次 我们只需要求出n+1个数选k个数的方案数再减去重复的部分即可 重复部分于两个相同数中间的距离有关,详见代码 代码 #i ...

  3. CodeForces 566D Restructuring Company (并查集+链表)

    题意:给定 3 种操作, 第一种 1 u v 把 u 和 v 合并 第二种 2 l r 把 l - r 这一段区间合并 第三种 3 u v 判断 u 和 v 是不是在同一集合中. 析:很容易知道是用并 ...

  4. linux core文件机制

    在程序不寻常退出时,内核会在当前工作目录下生成一个core文件(是一个内存映像,同时加上调试信息).使用gdb来查看core文件,可以指示出导致程序出错的代码所在文件和行数. 1.core文件的生成开 ...

  5. 多线程学习-基础(四)常用函数说明:sleep-join-yield

    一.常用函数的使用 (1)Thread.sleep(long millis):在指定的毫秒内让当前正在执行的线程休眠(暂停执行),休眠时不会释放当前所持有的对象的锁.(2)join():主线程等待子线 ...

  6. WndProc和hook区别

    1)WndProc函数作用:主要在程序中拦截并处理系统消息和自定义消息 比如:windows程序会产生很多消息,比如你单击鼠标,移动窗口都会产生消息.这个函数就是默认的消息处理函数.你可以重载这个函数 ...

  7. Java 在本地开发环境部署多个 spring 项目

    修改Tomcat 的 server.xml 文件 路径:C:\JAVA\apache_tomcat_8.5.11\conf\server.xml : 每个web项目的端口号不同,且存储的目录相同但是文 ...

  8. 一键结束port 5037占用

    输入cmd进入dos界面,进入android-sdk-windows\platform-tools目录,执行下面命令启动adb start-server出现下面错误* daemon not runni ...

  9. jmeter接口参数化获取tocken后保存批量保存在本地

    jmeter目录结构如下: 1,读取文件配置的ID提取tocken 2,CSV 数据文件设置,第一个为文件目录,第二个为参数化的参数名. 3,正则表达式提取tocken 4,BeanShell Pos ...

  10. 注解和注释以及Spring和SpringMVC常用的注解

    1.两者区别 注解 :参与代码编译,以@开头的.它是给应用程序看的,单独使用注解毫无意义,一定要跟工具一起使用,这个所谓的工具实际就是能读懂注解的应用程序 注释 :对代码没有影响.对代码起到解释.说明 ...