1,问题描述

[oracle@node2 ~]$ lsnrctl stop

LSNRCTL for Linux: Version 11.2.0.4. - Production on -MAY- ::

Copyright (c) , , Oracle.  All rights reserved.

Connecting to (ADDRESS=(PROTOCOL=tcp)(HOST=)(PORT=))
TNS-: The user is not authorized to execute the requested listener command

2,问题解析

[oracle@node2 ~]$  lsnrctl status

LSNRCTL for Linux: Version 11.2.0.4. - Production on -MAY- ::

Copyright (c) , , Oracle.  All rights reserved.

Connecting to (ADDRESS=(PROTOCOL=tcp)(HOST=)(PORT=))
STATUS of the LISTENER
------------------------
Alias LISTENER
Version TNSLSNR for Linux: Version 11.2.0.4. - Production
Start Date -MAY- ::
Uptime days hr. min. sec
Trace Level off
Security ON: Local OS Authentication
SNMP OFF
Listener Parameter File /u01/app/grid/11.2./crs/network/admin/listener.ora
Listener Log File /u01/app/grid/diag/tnslsnr/node2/listener/alert/log.xml
Listening Endpoints Summary...
(DESCRIPTION=(ADDRESS=(PROTOCOL=ipc)(KEY=LISTENER)))
(DESCRIPTION=(ADDRESS=(PROTOCOL=tcp)(HOST=192.168.0.215)(PORT=)))
(DESCRIPTION=(ADDRESS=(PROTOCOL=tcp)(HOST=192.168.0.217)(PORT=)))
Services Summary...
Service "+ASM" has instance(s).
Instance "+ASM2", status READY, has handler(s) for this service...
Service "oracle" has instance(s).
Instance "oracle2", status READY, has handler(s) for this service...
Service "oracleXDB" has instance(s).
Instance "oracle2", status READY, has handler(s) for this service...
The command completed successfully
其中:Security ON: Local OS Authentication 此条提示信息表明监听处于Local OS Authentication认证模式.
Oracle 10g版本以及之后的版本中推出了监听的本地操作系统认证安全特性.若监听程序是在当前用户下启动的,
则当前用户具有管理监听的所有权利,其他用户对监听的管理将受到限制 因为数据库是11.2.0.1而且使用了oracle restart特性且用户为grid.注册了listener服务且只对默认端口1521有效.
之前是1532所以oracle restart不会自动重启监听.由于将端口修改成了1521所以oracle restart自动重启了listener
[grid@node2 ~]$ srvctl status listener
Listener LISTENER is enabled
Listener LISTENER is running on node(s): node2,node1 这个是不用管的

问题描述二

  oracle sqlplus / as sysdba 连接不上去

oracle 死活连接不上去,实例是启动的完好无损,原因是权限不对,

问题解析

  跟据自己的实例分析所有权限:

[root@node2 bin]# cd /u01/app/grid/11.2./crs/bin/
[root@node2 bin]# chown grid.oinstall oracle
[root@node2 bin]# chmod +s oracle
[root@node2 bin]# chown root.oinstall oradism
[root@node2 bin]# chmod +s oradism
[root@node2 bin]# chown root.oinstall jssu
[root@node2 bin]# chmod +s jssu
[root@node2 bin]# chown root.oinstall extjob
[root@node2 bin]# chmod +s extjob
[root@node2 bin]# cd /u01/app/oracle/product/11.2./db_1/bin/
[oracle@node2 bin]$ chown root.oinstall extjob
[oracle@node2 bin]$ chmod +s extjob
[root@node2 bin]# chown root.oinstall jssu
[root@node2 bin]# chown root.oinstall nmb
[root@node2 bin]# chown root.oinstall nmhs
[root@node2 bin]# chown root.oinstall nmo
[root@node2 bin]# chmod +s nmb
[root@node2 bin]# chmod +s nmhs
[root@node2 bin]# chmod +s nmo
[root@node2 bin]# chmod +s jssu
[root@node2 bin]# chown oracle.asmadmin oracle
[root@node2 bin]# chmod +s oracle
[root@node2 bin]# chown root.oinstall oradism
[root@node2 bin]# chmod +s oradism

具体截图:

权限赋予完整后问题解决,具体权限根据实际情况分析,这里是RAC集群问题

oracle 错误 TNS-01190与oracle 登入没反应操作的更多相关文章

  1. vuex存取token,http简单封装、模拟登入权限校验操作、路由懒加载的几种方式、vue单页设置title

    1.config index.js下面的跨域代理设置: proxyTable: { '/api': { target: 'http://xxxx', //要访问的后端接口 changeOrigin: ...

  2. [Oracle]Oracle数据库任何用户密码都能以sysdba角色登入

    * 本文相关环境:Windows 10,64位操作系统:Oracle 11gR2:toad for Oracle12.1 最近在学习Oracle数据库,使用Toad for Oracle来查看数据库的 ...

  3. Oracle数据库任何用户密码都能以sysdba角色登入

    * 本文相关环境:Windows 10,64位操作系统:Oracle 11gR2:toad for Oracle12.1 最近在学习Oracle数据库,使用Toad for Oracle来查看数据库的 ...

  4. Oracle数据库TNS错误解决方法

    ORA-12154: TNS:could not resolve the connect identifier specified ,即无法解析指定的连接 标识符.这说明缺少了一个环境变量,TNS_A ...

  5. hibernate连接oracle12c数据库报:java.sql.SQLException: ORA-01017: 用户名/口令无效; 登录被拒绝。(用户名/口令在oracle客户端以及cmd命令都能登入)

    报错信息: 2017-09-22 15:40:07,354 WARN [org.hibernate.cfg.SettingsFactory] - Could not obtain connection ...

  6. Oracle用imp导入dmp 提示遇到 ORACLE 错误 12560 TNS: 协议适配器错误 解决方法

    用imp命令导入dmp文件时提示以下错误: IMP-00058: 遇到 ORACLE 错误 12560 : ORA-12560: TNS: 协议适配器错误 : IMP-00000: 未成功终止导入 : ...

  7. 错误信息:"OraOLEDB.Oracle" 返回了消息 "ORA-12154: TNS: 无法解析指定的连接标识符

    错误信息:"OraOLEDB.Oracle" 返回了消息 "ORA-12154: TNS: 无法解析指定的连接标识符 链接服务器"NC"的 OLE D ...

  8. Oracle+struts2实现用户登入并显示访问次数

    实体类: package entity; public class userfo { private int id;//id private String name;//用户名 private Str ...

  9. Oracle 错误总结及问题解决 ORA

    参考地址 ORA-00001: 违反唯一约束条件 (.)错误说明:当在唯一索引所对应的列上键入重复值时,会触发此异常.ORA-00017: 请求会话以设置跟踪事件ORA-00018: 超出最大会话数O ...

随机推荐

  1. [DP]Luogu 2014NOIP提高组 飞扬的小鸟题解

    2014NOIP提高组飞扬的小鸟题解 题目描述 Flappy Bird是一款风靡一时的休闲手机游戏.玩家需要不断控制点击手机屏幕的频率来调节小鸟的飞行高度,让小鸟顺利通过画面右方的管道缝隙.如果小鸟一 ...

  2. VOC数据集 目标检测

    最近在做与目标检测模型相关的工作,很多都要求VOC格式的数据集. PASCAL VOC挑战赛 (The PASCAL Visual Object Classes )是一个世界级的计算机视觉挑战赛, P ...

  3. C# 重载 overload,重写override覆盖

    重载overload 派生类和基类的方法同名,其中访问修饰符(public,private,protected,internal,protected internal),返回类型,参数类型,个数,顺序 ...

  4. WPF-自定义实现步骤条控件

    步骤条实现的效果: 步骤条控件是在listbox的基础上实现的. 一. xaml代码: <Window.Resources> <convert1:StepListBarWidthCo ...

  5. [笔记] C# 如何获取文件的 MIME Type

    MIME Type 为何物: MIME 参考手册 svn.apache.org/repos/asf/httpd/httpd/trunk/docs/conf/mime.types 常规方式 对于有文件后 ...

  6. Python - 数据结构 - 第十五天

    Python 数据结构 本章节我们主要结合前面所学的知识点来介绍Python数据结构. 列表 Python中列表是可变的,这是它区别于字符串和元组的最重要的特点,一句话概括即:列表可以修改,而字符串和 ...

  7. phpmyadmin 在服务起上检测到错误,请查看窗口底部

    使用phpmyadmin一直提示这个警告,看着难受: 解决: 修改文件:/etc/phpmyadmin/config.inc.php 在最后添加这一句, $cfg['SendErrorReports' ...

  8. Linux存储管理

    一.存储基础知识 从工作原理区分: 机械 HDD 固态 SSD SSD的优势: SSD是摒弃传统磁介质,采用电子存储介质进行数据存储和读取的一种技术,突破了传统机械硬盘的性能瓶颈,拥有极高的存储性能, ...

  9. 深入浅出《设计模式》之工厂模式(C++)

    前言 模式介绍 在之前简单工厂模式中,我们介绍了简单工厂模式的缺陷是违背了开放-封闭原则.如果在面馆中添加了烤海参,那将会修改waiter工厂类.违背了类内封闭原则. 还以面馆为例,现在两种面,用一个 ...

  10. 消息服务dubbo接口性能压测性能优化案例

    最近项目中的消息服务做了运营商的改动,导致这个服务做了重新开发 压测脚本如下: 开启200线程压测: tps只有200-300之间,平均耗时在700ms左右 开启500线程压测 500并发压测,发现平 ...