大数据HDFS集群相关概念
一、Zookeeper服务
| 端口 | 描述 | 配置路径 |
| 2181 | 主要使用端口,对cline端提供服务。连接方式jdbc:hive2://ip:2181 | conf/zoo.cfg中clientPort |
| 2183 | 选举leader使用 | conf/zoo.cfg中server.x=2182:2183 |
| 2182 | 集群内机器通讯使用(Leader监听此端口) | conf/zoo.cfg中server.x=2182:2183 |
二、Hive服务
| 端口 | 描述 | 配置路径 |
| 7004 | Metastore,连接方式thrift://ip:7004 | hive-site.xml 的hive.metastore.port |
| 7001 | HiveServer2 | hive-site.xml 的hive.server2.thrift.port |
三、Yarn服务
| 服务 | 端口 | 描述 | 配置路径 |
| ResourceManager | 5000 | RM的applications manager端口 | yarn.resourcemanager.address |
| 5001 | scheduler组件的IPC端口 | yarn.resourcemanager.scheduler.address | |
| 5002 | IPC | yarn.resourcemanager.resource-tracker.address | |
| 5003 | IPC | yarn.resourcemanager.admin.address | |
| 5004 | http服务端口 | yarn.resourcemanager.webapp.address | |
| NodeManager | 8040 | localizer IPC | yarn.nodemanager.localizer.address |
| 8042 | http服务端口 | yarn.nodemanager.webapp.address | |
| 8041 | NM中container manager的端口 | yarn.nodemanager.address | |
| JobHistory Server | 5022 | IPC | mapreduce.jobhistory.address |
| 5023 | MR jobhistory admin地址,用以接收history admin命令 | mapreduce.jobhistory.admin.address | |
| 5024 | http服务端口 | mapreduce.jobhistory.webapp.address |
四、HDFS服务
| 服务 | 端口 | 描述 | 配置路径 |
| DataNode | 50010 | datanode服务端口,用于数据传输 | dfs.datanode.address |
| 50075 | http服务的端口 | dfs.datanode.http.address | |
| 50475 | https服务的端口 | dfs.datanode.https.address | |
| 50020 | ipc服务的端口 | dfs.datanode.ipc.address | |
| NameNode | 4008 | http服务的端口 | dfs.namenode.http-address |
| 4009 | https服务的端口 | dfs.namenode.https-address | |
| 8020 | 接收Client连接的RPC端口,用于获取文件系统metadata信息。 | fs.defaultFS |
大数据HDFS集群相关概念的更多相关文章
- 大数据-HDFS 集群搭建的配置文件
1.HDFS简单版集群搭建相关配置文件 1.core-site.xml文件 <property> <name>fs.defaultFS</name> <val ...
- 大数据Hadoop-Spark集群部署知识总结(一)
大数据Hadoop-Spark集群部署知识总结 一.启动/关闭 hadoop myhadoop.sh start/stop 分步启动: 第一步:在hadoop102主机上 sbin/start-dfs ...
- [转]大数据hadoop集群硬件选择
问题导读 1.哪些情况会遇到io受限制? 2.哪些情况会遇到cpu受限制? 3.如何选择机器配置类型? 4.为数据节点/任务追踪器提供的推荐哪些规格? 随着Apache Hadoop的起步,云客户 ...
- 大数据——Hadoop集群坏境CentOS安装
前言 前面我们主要分析了搭建Hadoop集群所需要准备的内容和一些提前规划好的项,本篇我们主要来分析如何安装CentOS操作系统,以及一些基础的设置,闲言少叙,我们进入本篇的正题. 技术准备 VMwa ...
- 部署开启了Kerberos身份验证的大数据平台集群外客户端
转载请注明出处 :http://www.cnblogs.com/xiaodf/ 本文档主要用于说明,如何在集群外节点上,部署大数据平台的客户端,此大数据平台已经开启了Kerberos身份验证.通过客户 ...
- 大数据 -- Hadoop集群环境搭建
首先我们来认识一下HDFS, HDFS(Hadoop Distributed File System )Hadoop分布式文件系统.它其实是将一个大文件分成若干块保存在不同服务器的多个节点中.通过联网 ...
- 一台虚拟机,基于docker搭建大数据HDP集群
前言 好多人问我,这种基于大数据平台的xxxx的毕业设计要怎么做.这个可以参考之前写得关于我大数据毕业设计的文章.这篇文章是将对之前的毕设进行优化. 个人觉得可以分为两个部分.第一个部分就是基础的平台 ...
- 入门大数据---Redis集群分布式学习
Redis是什么? 官方介绍: Redis 是一个开源(BSD许可)的,内存中的数据结构存储系统,它可以用作数据库.缓存和消息中间件. 它支持多种类型的数据结构,如 字符串(strings), 散列( ...
- 大数据-zookeeper集群安装
一.安装前发现的问题: 1.安装前期发现jps权限不够 [root@master1 ~]# jps -bash: /opt/workspace/jdk1./bin/jps: Permission de ...
- 大数据 --> Kafka集群搭建
Kafka集群搭建 下面是以三台机器搭建为例,(扩展到4台以上一样,修改下配置文件即可) 1.下载kafka http://apache.fayea.com/kafka/0.9.0.1/ ,拷贝到三台 ...
随机推荐
- Windows下驱动安装
推荐使用金山毒霸中的电脑医生进行驱动或DLL文件的扫描,查找并下载 dll文件下载地址: https://www.wenjian.net/ 可以进行下载,告诉该文件的放置路径 其他:
- Django之添加prometheus监控
1.首先需要在prometheus.yml配置文件中配置targets: - job_name: "test-server-191" static_configs: - targe ...
- 【Amadeus原创】SQL Server查询某数据库所有表名行数和空间占用率
` select object_name(id) tablename, 8reserved/1024 reserved, rtrim(8dpages)+'kb' used, 8(reserved-dp ...
- 硬盘空间消失之谜:Linux 服务器存储排查与优化全过程
前言 最近线上服务经常出现一些奇奇怪怪的问题,比如网页上的静态资源加载不出来,或者请求后端莫名报错,又或者 Redis 报错- 当我 SSH 登录到服务器上时,更不对劲了,敲个命令都卡顿- 如果是以前 ...
- IOS多线程之NSOperation(1)
IOS多线程之NSOperation(1) NSOperation 是 OC 语言中基于 GCD 的面向对象的封装: 提供了一些用 GCD 不好实现的功能: 线程的生命周期由系统自动管理. NSOpe ...
- metasploit模块
模块类型 辅助模块(Auxiliary) 渗透攻击模块(Exploits) 后渗透攻击模块(Post) 攻击载荷模块(Payloads) 空指令模块(Nops) 编码器模块(Encoders) 后渗透 ...
- 关于 K8s 的一些基础概念整理-补充【k8s系列之五】
〇.前言 本文继续整理下 K8s 的一些基础概念,作为前一篇概念汇总的补充. 前一篇博文链接:https://www.cnblogs.com/hnzhengfy/p/k8s_concept.html. ...
- 【前端】display:inline-block中间的间隙
父元素宽度800px 两个并列子元素宽度设为50%,并且使用了display:inline-block 结果一运行,两个元素不在同一行? 我查审元素,两个子元素div的宽度都是400,也没有边框,边距 ...
- Mybatis plus 多表联查字段名重复报错 Column ‘id‘ in where clause is ambiguous
一.报错信息 Caused by: Column 'xxxx' in where clause is ambiguous 二.报错原因 表 person 和 表 class 都有字段 id 和 nam ...
- SpringBoot支持Kafka多源配置的同时还要支持启停配置化,是真的会玩
开心一刻 今早,女朋友给我发微信 她:宝贝,你要记住 她:我可是你女朋友,你相亲就亲,想抱就抱 她:不要老是问我,男生要主动一些 我:可是你上次报警可不是这么说的 基础回顾 Spring Boot 集 ...