ORA-00600: internal error code, arguments: [4194]
使用PlateSpin复制出来的一数据库服务器(Oracle 10g)在启动数据库实例时遇到“ORA-00600: internal error code, arguments: [4194].....”错误,实例在启动后,会自然Down掉。具体情况如下所示:
Successfully onlined Undo Tablespace 54.
Mon Nov 21 11:34:03 2016
SMON: enabling tx recovery
Mon Nov 21 11:34:03 2016
Errors in file /u01/app/oracle/admin/epps/bdump/epps_smon_7522.trc:
ORA-00600: internal error code, arguments: [4097], [], [], [], [], [], [], []
Mon Nov 21 11:34:03 2016
Database Characterset is UTF8
Mon Nov 21 11:34:03 2016
Errors in file /u01/app/oracle/admin/epps/udump/epps_ora_7548.trc:
ORA-00600: internal error code, arguments: [4194], [59], [40], [], [], [], [], []
Mon Nov 21 11:34:04 2016
Non-fatal internal error happenned while SMON was doing temporary segment drop.
SMON encountered 1 out of maximum 100 non-fatal internal errors.
Mon Nov 21 11:34:04 2016
Errors in file /u01/app/oracle/admin/epps/bdump/epps_smon_7522.trc:
ORA-00600: internal error code, arguments: [4097], [], [], [], [], [], [], []
................................................................................
................................................................................
ORA-00600: internal error code, arguments: [4194], [52], [29], [], [], [], [], []
ORA-00600: internal error code, arguments: [4194]Non-fatal internal error happenned while SMON was doing temporary segment drop.
Mon Nov 21 11:35:04 2016
Flush retried for xcb 0x4419143b0, pmd 0x4401e3c90
Mon Nov 21 11:35:04 2016
SMON encountered 6 out of maximum 100 non-fatal internal errors.
Mon Nov 21 11:35:04 2016
Doing block recovery for file 2 block 1007
No block recovery was needed
Mon Nov 21 11:35:05 2016
Errors in file /u01/app/oracle/admin/epps/bdump/epps_pmon_7510.trc:
ORA-00600: internal error code, arguments: [4194], [52], [29], [], [], [], [], []
Mon Nov 21 11:35:05 2016
Errors in file /u01/app/oracle/admin/epps/bdump/epps_pmon_7510.trc:
ORA-00600: internal error code, arguments: [4194], [52], [29], [], [], [], [], []
PMON: terminating instance due to error 472
Instance terminated by PMON, pid = 7510
这个错误,官方文档Step by step to resolve ORA-600 4194 4193 4197 on database crash (文档 ID 1428786.1)有提供详细的介绍。建议处理前,建议先查阅次文档,错误出现的主要场景:
This issue generally occurs when there is a power outage or hardware failure that initially crashes the database. On startup, the database does the normal roll forward (redo) and then rollback (undo), this is where the error is generated on the rollback.
具体操作如下所示
Step 1: 通过spfile创建生成pfile
SQL> create pfile from spfile;
File created.
Step 2: 关闭数据库实例。
Step 3:修改pfile中undo_management为MANUAL
[oracle@DB-Server dbs]$ grep undo initepps.ora
*.undo_management='AUTO'
*.undo_tablespace='UNDOTBS'
[oracle@DB-Server dbs]$ vi initepps.ora
Step 4: 使用PFILE启动数据库
[oracle@DB-Server dbs]$ sqlplus / as sysdba
SQL*Plus: Release 10.2.0.4.0 - Production on Mon Nov 21 11:51:59 2016
Copyright (c) 1982, 2007, Oracle. All Rights Reserved.
Connected to an idle instance.
SQL> startup restrict pfile='initepps.ora'
ORACLE instance started.
Total System Global Area 1.0737E+10 bytes
Fixed Size 2101808 bytes
Variable Size 6476008912 bytes
Database Buffers 4244635648 bytes
Redo Buffers 14671872 bytes
Database mounted.
Database opened.
Step 5:This is critical - we are looking for all undo segments to be offline - System will always be online.
If any are 'PARTLY AVAILABLE' or 'NEEDS RECOVERY' - Please open an issue with Oracle Support or update the current SR. There are many options from this moment and Oracle Support Analyst can offer different solutions for the bad undo segments.
If all offline then continue to the next step
SQL> select tablespace_name, status, segment_name from dba_rollback_segs where status != 'OFFLINE';
TABLESPACE_NAME STATUS SEGMENT_NAME
------------------------------ ---------------- ------------------------------
SYSTEM ONLINE SYSTEM
Step 6: 新建一个UNDO表空间
SQL> create undo tablespace UNDOTBS1
2 datafile '/u04/epps/oradata/undotbs_01.dbf'
3 size 4G;
Tablespace created.
Step 7: 删除旧的UNDO表空间
SQL> drop tablespace UNDOTBS including contents and datafiles;
Tablespace dropped.
Step 8:关闭数据库实例
SQL> shutdown immediate;
Database closed.
Database dismounted.
ORACLE instance shut down.
SQL> exit
Disconnected from Oracle Database 10g Release 10.2.0.4.0 - 64bit Production
Step 9:启动数据库实例到NOMOUNT状态
SQL> startup nomount;
ORACLE instance started.
Total System Global Area 1.6777E+10 bytes
Fixed Size 2113368 bytes
Variable Size 9982443688 bytes
Database Buffers 6777995264 bytes
Redo Buffers 14663680 bytes
Step 10:修改spfile中的undo_tablespace参数
SQL> alter system set undo_tablespace='UNDOTBS1' scope=spfile;
System altered.
Setp 11:关闭数据库实例。
Step 12:启动数据库实例(使用spfile)
SQL> startup;
ORACLE instance started.
Total System Global Area 1.6777E+10 bytes
Fixed Size 2113368 bytes
Variable Size 9982443688 bytes
Database Buffers 6777995264 bytes
Redo Buffers 14663680 bytes
Database mounted.
Database opened.
ORA-00600: internal error code, arguments: [4194]的更多相关文章
- ORA-00600: internal error code, arguments: [4194], [53], [41], [], [], [], [], []
真的不动,关闭同事开发测试IBM 3650server它直接关系到电源插头行??? 第二天加点重新启动之后oracle 打开报错ORA-00600: internal error code, argu ...
- oracle 断电启动失败:ORA-00600: internal error code, arguments
转载地址: http://www.2cto.com/database/201312/261602.html 由于服务器断电,启动 oracle 时报 ORA-00600 错误 查看 oracle tr ...
- ORA-00600: internal error code, arguments: [17281], [1001], [0x1FF863EE8], [], [], [], [], []
我们生产服务器中的一个数据库发出监控告警日志的邮件,内容如下所示,在31号09:11分出现了大名鼎鼎的ORA-00600错误. Dear All: The Instance xxx' alert lo ...
- ORA-00600: internal error code, arguments: [2662]
转自 http://www.eygle.com/archives/2005/12/oracle_diagnostics_howto_deal_2662_error.html 在ORA-00600 22 ...
- ORA-00600: internal error code, arguments: [13030], [20]一例解决
两年没有接触oracle了,中午,一环境update from的时候出现ORA-00600: internal error code, arguments: [13030], [20]异常,经查,官网 ...
- ORA-00600: internal error code, arguments: [kdBlkCheckError]
ORA-00600: internal error code, arguments: [kdBlkCheckError] Table of Contents 1. 现象 2. 分析 3. 故障处理 1 ...
- 07 oracle 归档模式 inactive/current redo log损坏修复--以及错误ORA-00600: internal error code, arguments: [2663], [0], [9710724], [0], [9711142], [], [], [], [], [], [], []
07 oracle 归档模式 inactive/current redo log损坏修复--以及错误ORA-00600: internal error code, arguments: [2663], ...
- ORA-00600: internal error code, arguments: [SKGMFAIL], [2], [4], [4], [1], [], [], [], [], [], [], [
ORA-00600: internal error code, arguments: [SKGMFAIL], [2], [4], [4], [1], [], [], [], [], [], [], [ ...
- ORA-00600: internal error code, arguments: [LibraryCacheNotEmptyOnClose]
案例环境: 操作系统版本: Red Hat Enterprise Linux ES release 4 数据库版本 : 10.2.0.4.0 32 bit 案例介绍: 今天我执行stop_ora ...
随机推荐
- ASP.NET Web API 管道模型
ASP.NET Web API 管道模型 前言 ASP.NET Web API是一个独立的框架,也有着自己的一套消息处理管道,不管是在WebHost宿主环境还是在SelfHost宿主环境请求和响应都是 ...
- 基于虎书实现LALR(1)分析并生成GLSL编译器前端代码(C#)
基于虎书实现LALR(1)分析并生成GLSL编译器前端代码(C#) 为了完美解析GLSL源码,获取其中的信息(都有哪些in/out/uniform等),我决定做个GLSL编译器的前端(以后简称编译器或 ...
- 简述linux同步与异步、阻塞与非阻塞概念以及五种IO模型
1.概念剖析 相信很多从事linux后台开发工作的都接触过同步&异步.阻塞&非阻塞这样的概念,也相信都曾经产生过误解,比如认为同步就是阻塞.异步就是非阻塞,下面我们先剖析下这几个概念分 ...
- Atitit. 破解 拦截 绕过 网站 手机 短信 验证码 方式 v2 attilax 总结
Atitit. 破解 拦截 绕过 网站 手机 短信 验证码 方式 v2 attilax 总结 1. 验证码的前世今生11.1. 第一代验证码 图片验证码11.2. 第二代验证码 用户操作 ,比如 ...
- Java发展历史
1991年1月 Sun公司成立了Green项目小组,专攻智能家电的嵌入式控制系统 1991年2月 放弃C++,开发新语言,命名为"Oak" 1991年6月 JamesGosling ...
- 广州的小伙伴福利-由微软组织的在广州SQL Server线下活动
请按照如下格式报名.
- Quartz.net开源作业调度框架使用详解
前言 quartz.net作业调度框架是伟大组织OpenSymphony开发的quartz scheduler项目的.net延伸移植版本.支持 cron-like表达式,集群,数据库.功能性能强大更不 ...
- 多线程同步工具——LockSupport
用例1:子线程等待主线程发放许可! public static void main(String[] args) { Thread thread = new Thread(){ public void ...
- CSS3与页面布局学习总结(七)——前端预处理技术(Less、Sass、CoffeeScript、TypeScript)
CSS不像其它高级语言一样支持算术运算.变量.流程控制与面向对象特性,所以CSS样式较多时会引起一些问题,如修改复杂,冗余,某些别的语言很简单的功能实现不了等.而javascript则是一种半面向对象 ...
- 细说Java主流日志工具库
概述 在项目开发中,为了跟踪代码的运行情况,常常要使用日志来记录信息. 在Java世界,有很多的日志工具库来实现日志功能,避免了我们重复造轮子. 我们先来逐一了解一下主流日志工具. java.util ...
