一、 下载mysql5.7

http://mirrors.sohu.com/mysql/MySQL-5.7/

Linux下载:

输入命令:wget http://mirrors.sohu.com/mysql/MySQL-5.7/mysql-5.7.17-linux-glibc2.5-x86_64.tar.gz

二、建立用户,以及mysql的目录

1、建立一个mysql的组

输入命令: groupadd mysql

2、建立mysql用户,并放到mysql组

输入命令:useradd -r -g mysql mysql

3、给mysql用户设置密码

输入命令:passwd mysql

三、解压mysql

1、把下载的mysql的包移动到Linux虚拟机下

2、把tar包放到/usr/local 目录下

输入命令:mv /software/mysql-5.7.17-linux-glibc2.5-x86_64.tar.gz /usr/local

3、解压

输入命令:cd /usr/local

输入命令:tar xzvf mysql-5.7.17-linux-glibc2.5-x86_64.tar.gz

4、把解压出来的文件改下名字,改为mysql

输入命令:mv mysql-5.7.17-linux-glibc2.5-x86_64 mysql

四、配置相关的启动配置文件

1、复制my_default.cnf到/etc/my.cnf (mysql启动时自动读取)

输入命令:cp my-default.cnf /etc/my.cnf

2、解决乱码问题

输入命令:vi /etc/my.cnf

更改:

1
2
3
4
5
[mysql]
default-character-set=utf8
[mysqld]
default-storage-engine=INNODB
character_set_server=utf8

3、复制mysql.server 到/etc/init.d/

输入命令:cp mysql.server /etc/init.d/mysql

4、修改 /etc/init.d/mysql 参数,给予2个目录位置

输入命令:vi /etc/init.d/mysql

更改:basedir=/usr/local/mysql

   datadir=/usr/local/mysql/data

5、 给目录/usr/local/mysql 更改拥有者

输入命令:chown -R mysql:mysql /usr/local/mysql/

五、初始化mysql的数据库

1、初始化数据库

首先要去到mysql/bin目录下

老版本的命令:mysql_install_db

新版本的命令:./mysqld --initialize --user=mysql --basedir=/usr/local/mysql --datadir=/usr/local/mysql/data

生成出一个data目录,代表数据库已经初始化成功

2、给数据库加密

输入命令: ./mysql_ssl_rsa_setup --datadir=/usr/local/mysql/data

3、启动mysql

输入命令:./mysqld_safe --user=mysql &

&符号:把当前进程丢给后台

六、 进入客户端

1、 登录

输入命令:./mysql -uroot –p

然后输入你的临时密码

2、此时root用户不输密码登陆报错。需要更改/etc/my.cnf配置文件,然后重启mysql

输入命令:vi /etc/my.cnf

添加

  [mysqld]

  skip-grant-tables

输入命令:service mysql restart

3、 修改密码(切记:修改完密码后,需要执行flush privileges;

输入命令:set password=password('你的密码');

mysql -uroot -p免密码登陆后,修改密码时报错:

报错:ERROR 1290 (HY000): The MySQL server is running with the --skip-grant-tables opt

原因:权限没有刷新

解决:在mysql中执行命令:flush privileges;

4 查询当前mysql中所有的用户 更多详细命令参考

SELECT DISTINCT CONCAT('User: ''',user,'''@''',host,''';') AS query FROM mysql.user;

新建用户:

CREATE USER 'mysql'@'localhost' IDENTIFIED BY 'mysql';

为用户授权:

  格式:grant 权限 on 数据库.* to username@登录主机 identified by "password"; 
  实例:grant all privileges on testDB.* to mysql@localhost identified by 'mysql';
  (为了时其他机器而访问) mysql@'%'
  grant all privileges on *.* to mysql@'%' identified by 'mysql';
  然后须要运行刷新权限的命令:
  flush privileges;
这里如果只mysql@localhost,下一步用navicat连接虚拟机的mysql时会报错:
 

七、window远程访问Linux虚拟机的mysql

1、首先要关闭防火墙,这样window才能连接上

输入命令:systemctl stop firewalld.service

2、在windows中用navicat premium 客户端连接虚拟机中的mysql数据库

八、设置开机自动启动mysql服务

1、添加服务mysql

输入命令:chkconfig --add mysql

2、设置服务开机自启

输入命令:chkconfig mysql on

九、设置path环境变量

输入命令:vi /etc/profile

设置环境变量:export PATH=$JAVA_HOME/bin:/usr/local/mysql/bin:$PATH

十、linux虚拟机重启后,mysql进程正常运行但查看服务状态报错,navicat客户端也连接不上

service mysql status报错:
或者navicat premium 客户端连接不上MySQL:
1 切换到mysql用户下进行操作:su mysql
2 注意检查防火墙是否关闭:systemctl stop firewalld.service

参考帖子:

  洒水閃人-详细教程

  虚拟机重启后,mysql操作权限的问题

  MySQL免密登录ERROR 

  MySQL免密码登陆后,修改密码ERROR

  mysql中用户授权不正确,导致navicat客户端连接报错没有授权ERROR

Linux虚拟机下mysql 5.7安装配置方法图文教程的更多相关文章

  1. mysql 5.5 安装配置方法图文教程(转发)

    MySQL下载地址:http://dev.mysql.com/downloads/installer/ 1.首先进入的是安装引导界面 2.然后进入的是类型选择界面,这里有3个类型:Typical(典型 ...

  2. windows Sever 2012下Oracle 12c安装配置方法图文教程

    windows Sever 2012下Oracle 12c安装配置方法图文教程 Oracle 12c安装配置方法图文教程,具体内容如下 1.我们开启虚拟机 2.Windows Sever 2012启动 ...

  3. mysql 5.7.12 winx64安装配置方法图文教程

    这篇文章主要为大家分享了mysql 5.7.12winx64安装配置方法图文教程,感兴趣的朋友可以参考一下   之前安装mysql时未做总结,换新电脑,补上安装记录,安装的时候,找了些网友的安装记录, ...

  4. mysql 5.7以上版本安装配置方法图文教程(mysql 5.7.12\mysql 5.7.13\mysql 5.7.14)(转)

    http://www.jb51.net/article/90302.htm ******************************* 这篇文章主要为大家分享了MySQL 5.7以上缩版本安装配置 ...

  5. mysql 5.7.15 安装配置方法图文教程(转)

    http://www.jb51.net/article/92521.htm ******************************* MySQL数据库作为关系型数据库中的佼佼者,因其体积小,速度 ...

  6. mysql 5.7.14 安装配置方法图文教程(转)

    http://www.jb51.net/article/90259.htm ******************************** 因笔者个人需要需要在本机安装Mysql,先将安装过程记录如 ...

  7. mysql 5.7.13 安装配置方法图文教程(win10) (转)

    http://www.jb51.net/article/87152.htm ***************************** MySQL是一款关系型数据库管理系统,是由Oracle旗下公司M ...

  8. CentOS7下MySQL5.7安装配置方法图文教程(YUM)

    安装环境:CentOS7 64位,MySQL5.7 1.配置YUM源 在MySQL官网中下载YUM源rpm安装包:http://dev.mysql.com/downloads/repo/yum/ # ...

  9. mysql 5.7.13 安装配置方法图文教程(linux) (转)

    http://www.jb51.net/article/87160.htm ************************************************ linux环境Mysql ...

随机推荐

  1. 第三百七十二节,Python分布式爬虫打造搜索引擎Scrapy精讲—scrapyd部署scrapy项目

    第三百七十二节,Python分布式爬虫打造搜索引擎Scrapy精讲—scrapyd部署scrapy项目 scrapyd模块是专门用于部署scrapy项目的,可以部署和管理scrapy项目 下载地址:h ...

  2. (转)android媒体--stagefright概述【一】

    转自:http://blog.csdn.net/loovejava/article/details/8971790 最近杂七杂八的忙碌着,前几天看了下这部分主要是stagefright模块的,所以更改 ...

  3. (转)FFmpeg源代码简单分析:avformat_find_stream_info()

    目录(?)[+] ===================================================== FFmpeg的库函数源代码分析文章列表: [架构图] FFmpeg源代码结 ...

  4. org.in2bits.MyXls.XlsDocument 生成excel文件 ; 如果想读取模板再另外生成的话,试试 NPOI

    优点:不依赖Microsoft组件,在内存中操作excel,读写速度快.   缺点:无法读取模板,只能生成新的excel (我亲自测试是在读取完模板后,不能保存,也不能另存,并且其他人说这个读取还会有 ...

  5. Cisco 交换机修改密码

    实验环境: 公司有一台思科交换机忘记登录密码,无法进入到特权模式下. 实现功能: 修改特权模式下的登录密码 1.  桌面 ---- 开始  ---- 所有程序 ---- 附件 ---- 超级终端 -- ...

  6. asp.net 局域网中获取 client的机器名

    //获取客户端计算机名称 System.Net.IPAddress clientIP = System.Net.IPAddress.Parse(Request.UserHostAddress);//根 ...

  7. 关于js中namespace命名空间模式

    命名空间有助于减少程序中所需要的全局变量的数量,并且同时有助于避免命名冲突或过长的名字前缀. 关于命名空间的例子: /** * 创建全局对象MYAPP * @module MYAPP * @title ...

  8. Javascript实例教程:querySelector()方法接受一个CSS查询并返回匹配模式的第一个子孙元素,如果没有匹配的元素则返回null。

    文章简介:querySelector()方法接受一个CSS查询并返回匹配模式的第一个子孙元素,如果没有匹配的元素则返回null. querySelector()方法接受一个CSS查询并返回匹配模式的第 ...

  9. Thinkphp5笔记二:创建模块

    系统:window 7 64位 Thinkphp版本:5.0.5 环境:wampserver集成 我的项目是部署在本地www/thinkphp  目录下.在做之前,先要考虑清楚,你需要几个模块来完成你 ...

  10. Linux中/etc/resolv.conf文件简析

    https://blog.csdn.net/lcr_happy/article/details/54867510