linux下Oracle11g RAC搭建(二)
linux下Oracle11g RAC搭建(二)
一、安装前配置
网络的配置
IP占用測试
进入windows下。运行cmd,使用ping命令验证网段是否被占用。
注:用哪个网段都行,一定保证不要被其他设备占用就可以。
ping 192.168.4.71
ping 192.168.4.72
ping 192.168.4.73
ping 192.168.4.74
ping 192.168.4.75
私有网卡预分配:
node1:10.10.10.71
node2:10.10.10.72
改动主机名
配置node1(节点1)网络
eth0和eth1不在同网段
eth0配置(桥接网卡)
vi /etc/sysconfig/network-scripts/ifcfg-eth0
DEVICE=eth0
BOOTPROTO=static //改动成静态
ONBOOT=yes
IPADDR=192.168.4.71 //加入公有IP
NETMASK=255.255.255.0 //加入子网掩码
GATEWAY=192.168.4.1 //加入网关
//删除掉广播地址、MAC地址
eth1配置(私有网卡)
vi /etc/sysconfig/network-scripts/ifcfg-eth1
DEVICE=eth1
BOOTPROTO=static
ONBOOT=yes
IPADDR=10.10.10.71
NETMASK=255.255.255.0
#service network restart
配置node2(节点2)网络
eth0配置(桥接网卡)
vi /etc/sysconfig/network-scripts/ifcfg-eth0
DEVICE=eth0
BOOTPROTO=static
ONBOOT=yes
IPADDR=192.168.4.72
NETMASK=255.255.255.0
GATEWAY=192.168.4.1
//删除掉广播地址、MAC地址
eth1配置(私有网卡)
vi /etc/sysconfig/network-scripts/ifcfg-eth1
DEVICE=eth1
BOOTPROTO=static
ONBOOT=yes
IPADDR=10.10.10.72
NETMASK=255.255.255.0
#service network restart
linux对新加入的硬盘分区
[root@node1 etc]# df -h //查看磁盘信息
分别对node1 和 node2中的磁盘分区
对node1中的磁盘分区
sda1表示第一块磁盘的第一个分区
sda2表示第一块磁盘的第二个分区
sda表示第一块磁盘
sdb表示第二块磁盘
node1下查看(应该能看到3块)
# fdisk –l //查看磁盘分配情况
Disk /dev/sda: 21.4 GB, 21474836480 bytes
255 heads, 63 sectors/track, 2610 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
DeviceBoot Start End Blocks Id System
/dev/sda1 * 1 13 104391 83 Linux
/dev/sda2 14 2610 20860402+ 8e Linux LVM
Disk /dev/sdb: 32.2 GB, 32212254720 bytes
255 heads, 63 sectors/track, 3916 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk /dev/sdb doesn't contain a valid partition table
一、对node1 sdb分区
#fdisk /dev/sdb
//分区。表示对/dev下的/sdb(第二块磁盘)分区
Command (m for help): m
Command action
a toggle a bootable flag
b edit bsd disklabel
c toggle the dos compatibility flag
d delete a partition //删除分区
l list known partition types
m print this menu
n add a new partition //加入分区
o create a new empty DOS partition table
p print the partition table //打印分区表
q quit without saving changes
s create a new empty Sun disklabel
t change a partition's system id
u change display/entry units
v verify the partition table
w write table to disk and exit //保存退出
x extra functionality (experts only)
Command (m for help): n
Command action
e extended 扩展分区
p primary partition (1-4) 主分区
p 创建一个主分区
Partition number (1-4):
First cylinder (1-3916, default 1):
Last cylinder or +size or +sizeM or +sizeK (1-3916,default 3916):
按回车 由于仅仅分一个区
Command (m for help): p //查看分区结果。打印分区表
Command (m for help): w //保存退出
#fdisk –l
Disk /dev/sdb: 32.2 GB, 32212254720 bytes
255 heads, 63 sectors/track, 3916 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
DeviceBoot Start End Blocks Id System
/dev/sdb1 1 3916 31455238+ 83 Linux
#mkfs.ext3 /dev/sdb1 //格式化sdb1,格式成ext3格式文件系统
#mkdir /u01 //创建挂载文件夹
#mount /dev/sdb1 /u01 //挂载到u01下,手工mount重新启动后失效
[root@node1 etc]# df -h //查看磁盘信息,硬盘挂载成功
#vi /etc/fstab //创建自己主动挂载。保证重新启动后仍可用
加入:
/dev/sdb1 /u01 ext3 defaults 0 0
要挂载的对象 挂载的文件夹 系统类型 文件系统訪问权限 开机后是否检測出问题后是否转储
# mount /u01 //挂载
二、对node2的sdb磁盘分区
#fdisk /dev/sdb------m (help)查看帮助
Command (m for help): n
Command action
e extended 扩展分区
p primary partition (1-4) 主分区
p 创建一个主分区
Partition number (1-4): 1
First cylinder (1-3916, default 1):
按回车 由于仅仅分一个区
Command (m for help): p
Command (m for help): w 保存分区
#fdisk -l
Disk /dev/sdb: 32.2 GB, 32212254720 bytes
255 heads, 63 sectors/track, 3916 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
DeviceBoot Start End Blocks Id System
/dev/sdb1 1 3916 31455238+ 83 Linux
格式化分区
#mkfs.ext3 /dev/sdb1 对sdb1格式化
#mkdir /u01
//创建挂载文件夹
#vi /etc/fstab //创建自己主动挂载
加入:/dev/sdb1 /u01 ext3 defaults 0 0
# mount /u01 //挂载
[root@node2 etc]# df -h //查看硬盘信息, 硬盘挂载成功了
Filesystem Size Used Avail Use% Mounted on
/dev/sdb1 30G 173M 28G 1% /u01
**************************兴许更新上传中敬请关注**************************************
声明:
原创作品。出自 “深蓝的blog” 博客。同意转载,转载时请务必注明出处(http://blog.csdn.net/huangyanlong)。关于涉及版权事宜。作者有权追究法律责任。
linux下Oracle11g RAC搭建(二)的更多相关文章
- linux下Oracle11g RAC搭建(七)
linux下Oracle11g RAC搭建(七) 六.安装Grid 启动GRID安装界面 方式一:redhat下调整分辨率 [root@node1 ~]# xhost + //授权 [ro ...
- linux下Oracle11g RAC搭建(六)
linux下Oracle11g RAC搭建(六) 五.校验安装前的环境 root身份下完毕解压grid.database安装包 [grid@node1 soft]$ su - Password: [r ...
- linux下Oracle11g RAC搭建(九)
linux下Oracle11g RAC搭建(九) 八.创建ASM仓储 相同在图形化界面操作 [root@node1 ~]# su - grid [grid@node1 ~]$ asmca //创 ...
- linux下Oracle11g RAC搭建(一)
linux下Oracle11g RAC搭建(一) 文档说明 作者 深蓝 项目 Visualbox下模拟RAC搭建(双节点)(Redhat5+Oracle11G) 环境 RedHat Enterp ...
- linux下oracle11G DG搭建(二):环绕主库搭建操作
linux下oracle11G DG搭建(二):环绕主库搭建操作 环境 名称 主库 备库 主机名 bjsrv shsrv 软件版本号 RedHat Enterprise5.5.Oracle 11g 1 ...
- Linux下Oracle11G RAC报错:在安装oracle软件时报file not found一例
Linux下Oracle11G RAC报错:在安装oracle软件时报file notfound一例 1.现象 之前安装一切都比較顺利,安装oracle软件时,进度到30%时报错:file not f ...
- linux下oracle11G DG搭建(三):环绕备库搭建操作
linux下oracle11G DG搭建(三):环绕备库搭建操作 环境 名称 主库 备库 主机名 bjsrv shsrv 软件版本号 RedHat Enterprise5.5.Oracle 11g 1 ...
- linux下安装EJBCA 搭建私有CA服务器
linux下安装EJBCA 搭建私有CA服务器 EJBCA是一个全功能的JAVA的CA系统软件,我们可以用此搭建私有CA服务器: 一:首先我的测试环境: 1. linux mint18.3 62位: ...
- linux下的服务器搭建集成环境
linux下的服务器搭建集成环境 ——写给初学者的我们 1.准备工具 1.1 SecureCRT SecureCRT是一款支持SSH(SSH1和SSH2)的终端仿真程序,简单地说是Windows下登录 ...
随机推荐
- 主元素 II
主元素 II 给定一个整型数组,找到主元素,它在数组中的出现次数严格大于数组元素个数的三分之一. 样例 给出数组[1,2,1,2,1,3,3] 返回 1 注意 数组中只有唯一的主元素 挑战 要求时间复 ...
- Codeforces Round #424 (Div. 2, rated, based on VK Cup Finals) Office Keys(思维)
Office Keys time limit per test 2 seconds memory limit per test 256 megabytes input standard input o ...
- git "Could not read from remote repository.Please make sure you have the correct access rights."解决方案
我们在使用git clone 或其他命令的时候,有时候会遇到这类问题,如图: fatal: Could not read from remote repository.Please make sure ...
- 【BZOJ 2118】 2118: 墨墨的等式 (最短路)
2118: 墨墨的等式 Description 墨墨突然对等式很感兴趣,他正在研究a1x1+a2y2+…+anxn=B存在非负整数解的条件,他要求你编写一个程序,给定N.{an}.以及B的取值范围,求 ...
- [P2698][USACO12MAR]花盆Flowerpot
Link: P2698 传送门 Solution: 对于可行区间$[L,R]$,随着$L$的递增$R$不会递减 因此可以使用尺取法来解决此题:不断向右移动左右指针,复杂度保持线性 同时为了维护区间内的 ...
- Java程序运行时内存划分
1.Java程序跨平台运行的原因 主要原因是:各种平台的JVM和字节码文件 Java源程序--具体平台的机器代码文件---被编译器翻译成平台无关的Class文件,又用特定JVM运行字节码文件,JVM在 ...
- 错误:Caused by:org.apache.spark.SparkException: Kryo serialization failed: Buffer overflow.Available: 0, required: 21. To avoid this,
这个是写入Redis时用的序列化器,然后错误提示是超过了大小限制,把配置调大即可. .set("spark.kryoserializer.buffer.max","128 ...
- mysql 中添加索引的三种方法
原文:http://www.andyqian.com/2016/04/06/database/mysqleindex/ 在mysql中有多种索引,有普通索引,全文索引,唯一索引,多列索引,小伙伴们可以 ...
- Toad 常用快捷键
F9 执行全部sql Ctrl_Enter 执行当前sql Ctrl+T 补全table_name ...
- jrat
JRat the Java Runtime Analysis Toolkit What is it? The Java Runtime Analysis Toolkit is a low overhe ...