linux下安装EJBCA 搭建私有CA服务器
linux下安装EJBCA 搭建私有CA服务器
EJBCA是一个全功能的JAVA的CA系统软件,我们可以用此搭建私有CA服务器;
一:首先我的测试环境:
1. linux mint18.3 62位:同ubuntu
2. ejbca_ce_6_5_0 : 下载地址 https://sourceforge.net/projects/ejbca/files/ejbca6/ejbca_6_5_0/
3. jboss-eap-6.4.0 :下载地址 https://developers.redhat.com/products/eap/download/ (需要redhat账号)
4. java环境:openjdk8
注意:ubuntu下用户权限$以及目录权限
二:安装过程
1. 创建user用户并添加主目录
//创建user用户,并指定主目录user
sudo useradd -d /home/user -m user
2. 将下载的文件 ejbca,jboss放到 /home/user 目录下,并使用unzip命令解压;
ejbca_ce_6_5_0 ejbca_ce_6_5_0.zip jboss-eap-6.4 jboss-eap-6.4.0.zip
3. 安装JDK以及ant,打开终端,定义为终端A
sudo apt-get install default-jdk-headless ant ant-optional unzip
4. 配置ejbca与jboss的关联,终端A
sudo echo "appserver.home=/home/user/jboss-eap-6.4" >> ejbca_ce_6_5_0/conf/ejbca.properties
5. 另外打开一个终端B,开启jboss服务
jboss-eap-6.4/bin/standalone.sh
6.在之前终端A,下开启ant配置
cd ejbca_ce_6_5_0 #遇到提示,一路回车
sudo ant deploy sudo ant install
7. 在终端B,下重新开启jboss服务
#停止之前的
ctrl-c #重新开启
sudo jboss-eap-6.4/bin/standalone.sh
8. 如果一切顺利正常的话,会生成如下浏览器用的p12文件
/home/user/ejbca_ce_6_5_0/p12/superadmin.p12 #把这个文件放到浏览器上导入,mac下可直接双击导入钥匙串,默认密码ejbca
9.浏览器打开服务管理页面
https://server:8443/ejbca #server就是你安装ejbca电脑的ip或域名
10 . 在浏览器里面页面

参考:https://www.ejbca.org/docs/installation.html
linux下安装EJBCA 搭建私有CA服务器的更多相关文章
- Nginx 在 Linux 下安装与搭建集群
搭建集群图例 集群搭建图如下,为了简单一点,使用一个Nginx服务器+两个Tomcat服务器,省略数据库部分: 环境说明 Linux 为 CentOS 7.2 发行版 + Java jdk 1.8 + ...
- 转:Linux下使用Nginx搭建简单图片服务器
最近经常有人问图片上传怎么做,有哪些方案做比较好,也看到过有关于上传图片的做法,但是都不是最好的,今天再这里简单讲一下Nginx实现上传图片以及图片服务器的大致理念. 如果是个人项目或者企业小项目,仅 ...
- linux下安装haproxy作为端口转发服务器,以及安装keepalived作为haproxy高可用方案
一.安装haproxy作为端口转发服务器(主服务器:172.28.5.4,备服务器:172.28.5.8,浮点IP为:172.28.5.6) 1.安装依赖包 yum -y install wget g ...
- 搭建私有CA服务器
1 CA是什么 CA(Certificate Authority)证书颁发机构主要负责证书的颁发.管理以及归档和吊销.证书内包含了拥有证书者的姓名.地址.电子邮件帐号.公钥.证书有效期.发放证书的CA ...
- Linux下安装PHP并在nginx服务器中进行配置的详细方法
先介绍一下使用的环境:centos 7.4, PHP 7.0 , nginx 1.12 Linux系统版本可以通过命令:lsb_release -a 查看. 现在开始步入正题了! 1. 首先查看一下 ...
- linux下安装shellinabox实现web登录服务器
GitHub地址(含有文件下载和详细安装流程):https://github.com/shellinabox/shellinabox 这里我们使用的是redhat安装方法如下: 1.配置安装依赖环境 ...
- Ubuntu18.04安装GitLab搭建私有仓库服务器过程笔记
百度了很多资料结果折腾很久还没安装成功,索性就直接上官网找文档参考顺利搭建完成 因为有2台服务器做练习,总结了2种安装方式提供参考:第一种官网安装方式,第二种国内镜像安装方式(建议采用第二种) 第 ...
- 搭建私有CA并实现证书颁发
一.搭建私有CA服务器 1.安装包 # yum -y install openssl 2.生成密钥对儿 # cd /etc/pki/CA # (umask 077;openssl genrsa -ou ...
- Linux系统搭建私有CA证书服务器
一.CA简介 CA是什么?CA是Certificate Authority的简写,从字面意思翻译过来是凭证管理中心,认证授权.它有点类似我们生活中的身份证颁发机构,这里的CA就相当于生活中颁发身份证的 ...
随机推荐
- BZOJ2553 [BeiJing2011]禁忌 AC自动机 矩阵
原文链接http://www.cnblogs.com/zhouzhendong/p/8196279.html 题目传送门 - BZOJ2553 题意概括 引用一下lych大佬的: 在字母只有前alph ...
- Linux安装Tomcat-Nginx-FastDFS-Redis-Solr-集群——【第十一集之安装FastDFS】
1,安装FastDFS之前,先安装libevent工具包. yum -y install libevent 2,安装libfastcommonV1.0.7工具包.有可能找到新版本的zip压缩包:lib ...
- sql的连接查询
http://www.cnblogs.com/LeoTerry/archive/2010/03/26/1696988.html
- hive提前过滤重要性
hive提前过滤 create table sospdm.tmp_yinfei_test_01 ( id string ) partitioned by (statis_date string) ; ...
- 001.Linux开机启动过程
相关Linux启动过程解析,此作为通用启动参考:
- redsi搭建主从和多主多从
- Unity容器在asp.net mvc中的IOC应用及AOP应用
<asp.net-mvc框架揭秘>一书中,有个示例,是使用unity容器来注入自定义的控制器工厂.代码示例可以自己去下载源码,在这里我就不说了.IOC容器的本质是解耦的实例化接口类,而如何 ...
- [PA2014]Muzeum
[PA2014]Muzeum 题目大意: 有\(n\)件展品和\(m\)个警卫,每件展品有一个坐标\((x_i,y_i)\)和价值\(v_i\),每个警卫的坐标为\((x_i,y_i)\).每个警卫面 ...
- IDEA+Maven:cannot download sources
把IDEA的maven换成maven2
- 浏览器JS报错Uncaught RangeError Maximum call stack size exceeded
JavaScript错误:Uncaught RangeError: Maximum call stack size exceeded 堆栈溢出 原因:有小类到大类的递归查询导致溢出 解决方法思想: A ...