debian apache2 多端口对应多文件 虚拟端口配置
apache2单IP多端口创建虚拟站点如下:
1.转到配制目录虚拟站点配制目录
cd /etc/apache2/
2.配置新增多的端口
编辑上级目录中的端口配制文件
sudo gedit ports.conf
添加你的端口,建议取5位数的或者其他不常见的端口号,比较安全不容易被攻击
Listen 80
Listen 1117
<IfModule ssl_module>
Listen 443
</IfModule>
<IfModule mod_gnutls.c>
Listen 443
</IfModule>
3.拷贝默认站点 000-default.conf 文件 并修改为你的配置
cd /etc/apache2/sites-available/
# 拷贝文件
sudo cp 000-default.conf 你的配置文件名.conf
# 编辑文件
vim 你的配置文件名.conf
完整配置文件如下,这样配置完基本没有问题了
<VirtualHost *:1117>
ServerAdmin webmaster@localhost
DocumentRoot /var/www/233 #注意结尾没有 ‘/’
ErrorLog ${APACHE_LOG_DIR}/error.log
CustomLog ${APACHE_LOG_DIR}/access.log combined
<Directory />
Options FollowSymLinks
AllowOverride None
Require all granted
</Directory>
<Directory /var/www/233/> #注意结尾有‘/’
Options Indexes FollowSymLinks
AllowOverride none
Require all granted
</Directory>
</VirtualHost>
4.上级目录sites-enabled中建立链接
```bash
sudo ln -s 你的配置文件名.conf ../sites-enabled/你的配置文件名.conf
```
这一步的目的是建立软链接,不加-s是建立硬链接;
软链接只会在选定的位置上生成一个文件的镜像,不会占用磁盘空间,类似与windows的快捷方式。
硬连接会在选定的位置上生成一个和源文件大小相同的文件,无论是软链接还是硬链接,文件都保持同步变化。
我每次这样操作后面都无法重启apache,所以取消链接,手动复制相同的两个文件了。
取消链接方法:
# unlink 刚刚链接的文件
unlink /etc/apache2/sites-enabled/你的配置文件.conf
5.重启apache
sudo service apache2 restart
6.尝试下是否能正常访问
出现的问题:
a.如果出现403等情况,可能是文件没有访问权限,修改文件权限为可读写
chmod -R 755 '/var/www/233'
b.ln: failed to create symbolic link '/tmp/mysql.sock': File exists
链接的文件已存在,查看下链接时路径文件是否正确
后续:记得修改服务器端口,开放你的配置的端口
我的是debian服务器,修改端口配置
vim /etc/iptables/rules.v4
#添加开放端口
-A INPUT -m state --state NEW -m tcp -p tcp --dport 1117 -j ACCEPT
# 启动刚刚修改的端口配置
iptables-restore < /etc/iptables/rules.v4
我用的阿里服务器,还要在阿里上开放该端口的安全组(具体方法百度、阿里云官网很多)
debian apache2 多端口对应多文件 虚拟端口配置的更多相关文章
- Apache基于域名、端口、IP的虚拟主机配置(Centos 6.5)
虚拟主机:部署多个站点,每个站点,希望用不同的域名和站点目录,或者是不同的端口,不同的ip,需要虚拟主机功能.一句话,一个http服务要配置多个站点,就需要虚拟主机. 虚拟主机分类:基于域名.基于端口 ...
- apache2.2 虚拟主机配置详解
一.修改httpd.conf 打开appserv的安装目录,找到httpd.conf文件,分别去掉下面两行文字前面的#号. #LoadModule vhost_alias_module modules ...
- ubuntu apache2配置详解(含虚拟主机配置方法)
ubuntu apache2配置详解(含虚拟主机配置方法) 在Windows下,Apache的配置文件通常只有一个,就是httpd.conf.但我在Ubuntu Linux上用apt-get inst ...
- CentOS 7运维管理笔记(7)----Apache 基于端口的虚拟主机配置
如果一台服务器只有一个IP或需要通过不同的端口访问不同的虚拟主机,可以使用基于端口的虚拟主机配置. (1) 在虚拟机的CentOS7服务器上配置 eth0:4 为192.168.1.214: (2) ...
- ubuntu下安装配置apache2(含虚拟主机配置)
在Ubuntu14.14中安装apache 安装指令: sudo apt-get install apache2 安装结束后: 产生的启动和停止文件是: /etc/init.d/apache2 启动: ...
- linux下apache2的虚拟主机配置
1,起因 在一星期前吧,大波说既然咱们有了自己的服务器,二级域名了.可以考虑怎样每人一个域名,分别指向我们各自的空间.想法挺好,避免我们个人的东西放在同一主页上.那就做吧 2,第一次尝试 (1)在域名 ...
- 解决 Tomcat 无法绑定 80 端口的问题,以及 Tomcat 配置虚拟目录、二级域名等
问题 今天安装完 Tomcat,安装时把 Tomcat 默认的 HTTP/1.1 Connector Port 从 8080 改为了 7080,启动 Tomcat,在浏览器中输入 Http://loc ...
- TOMCAT服务器不写端口号、不写项目名访问项目、虚拟目录配置
一.不写端口. 这个问题都被问烂了,因为TOMCAT默认的访问端口为8080,而TCP/IP协议默认80端口访问,大家之所以看到别的网站都不写端口号是因为人家用的的80端口访问的,而80端口因为的TC ...
- apache2.2 虚拟主机配置
一.改动httpd.conf 打开appserv的安装文件夹,找到httpd.conf文件,分别去掉以下两行文字前面的#号. #LoadModule vhost_alias_module module ...
随机推荐
- Tomcat出现 java.net.ConnectException: Connection refused 异常的原因及解决方法
原因有2. ------------------ 端口被占用 --------------------数据库链接失败导致的异常 cmd 查看 端口占用情况 检查数据库服务是否启动 --------此次 ...
- 小妖精的完美游戏教室——人工智能,A*算法,实现篇
//================================================================//// Copyright (C) 2017 Team Saluk ...
- java_集合类_简
Collection 来源于Java.util包,实用常用的数据结构,字面意思就是容器 主要方法 boolean add(Object o)添加对象到集合 boolean remove(Object ...
- 软件开发者路线图梗概&书摘chapter4
准确的自我评估:不是超出平庸,而是度量能力,做到更好,谦卑 1.只求最差:学期曲线趋平 更好团队→提供帮助+准确的自我评估 列举团队并排序 2.找人指导:学习前头的人,寻找师傅 加入社区,寻找活跃的老 ...
- Python基础:十一、流程控制(if语句、while循环)
一.流程控制——if循环 1.第一种语法: if条件: #引号是将条件与结果分开 结果1 #四个空格,或者一个tab键,这个是告诉程序满足条件的话,运行这个结果 结果2 #如果条件是真(True)执行 ...
- Oracle开启监听缓慢问题
现象: Oracle数据库中,使用lsnrctl开启.关闭监听或查看监听状态时,非常慢,可以通过断网的方式使动作马上完成. 在客户端使用plsql等方式连接数据库时,也是非常慢,同样也可以通过切换网络 ...
- DataFrame对行列的基本操作实战
1.pandas对行列的基本操作命令: import numpy as np import pandas as pd from pandas import Sereis, DataFrame ser ...
- 1、IT人思维之投资开篇 - IT人思维之投资
在IT圈中,很多人的认识就只在于工作中获取收益,这个观点是狭隘的,本身就不符合投资领域的内容.所以,在工作之余,笔者就对投资领域的内容进行的分析和收集整理相关的投资方面的内容,一方面对笔者自己的投资方 ...
- Gradle的使用及下载
1在官网下载Gradle 基本学这个的都有JDK和JVM所以只需要在环境变量中配置即可 点击hettp://start.spring.io/即可使用
- java.lang.IllegalArgumentException: No enum constant org.apache.ws.commons.schema.XmlSchemaForm.
一次系统断电维护之后,apache cxf 的 web service 接口调用一直报错: java.lang.IllegalArgumentException: No enum constant o ...