1.  JDK安装配置

第一步:创建jdk安装目录(该/usr/local/src 目录是空的,最好把我们自己下载的放到这,容易区分

命令:mkdir -p /usr/local/src/jdk

第二步:查看安装程序
   命令:rpm -qa | grep -i jdk
   若之前安装过jdk,下次安装一定把之前的删除干净
第三步:命令下载jdk包 (需要联网,下载也需要点时间
      本章使用的为后缀为tar.gz的文件(不需要安装)
  注意:如果上面wget命令不能用,报错:-bash: wget: command not found。执行一下该命令(安装依赖包) yum -y install wget
  注意:如果上面wget命令不能用,报错:-bash: wget: command not found。执行一下该命令(安装依赖包) yum -y install wget
      注意 : 记住需要加上:--no-check-certificate --no-cookies --header "Cookie: oraclelicense=accept-securebackup-cookie"    这段是为了避开用户验证用的
第四步:解压
     [root@bogon jdk]# tar -zxvf jdk-8u131-linux-x64.tar.gz
    系统会生成一个名为:jdk1.8.0_131 的文件夹。可以使用mv命令自定义文件名。
    [root@bogon jdk]# mv jdk1.8.0_131  jdk1.8
第五步:配置环境变量
    [root@bogon bin]# vi /etc/profile
    可以看到这个文件的内容,profile文件有点类似于windows系统里面的环境变量的配置,
   shift + g 定位到最后一行
        这个时候按一下a或i键,进入编辑模式
中间用红色的线圈起来的就是需要加的( JAVA_HOME  是jdk安装目录,和在Windows下配置一样 )
export JAVA_HOME=/usr/local/software/jdk/jdk1..0_221
export PATH=$PATH:$JAVA_HOME/bin
export CLASSPATH=.:$JAVA_HOME/lib/dt.jar:$JAVA_HOME/lib/tools.jar

第六步:退出文件,保存

     按Esc键   输入:wq   保存并退出
第七步:让配置文件生效
 [root@bogon jdk]# source /etc/profile
第八步:查看是否配置成功
    [root@bogon java1.8]# java -version     
 若出现jdk版本号,则安装并配置环境变量成功
     如果提示命令找不到的话,查看一下jdk的配置路径是否错误。
 

2. Tomcat安装配置

1,下载Tomcat链接,到启动测试。

将文件apache-tomcat-8.5.50.tar.gz移动到/usr/tomcat/下,并解压

mkdir /usr/local/tomcat创建文件夹
mv apache-tomcat-8.5.50 /usr/local/tomcat/移动到目录下
tar -zxvf apache-tomcat-8.5.50.tar.gz解压
 [root@VM_0_3_centos ~]# mv apache-tomcat-8.5.50.tar.gz /usr/local/tomcat/
[root@VM_0_3_centos ~]# cd /usr/local/tomcat/
[root@VM_0_3_centos tomcat]# ll
-rw-r--r-- 1 root root 10305939 Dec 18 09:33 apache-tomcat-8.5.50.tar.gz
[root@VM_0_3_centos tomcat]# tar -zxvf apache-tomcat-8.5.50.tar.gz
apache-tomcat-8.5.50/conf/
apache-tomcat-8.5.50/conf/catalina.policy
apache-tomcat-8.5.50/conf/catalina.properties
apache-tomcat-8.5.50/conf/context.xml
apache-tomcat-8.5.50/conf/jaspic-providers.xml
apache-tomcat-8.5.50/conf/jaspic-providers.xsd
apache-tomcat-8.5.50/conf/logging.properties
apache-tomcat-8.5.50/conf/server.xml。。。。。。。

进入tomcat目录下bin 启动startup.sh

./startup.sh执行文件

[root@VM_0_3_centos tomcat]# cd apache-tomcat-8.5.50/bin
[root@VM_0_3_centos bin]# ll | grep startup.sh
-rwxr-x--- 1 root root 1904 Dec 8 03:21 startup.sh
[root@VM_0_3_centos bin]# ./startup.sh
Using CATALINA_BASE: /usr/local/tomcat/apache-tomcat-8.5.50
Using CATALINA_HOME: /usr/local/tomcat/apache-tomcat-8.5.50
Using CATALINA_TMPDIR: /usr/local/tomcat/apache-tomcat-8.5.50/temp
Using JRE_HOME: /usr/local/src/java/jdk1.8.0_221
Using CLASSPATH: /usr/local/tomcat/apache-tomcat-8.5.50/bin/bootstrap.jar:/usr/local/tomcat/apache-tomcat-8.5.50/bin/tomcat-juli.jar
Tomcat started.
[root@VM_0_3_centos bin]#

启动tomcat,分别进入tomcat里面的bin目录

  执行: ./startup.sh  -->启动tomcat

  执行: ./shutdown.sh  -->关闭tomcat

本地浏览器输入http://localhost:8080/查看信息(如果不是本机则输入对应IP,我是用的腾讯云服务器公网IP111.229.52.48:8080)

如果是虚拟机输入ifconfig查看IP   ***ip*****

[root@VM_0_3_centos bin]# ifconfig
eth0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST> mtu 1500
inet ****ip***** netmask 255.255.240.0
inet6 fe80::5054:ff:feaa:20b6 prefixlen 64 scopeid 0x20<link>
ether 52:54:00:aa:20:b6 txqueuelen 1000 (Ethernet)
RX packets 7907667 bytes 1996512440 (1.8 GiB)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 7372298 bytes 1070200227 (1020.6 MiB)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0 lo: flags=73<UP,LOOPBACK,RUNNING> mtu 65536
inet 127.0.0.1 netmask 255.0.0.0
inet6 ::1 prefixlen 128 scopeid 0x10<host>
loop txqueuelen 1000 (Local Loopback)
RX packets 9054 bytes 685322 (669.2 KiB)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 9054 bytes 685322 (669.2 KiB)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

tomcat安装完成,我们可能下面需要修改查看文件。

2,查看端口占用以及端口详情

tomcat默认端口为8080,如被占用,则需修改tomcat的端口配置

查看所有端口:netstat -ntpl

查看8080端口是否被占用:netstat -tunlp | grep 8080 或 lsof -i:8080 (注:如果提示没有lsof命令,则使用 yum install lsof 进行安装 )

则表示进程ID为20593 的进程占用了8080端口,

如查看占用8080端口的进程的详细情况,则使用:

ps -aux | grep 20593
[root@VM_0_3_centos ~]# netstat -ntpl | grep 8080
tcp6 0 0 :::8080 :::* LISTEN /java
[root@VM_0_3_centos ~]# lsof -i:8080
COMMAND   PID USER   FD   TYPE   DEVICE SIZE/OFF NODE NAME
java    root   53u  IPv6 14398904      0t0  TCP *:webcache (LISTEN)
[root@VM_0_3_centos ~]# ps -aux | grep 20593
root     20593  0.2  9.9 2306948 100728 ?      Sl   10:14   0:05 /usr/local/src/java/jdk1.8.0_221/bin/java -Djava.util.logging.config.
file=/usr/local/tomcat/apache-tomcat-8.5.50/conf/logging.properties -Djava.util.logging.manager=org.apache.juli.ClassLoaderLogManager -Djdk.tls.ephemeralDHKeySize=2048 -Djava.protocol.handler
.pkgs=org.apache.catalina.webresources -Dorg.apache.catalina.security.SecurityListener.UMASK=0027 -Dignore.endorsed.dirs= -classpath /usr/local/tomcat/apache-tomcat-8.5.50/bin/bootstrap.j
ar:/usr/local/tomcat/apache-tomcat-8.5.50/bin/tomcat-juli.jar -Dcatalina.base=/usr/local/tomcat/apache-tomcat-8.5.50 -Dcatalina.home=/usr/local/tomcat/apache-tomcat-8.5.50 -Djava.io.tmpdir=
/usr/local/tomcat/apache-tomcat-8.5.50/temp org.apache.catalina.startup.Bootstrap start
root     25443  0.0  0.0 112712   964 pts/0    R+   10:51   0:00 grep --color=auto 20593
[root@VM_0_3_centos ~]#

表示运行的 tomcat/apache-tomcat 的进程占用了 8080端口,

如需kill该进程释放端口,则使用 kill -9   关闭进程20593

如占用8080端口的不是tomcat,也不需要kill该进程的话,则需更改tomcat的端口配置

3,tomcat端口配置,修改tomcat里面conf/server.xml

  vi conf/server.xml

  server.xml文件中有三个端口设置:

  <Server port="8005" shutdown="SHUTDOWN"> :关闭时使用

  <Connector port="8080" protocol="HTTP/1.1" connectionTimeout="20000" redirectPort="8443" /> : 一般应用使用

  <Connector port="8009" protocol="AJP/1.3" redirectPort="8443" />:为AJP端口,即容器使用,如 APACHE能通过AJP协议访问Tomcat的8009端口

4,设置tomcat开机启动

   1、找到/etc文件夹下的rc.local文件(有的是在/etc/rc.d文件夹下),在文件的最后添加以下java环境变量和启动tomcat命令:

   修改脚本文件vi /etc/rc.d/rc.local

    export JAVA_HOME=/usr/java/jdk1.8.0_211

    export JRE_HOME=$JAVA_HOME/jre

    sh /usr/tomcat/apache-tomcat-9.0.20/bin/startup.sh

 2,Esc保存退出  :wq

    给rc.local文件添加执行权限

    chmod +x etc/rc.d/rc.local

   3,重启服务器,即可访问Tomcat

    reboot

 PS:如若访问不了,有可能是防火墙开启的原因,则需关闭防火墙

  systemctl status firewalld  查看防火墙状态,如果开启则需关闭
  systemctl stop firewalld 暂时关闭防火墙
  systemctl disable firewalld 永久关闭防火墙

3.mysql安装使用

1.清理环境

  centos7会自带一个mariadb

   查看是否已安装

rpm -qa |grep -i mysql

rpm -qa |grep -i mariadb(centos7默认系统自带的)

  mariadb是从mysql来的,是它的一个分支,需要清理掉清理掉mariadb包

   rpm -e 加上包名,把mariadb包清掉

 rpm -e mariadb-libs-5.5.56-2.el7.x86_64

    可以看到用rpm删除会失败,提示有依赖关系的软件需要安装

    rpm删除时如果有依赖关系,可以用yum remove + 包名来删除mariadb

2.开始安装:.

下次安装写这个一样https://www.cnblogs.com/xiaxiaoxu/p/9978976.html

5.无法用软件链接,出现MySQL ERROR 1130 : Host 'XXXX' is not allowed to connect to this MySQL server

mysql -u root -proot
mysql>use mysql;
mysql>update user set host = '%' where user = 'root';
  ERROR 1062 (23000): Duplicate entry '%-root' for key 'PRIMARY' 不予理会
mysql>flush privileges; 
mysql>select host, user from user;
mysql>quit
information_schema存一些统计数据

performance_schema存一些状态数据,

mysql存的数据用于监控、权限、账号等

test是测试库,用于做测试用的

4.LINUX安装nginx

centens安装

1.安装依赖包

//一键安装上面四个依赖
yum -y install gcc zlib zlib-devel pcre-devel openssl openssl-devel

2.下载并解压安装包

//创建一个文件夹
cd /usr/local
mkdir nginx
cd nginx
//下载tar包
wget http://nginx.org/download/nginx-1.13.7.tar.gz
tar -xvf nginx-1.13..tar.g

3.安装nginx

  1. //进入nginx目录 ,自己目录
  2. cd /usr/local/nginx
  3. //执行命令
  4. ./configure
  5. //执行make命令
  6. make
  7. //执行make install命令
  8. make install

4.配置nginx.conf  详细看nginx配置文件 通过域名访问

# 打开配置文件
vi /usr/local/nginx/conf/nginx.conf

将端口号改成8089,因为可能apeache占用80端口,apeache端口尽量不要修改,我们选择修改nginx端口。

localhost修改为你服务器ip地址。

5.启动nginx

/usr/local/nginx/sbin/nginx -s reload

 查看nginx进程是否启动:

 ps -ef | grep nginx

 

 

Linux Tomcat安装及端口配置的更多相关文章

  1. 【Linux】Tomcat安装及端口配置

    安装环境 :Linux(CentOS 64位) 安装软件 : apache-tomcat-9.0.20.tar.gz(下载地址http://tomcat.apache.org/) 一:JDK安装配置 ...

  2. Linux Tomcat安装,Linux配置Tomcat,Linux Tomcat修改内存,Linux tomcat修改端口

    Linux Tomcat安装,Linux配置Tomcat,Linux Tomcat修改内存,Linux tomcat修改端口 >>>>>>>>>& ...

  3. 【转】linux 编译安装nginx,配置自启动脚本

    linux 编译安装nginx,配置自启动脚本 本文章来给各位同学介绍一篇关于linux 编译安装nginx,配置自启动脚本教程,希望有需要了解的朋友可一起来学习学习哦. 在公司的suse服务器装ng ...

  4. linux 编译安装nginx,配置自启动脚本

    本文章来给各位同学介绍一篇关于linux 编译安装nginx,配置自启动脚本教程,希望有需要了解的朋友可一起来学习学习哦. 在公司的suse服务器装nginx,记录下安装过程: 参照这篇文章:Linu ...

  5. linux 下安装jdk及配置jdk环境图解

    linux 下安装jdk及配置jdk环境图解 一:先检測是否已安装了JDK 运行命令: # rpm -qa|grep jdk  或   # rpm -q jdk  或  #find / -name j ...

  6. Linux下安装Java环境配置

    1.下载安装文件 下载地址:http://www.oracle.com/technetwork/java/javase/downloads/jdk8-downloads-2133151.html 2. ...

  7. Linux Tomcat安装部署项目

    一.上传Tomcat服务器

  8. tomcat安装以及常用配置

    目录 一 什么是tomcat 二 tomcat 的版本: 三 tomcat的下载 3.1 tomcat9版本下载链接 3.2 tomcat8.5版本下载链接 四 tomcat的安装 4.1 java环 ...

  9. linux下安装nginx和配置

    1.系统:centos6.8 2.安装准备: 安装nginx前,我们首先要确保系统安装了g++.gcc.openssl-devel.pcre-devel和zlib-devel软件,可通过如图所示命令进 ...

随机推荐

  1. es6模块化规范

    在 es6 之前是没有块这个概念的,es6zhong 引入:实际如下: 若 xx1 和 xx2 中有变量名相同,且引入在同一 html 下,需要为引入的 script 标签加上 type=“modul ...

  2. Cannot resolve reference to bean 'mongoTemplate' while setting bean property 'mongoOperations'; nested exception is org.springframework.beans.factory.BeanCreationException: Error creating bean with na

    问题: Springboot 启动时出错,报没法创建bean的错误,看到nested最后是关于mongoTemplate的错误. 过程: 看网上大多说的是修改mongoTemplate的配置,但是sp ...

  3. requests获取图片的宽和高

    try: if cover: resp = requests.get('%s?x-oss-process=image/info' % (url), timeout=30) if resp.status ...

  4. how to design AWS SQS?

    遇到这么一题system design,怎么做? 几个月以前,有同事提出要用Webapi代替现有的WCF,当时我投的反对票.而且我给了很充分的理由,不仅仅是时间不足,人手不够,更重要的是这个变化太大, ...

  5. 戴尔灵越14燃5488安装LTSC2019

     戴尔笔记本应该改成ahci模式之后再进行分区和重装系统操作,否则很难折腾的 戴尔灵越14燃5488不能安装LTSB2016,因为显卡驱动不支持,安装LTSC2019可以,亲测. 这款笔本似乎NVME ...

  6. Linux性能优化实战学习笔记:第五十一讲

    一.上节回顾 上一节,我带你一起学习了常见的动态追踪方法.所谓动态追踪,就是在系统或者应用程序正常运行的时候,通过内核中提供的探针,来动态追踪它们的行为,从而辅助排查出性能问题的瓶颈. 使用动态追踪, ...

  7. [LeetCode] 4. Median of Two Sorted Arrays 两个有序数组的中位数

    There are two sorted arrays nums1 and nums2 of size m and n respectively. Find the median of the two ...

  8. [转]Visual Studio 2017各版本安装包离线下载、安装全解析

    Visual Studio 2017各版本安装包离线下载.安装全解析 2017-3-10 11:15:03来源:IT之家作者:寂靜·櫻花雨责编:晨风评论:165   感谢IT之家网友 寂靜·櫻花雨的投 ...

  9. 本地搭建WordPress (XAMPP环境)

    1,XAMPP是一个流行的PHP开发环境,官网下载: https://www.apachefriends.org/zh_cn/index.html 然后安装. 官方介绍:XAMPP是最流行的PHP开发 ...

  10. torch_07_卷积神经网络案例分析

    1. LeNet(1998) """ note: LeNet: 输入体:32*32*1 卷积核:5*5 步长:1 填充:无 池化:2*2 代码旁边的注释:卷积或者池化后的 ...