安装 
https://www.jianshu.com/p/875457cb8da6
 

操作系统:Linux

kibana 版本: 7.4.0

1. 在/etc/yum.repos.d/ 下新建 kibana.repo  配置 yum 源地址 内容如下:

[root@localhost yum.repos.d]# cat kibana.repo
[kibana-7.x]
name=Kibana repository for 7.x packages
baseurl=https://artifacts.elastic.co/packages/7.x/yum
gpgcheck=1
gpgkey=https://artifacts.elastic.co/GPG-KEY-elasticsearch
enabled=1
autorefresh=1
type=rpm-md

2. 安装 kibana

sudo yum install kibana

3. 安装完成之后,kibana 的相关目录如下所示:

4. 修改配置文件 ,主要是添加 elasticsearch 的信息:

server.port: 5601
server.host: "127.0.0.1"
server.name: "tanklog"
elasticsearch.url: "http://127.0.0.1:9200"

5. 启动 kibana (由于 root 用户不能直接启动 kibana,可以新建一个用户专门用来管理 kibana,或者在启动命令后追加 --allow-root)

/usr/share/kibana/bin/kibana --allow-root

6. 然后会报错如下:

FATAL  Error: [elasticsearch.url]: definition for this key is missing

7. 经过一波操作之后,发现需要将 url 换成 hosts,配置文件需要设置为如下所示:

需要用: elasticsearch.hosts, 而不是: elasticsearch.url

server.port: 5601
server.host: "127.0.0.1"
server.name: tanklog
elasticsearch.hosts: ["http://localhost:9200/"]
# elasticsearch.url: "http://localhost:9200"

8. kibana 本身没问题,启动成功时会出现如下日志:

[root@localhost kibana]#  /usr/share/kibana/bin/kibana --allow-root
log [08:41:50.254] [info][plugins-system] Setting up [4] plugins: [security,translations,inspector,data]
log [08:41:50.263] [info][plugins][security] Setting up plugin
log [08:41:50.266] [warning][config][plugins][security] Generating a random key for xpack.security.encryptionKey. To prevent sessions from being invalidated on restart, please set xpack.security.encryptionKey in kibana.yml
log [08:41:50.266] [warning][config][plugins][security] Session cookies will be transmitted over insecure connections. This is not recommended.
log [08:41:50.325] [info][plugins][translations] Setting up plugin
log [08:41:50.326] [info][data][plugins] Setting up plugin
log [08:41:50.328] [info][plugins-system] Starting [3] plugins: [security,translations,data]
log [08:42:15.769] [warning][plugin] Skipping non-plugin directory at /usr/share/kibana/src/legacy/core_plugins/metric_vis
log [08:42:15.832] [warning][plugin] Skipping non-plugin directory at /usr/share/kibana/src/legacy/core_plugins/table_vis
log [08:42:15.833] [warning][plugin] Skipping non-plugin directory at /usr/share/kibana/src/legacy/core_plugins/tagcloud
log [08:42:15.910] [warning][plugin] Skipping non-plugin directory at /usr/share/kibana/src/legacy/core_plugins/vega
log [08:42:17.487] [info][status][plugin:kibana@7.4.0] Status changed from uninitialized to green - Ready
log [08:42:17.494] [info][status][plugin:elasticsearch@7.4.0] Status changed from uninitialized to yellow - Waiting for Elasticsearch
log [08:42:17.496] [info][status][plugin:xpack_main@7.4.0] Status changed from uninitialized to yellow - Waiting for Elasticsearch
log [08:42:17.508] [info][status][plugin:telemetry@7.4.0] Status changed from uninitialized to green - Ready
log [08:42:17.511] [info][status][plugin:graph@7.4.0] Status changed from uninitialized to yellow - Waiting for Elasticsearch
log [08:42:17.525] [info][status][plugin:monitoring@7.4.0] Status changed from uninitialized to green - Ready
log [08:42:17.529] [info][status][plugin:spaces@7.4.0] Status changed from uninitialized to yellow - Waiting for Elasticsearch
log [08:42:17.563] [info][status][plugin:security@7.4.0] Status changed from uninitialized to green - Ready
log [08:42:17.565] [info][status][plugin:searchprofiler@7.4.0] Status changed from uninitialized to yellow - Waiting for Elasticsearch
log [08:42:17.568] [info][status][plugin:ml@7.4.0] Status changed from uninitialized to yellow - Waiting for Elasticsearch
log [08:42:17.635] [info][status][plugin:tilemap@7.4.0] Status changed from uninitialized to yellow - Waiting for Elasticsearch
log [08:42:17.638] [info][status][plugin:watcher@7.4.0] Status changed from uninitialized to yellow - Waiting for Elasticsearch
log [08:42:17.654] [info][status][plugin:grokdebugger@7.4.0] Status changed from uninitialized to yellow - Waiting for Elasticsearch
log [08:42:17.660] [info][status][plugin:dashboard_mode@7.4.0] Status changed from uninitialized to green - Ready
log [08:42:17.662] [info][status][plugin:logstash@7.4.0] Status changed from uninitialized to yellow - Waiting for Elasticsearch
log [08:42:17.670] [info][status][plugin:beats_management@7.4.0] Status changed from uninitialized to yellow - Waiting for Elasticsearch
log [08:42:17.689] [info][status][plugin:apm_oss@7.4.0] Status changed from uninitialized to green - Ready
log [08:42:17.727] [info][status][plugin:apm@7.4.0] Status changed from uninitialized to green - Ready
log [08:42:17.729] [info][status][plugin:code@7.4.0] Status changed from uninitialized to green - Ready
log [08:42:17.731] [info][status][plugin:data@7.4.0] Status changed from uninitialized to green - Ready
log [08:42:17.733] [info][status][plugin:visualizations@7.4.0] Status changed from uninitialized to green - Ready
log [08:42:17.740] [info][status][plugin:interpreter@7.4.0] Status changed from uninitialized to green - Ready
log [08:42:17.742] [info][status][plugin:tile_map@7.4.0] Status changed from uninitialized to green - Ready
log [08:42:17.746] [info][status][plugin:task_manager@7.4.0] Status changed from uninitialized to green - Ready
log [08:42:17.751] [info][status][plugin:maps@7.4.0] Status changed from uninitialized to yellow - Waiting for Elasticsearch
log [08:42:17.770] [info][status][plugin:canvas@7.4.0] Status changed from uninitialized to green - Ready
log [08:42:17.776] [info][status][plugin:license_management@7.4.0] Status changed from uninitialized to green - Ready
log [08:42:17.779] [info][status][plugin:cloud@7.4.0] Status changed from uninitialized to green - Ready
log [08:42:17.781] [info][status][plugin:index_management@7.4.0] Status changed from uninitialized to yellow - Waiting for Elasticsearch
log [08:42:17.799] [info][status][plugin:console@7.4.0] Status changed from uninitialized to green - Ready

9. 由于我的 elasticsearch 版本是7.3.2, 与 kibana 版本不一致,所以启动过程中出现了 error, 需要升级 elasticsearch 版本为 7.4.0

g   [08:42:18.088] [info][status][plugin:table_vis@7.4.0] Status changed from uninitialized to green - Ready
log [08:42:18.090] [info][status][plugin:tagcloud@7.4.0] Status changed from uninitialized to green - Ready
log [08:42:18.092] [info][status][plugin:vega@7.4.0] Status changed from uninitialized to green - Ready
log [08:42:18.096] [warning][browser-driver][reporting] Enabling the Chromium sandbox provides an additional layer of protection.
log [08:42:19.041] [error][status][plugin:xpack_main@7.4.0] Status changed from yellow to red - This version of Kibana requires Elasticsearch v7.4.0 on all nodes. I found the following incompatible nodes in your cluster: v7.3.2 @ 192.168.1.27:9200 (192.168.1.27)
log [08:42:19.042] [error][status][plugin:graph@7.4.0] Status changed from yellow to red - This version of Kibana requires Elasticsearch v7.4.0 on all nodes. I found the following incompatible nodes in your cluster: v7.3.2 @ 192.168.1.27:9200 (192.168.1.27)

升级 elasticsearch 版本

sudo yum -y install elasticsearch-oss

10. 启动 kibana,查看日志信息,发现有很多 warn

[warning][config][plugins][security] Generating a random key for xpack.security.encryptionKey. To prevent sessions from being invalidated on restart, please set xpack.security.encryptionKey in kibana.yml

根据 warn 提示,在 kibana.yml 里面添加缺失的属性内容

xpack.reporting.encryptionKey: "a_random_string"
xpack.security.encryptionKey: "something_at_least_32_characters"

启动 kibana,且将启动日志收集到指定文件

/usr/share/kibana/bin/kibana --allow-root > /var/lib/kibana/kibana.log &

访问

原文 https://www.cnblogs.com/miaoying/p/11639437.html

kinaba 安装踩坑: FATAL Error: [elasticsearch.url]: definition for this key is missing 转的更多相关文章

  1. kinaba 安装踩坑: FATAL Error: [elasticsearch.url]: definition for this key is missing

    操作系统:Linux kibana 版本: 7.4.0 1. 在/etc/yum.repos.d/ 下新建 kibana.repo  配置 yum 源地址 内容如下: [root@localhost ...

  2. Android Studio安装踩坑

    title: Android Studio安装踩坑 date: 2018-09-07 19:31:32 updated: tags: [Android,Android Studio,坑] descri ...

  3. Nextcloud fpm 版在 Dokcer 下安装踩坑

    安装 首先到 https://registry.hub.docker.com/_/nextcloud 获取 Nextcloud 的示例 docker-compose version: '2' volu ...

  4. Symfony没有安装依赖_PHP Fatal error: require(): Failed opening required

    $ php bin/console server:run PHP Warning: require(D:\home\workspace\pd\app/../vendor/autoload.php): ...

  5. VNPY - windows 安装踩坑记录

    twisted requires PyHamcrest>=, which is not ins grin requires argparse>=1.1, which is not inst ...

  6. python2用pip进行安装时报错Fatal error in launcher: Unable to create process using '"'

    win7下python3和python2共存环境 用pip安装一个包执行pip2 install xxx的时候报错Fatal error in launcher: Unable to create p ...

  7. ubuntu 16.04 + eigen3 安装(解决 fatal error: Eigen/Core: No such file or directory)

    1.安装 sudo apt-get install libeigen3-dev 2. 解决 fatal error: Eigen/Core: No such file or directory 当调用 ...

  8. deepin 安装scrapy安装出错:fatal error: Python.h 的解决办法

    环境deepin Linux 15.7 Python3.6.5 今天重新装了deepin系统,需要重新安装scrapy,直接pip了一下,没成. 报错:fatal error: Python.h: 没 ...

  9. 全文搜索引擎 Elasticsearch 安装踩坑记录

    一.安装 Elastic 需要 Java 8 环境.如果你的机器还没安装 Java 安装完 Java,就可以跟着官方文档安装 Elastic.直接下载压缩包比较简单. $ wget https://a ...

随机推荐

  1. Linux:nginx基础

    一..简单介绍 nginx时开源的www服务器,只能解析静态的网页(html,js,css等),具有静态小文件高并发特性. 可做web服务器.负载均衡.web cache(web缓存) 优点: 1.高 ...

  2. html基础:js

    js是一种脚本语言.在html中起到操控行为的作用.在html中,html代码如果是一个人的话,那么js就是这个人的行为 js在html的head中被引用,也可以在body中被引用.引用方式用< ...

  3. Python 字符串去除相邻重复的元素

    1 def quchong(S): 2 str1=[""] 3 for i in S: 4 if i == str1[-1]: 5 str1.pop() 6 else: 7 str ...

  4. 【python练习册】1.3 将1.2题生成的n个激活码保存到mysql关系型数据库中

    该题涉及到mysql中一些指令,先熟悉一下 MySQL指令 参考:https://www.cnblogs.com/zhuyongzhe/p/7686105.html mysql -u root -p ...

  5. pytest测试框架 -- skip跳过执行测试用例

      跳过执行测试用例 1.@pytest.mark.skip(reason=" ") -- 跳过执行测试函数 可传入一个非必须参数reason表示原因 import pytest@ ...

  6. [程序员代码面试指南]二叉树问题-在二叉树中找到两个节点的最近公共祖先、[LeetCode]235. 二叉搜索树的最近公共祖先(BST)(非递归)

    题目 题解 法一: 按照递归的思维去想: 递归终止条件 递归 返回值 1 如果p.q都不在root为根节点的子树中,返回null 2 如果p.q其中之一在root为根节点的子树中,返回该节点 3 如果 ...

  7. 10月1日之后,你新建的GitHub库默认分支不叫「master」了

    从 2020 年 10 月 1 日开始,GitHub 上的所有新库都将用中性词「main」命名,取代原来的「master」,因为后者是一个容易让人联想到奴隶制的术语. 这个决定并不是最近才做出的.今年 ...

  8. Java基础一篇过(四)List这篇就够了

    文章更新时间:2020/08/03 一.List介绍 list是Java的一个接口,继承了Collection,常用到的有3个子类实现: ArrayList 底层数据结构是数组.线程不安全 Linke ...

  9. 堆的源码与应用:堆排序、优先队列、TopK问题

    1.堆 堆(Heap))是一种重要的数据结构,是实现优先队列(Priority Queues)首选的数据结构.由于堆有很多种变体,包括二项式堆.斐波那契堆等,但是这里只考虑最常见的就是二叉堆(以下简称 ...

  10. Harbor介绍与企业级私有Docker镜像仓库搭建

    Harbor介绍与安装部署,并实现通过http和https协议[自签发SSL证书]访问,客户端如何通过Harbor镜像仓库实现镜像的上传[推送]与下载[拉取]. Harbor介绍 Harbor,是一个 ...