由于我们有时候没法预估或者说错误的盘符分区的时候,常常会导致我们后面的操作出现极大的不方便,这里我就记录下一个错误分区后对home和根分区存储空间大小调整的整个过程!
  
  ①查看我们现有机器的分区状况

centos下载:http://www.gooln.com/other/8820.html

[root@weidianserver2 ~]# df -h
Filesystem                             Size  Used Avail Use% Mounted on
/dev/mapper/vg_weidianserver2-lv_root   50G   44G  2.8G  95% /
tmpfs                                  7.8G   72K  7.8G   1% /dev/shm
/dev/sda1                              485M   39M  421M   9% /boot
/dev/mapper/vg_weidianserver2-lv_home  860G  4.4G  812G   1% /home

  我们能发现根分区和home分区产生极大的不合理性,所以在这里我们将对home分区缩小存储并把压缩出来的存储添加到root下!
  
  ②首先卸载我们的home分区,并压缩我们的home分区大小

[root@weidianserver2 ~]#  umount /home
[root@weidianserver2 ~]# df -h
Filesystem                             Size  Used Avail Use% Mounted on
/dev/mapper/vg_weidianserver2-lv_root   50G   44G  2.8G  95% /
tmpfs                                  7.8G   72K  7.8G   1% /dev/shm
/dev/sda1                              485M   39M  421M   9% /boot
[root@weidianserver2 ~]# resize2fs -p /dev/mapper/vg_weidianserver2-lv_home 20G
resize2fs 1.41.12 (17-May-2010)
请先运行 'e2fsck -f /dev/mapper/vg_weidianserver2-lv_home'.

[root@weidianserver2 ~]# e2fsck -f /dev/mapper/vg_weidianserver2-lv_home
e2fsck 1.41.12 (17-May-2010)
第一步: 检查inode,块,和大小
第二步: 检查目录结构
第3步: 检查目录连接性
Pass 4: Checking reference counts
第5步: 检查簇概要信息
/dev/mapper/vg_weidianserver2-lv_home: 330/57229312 files (3.9% non-contiguous), 4737926/228899840 blocks
[root@weidianserver2 ~]# resize2fs -p /dev/mapper/vg_weidianserver2-lv_home 20G
resize2fs 1.41.12 (17-May-2010)
Resizing the filesystem on /dev/mapper/vg_weidianserver2-lv_home to 5242880 (4k) blocks.
Begin pass 2 (max = 33784)
正在重定位块            XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX
Begin pass 3 (max = 6986)
正在扫描inode表          XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX
Begin pass 4 (max = 147)
正在更新inode引用       XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX
The filesystem on /dev/mapper/vg_weidianserver2-lv_home is now 5242880 blocks long.

③我们通过运行结果可以看到我们的将home压缩到20G,这个时候我们可以重新装载我们的home目录

[root@weidianserver2 ~]# mount /home
[root@weidianserver2 ~]# df -h
Filesystem                             Size  Used Avail Use% Mounted on
/dev/mapper/vg_weidianserver2-lv_root   50G   44G  2.8G  95% /
tmpfs                                  7.8G   72K  7.8G   1% /dev/shm
/dev/sda1                              485M   39M  421M   9% /boot
/dev/mapper/vg_weidianserver2-lv_home   20G  4.4G   15G  24% /home

这样对home的压缩并重新装载就完成了,如下图:

④我们上面的三步将home的块处理好了,但是我们的空闲硬盘并没有添加到root下,所以下面我们将压缩产生的磁盘添加到root下:

[root@localhost ~]# lvextend -L +812G /dev/mapper/vg_weidianserver2-lv_root
注:lvextend -L +283G为在文件系统上增加283G
[root@localhost ~]# resize2fs -p /dev/mapper/vg_weidianserver2-lv_root

在这个从新加载和挂载的过程中需要花费一点时间,不过我们也可以在这段时间中不断的查看盘符的大小,这个时候我们会发现root盘符的大小会一点点的增加上来,如下图:

从上图最后的结果我们可以看出我们将home中的空闲盘符压缩出812G添加到了root下面,这样我们的root的空间就瞬间增加了;最后感谢你的翻阅,如有疑问可以留言交流讨论,谢谢!

CentOS下调整home和根分区大小的更多相关文章

  1. 解决linux系统CentOS下调整home和根分区大小

    目标:将VolGroup-lv_home缩小到20G,并将剩余的空间添加给VolGroup-lv_root   1.首先查看磁盘使用情况 [root@localhost ~]# df -h 文件系统 ...

  2. CentOS下调整home和根分区大小的方法

    解决外挂硬盘的问题. 目标:将VolGroup-lv_home缩小到20G,并将剩余的空间添加给VolGroup-lv_root 1.首先查看磁盘使用情况[root@jb51.net~]# df -h ...

  3. 解决linux系统CentOS下调整home和根分区大小《转》

    转自http://www.php114.net/2013/1019/637.html 目标:将VolGroup-lv_home缩小到20G,并将剩余的空间添加给VolGroup-lv_root   1 ...

  4. Linux、CentOS系统下调整home和根分区大小

    1.首先查看磁盘使用情况 [root@localhost ~]# df -h 文件系统 容量 已用 可用 已用% 挂载点 Filesystem Size Used Avail Use% Mounted ...

  5. CentOS环境下下调整home和根分区大小

    项目建设方给提供了3台CentOS的服务器,连接进去之后发现磁盘空间很大,但是都放在了home目录下,所以需要调整一下. 1.查看磁盘使用情况 [root@CentOS ~]# df -h Files ...

  6. 调整home和根分区大小

    目标:将VolGroup-lv_home缩小到100G,并将剩余的空间添加给VolGroup-lv_root ============================================= ...

  7. 动态在线扩容root根分区大小的方法详解

    前言 本文主要介绍了关于动态在线扩容root根分区大小的相关内容,分享出来供大家参考学习,下面话不都说了,来一起看看详细的介绍吧. ? 1 qemu-img resize yourname.img + ...

  8. Linux(Centos)下调整分区大小(以home和根分区为例)

      在安装新系统的时候,有时候没法预估或者说错误的划分了分区大小,常常会导致我们后面的操作出现极大地不方便,比如某个分区分的太小了,导致 软件安装的时候会报安装空间不够,这就很麻烦.在这里我就记录一下 ...

  9. CentOS用gparted实现无损调整磁盘分区大小

    作者: sheldon 测试服务器硬盘挂载在/usr下的分区大小只有10G,随着必须软件都安装在这个目录下,这个分区已经满额,给分区扩容刻不容缓,window下有PQ分区工具,Linux下也有gpar ...

随机推荐

  1. leetcode-551-Student Attendance Record I(判断是否出现连续几个相同字符)

    题目描述: You are given a string representing an attendance record for a student. The record only contai ...

  2. 分享自建的 Jrebel License Server 激活 Jrebel

    使用在线验证服务器激活 Jrebel 与 Idea 说明 代码来自于开源项目: gsls200808 / JrebelLicenseServerforJava 自建的服务地址 http://jrebe ...

  3. 基础篇:3.2)规范化:3d零件建模

    本章目的:规范化零件建模,这是机械的基本功夫. 1.建模的总体原则和总体要求 1.1 建模总体原则 a)零件模型应能准确表达零件的设计信息:b)零件模型包含零件的几何要素.约束要素和工程要素:c)零件 ...

  4. 求最大公因数(辗转相除法&更相减损术)

    求最大公因数(辗转相除法&更相减损术) 辗转相除法 又名欧几里得算法 ,其原理其实是基于这个定理:\(gcd(a,b)=gcd(b,a\%b)\),详细证明,而任何数与0的最大公约数是它本身 ...

  5. app接口,如何保证是由app内部调用而非外部模拟post请求调用。

    在爬虫快手主播信息的时候,发现只要我改动一下参数,比如第一页 page=1的时候,需要爬下一页,把page改为2发现提示sign验证失败了 也就是说,快手在开发的时候考虑了有人抓包到接口后,通过修改参 ...

  6. centos 7编译安装apache

    1.安装工具和依赖包 yum install unzipyum -y install gcc gcc-c++ 2.创建软件安装目录mkdir /usr/local/{apr,apr-util,apr- ...

  7. Cloudera Manager安装之时间服务器和时间客户端(Ubuntu14.04)(二)

    第二步: Cloudera Manager安装之时间服务器和时间客户端(二) 找一台机器作为时间服务器 我这里,放到ubuntucmbigdata1这台机器! 注意,之前是已经做了集群时间同步了. 在 ...

  8. solr的安装及配置详细教程/solr入门教程

    1 solr的下载 从Solr官方网站(http://lucene.apache.org/solr/ )下载Solr最新版本,根据Solr的运行环境,Linux下需要下载solr-7.3.1.tgz, ...

  9. Java入门系列-20-异常

    为什么要进行异常处理 下面这段代码能否正常执行 public class DemoCalc { public static void main(String[] args) { int a=0; in ...

  10. Hbuilder编辑App时,ajax跨域访问失败问题

    今天试着用Hbuilder写app的前段显示页面,在第一步时就被打住了,ajax异步调用服务器的登录接口时,报错, 显示这样的错误 XMLHttpRequest cannot loadhttp://w ...