MySQL5.6自动化部署(二进制)
###### 二进制自动安装数据库脚本root密码MANAGER将脚本和安装包放在/root目录即可###############
######数据库目录/usr/local/mysql############
######数据目录/data/mysql############
######日志目录/log/mysql############
######端口号默认3306其余参数按需自行修改############
##################
#author:rrhelei@126.com#
##################
#!/bin/bash
PATH=/bin:/sbin:/usr/bin:/usr/sbin:/opt/bin:/opt/sbin:~/bin
exportPATH
# Checkif user is root
if [ $(id-u) != "0" ]; then
echo "Error: You must be root to runthis script, please use root to install"
exit 1
fi
clear
echo"========================================================================="
echo"A tool to auto-compile & install MySQL 5.6.25 on Redhat/CentOS Linux"
echo"========================================================================="
cur_dir=$(pwd)
#setmysql root password
echo "==========================="
mysqlrootpwd="MANAGER"
echo -e "Please input the root password of mysql:"
read -p "(Default password: MANAGER):" mysqlrootpwd
if [ "$mysqlrootpwd" = "" ]; then
mysqlrootpwd="MANAGER"
fi
echo "==========================="
echo "MySQL root password:$mysqlrootpwd"
echo "==========================="
#whichMySQL Version do you want to install?
echo"==========================="
isinstallmysql56="n"
echo "Install MySQL 5.6.25,Please input y"
read -p "(Please input y , n):" isinstallmysql56
case "$isinstallmysql56" in
y|Y|Yes|YES|yes|yES|yEs|YeS|yeS)
echo "You will install MySQL 5.6.25"
isinstallmysql56="y"
;;
*)
echo "INPUT error,You will exit install MySQL 5.6.25"
isinstallmysql56="n"
exit
esac
get_char()
{
SAVEDSTTY=`stty -g`
stty -echo
stty cbreak
#dd if=/dev/tty bs=1 count=1 2> /dev/null
stty -raw
stty echo
stty $SAVEDSTTY
}
echo ""
echo "Press any key to start...or Press Ctrl+c to cancel"
char=`get_char`
#Initialize the installation relatedcontent.
functionInitInstall()
{
cat /etc/issue
uname -a
MemTotal=`free -m | grep Mem | awk '{print $2}'`
echo -e "\n Memory is: ${MemTotal} MB "
#Set timezone
rm -rf /etc/localtime
ln -s /usr/share/zoneinfo/Asia/Shanghai /etc/localtime
#Delete Old Mysql program
rpm -qa|grep mysql
rpm -e mysql
#yum -y remove mysql-server mysql mysql-libs
#yum -y remove php-mysql
#yum -y install yum-fastestmirror
#yum -y update
#Disable SeLinux
if [ -s /etc/selinux/config ]; then
sed -i 's/SELINUX=enforcing/SELINUX=disabled/g' /etc/selinux/config
fi
setenforce 0
}
#Installationof depend on and optimization options.
functionInstallDependsAndOpt()
{
cd$cur_dir
cat>>/etc/security/limits.conf<<EOF
* softnproc 65535
* hardnproc 65535
* softnofile 65535
* hardnofile 65535
EOF
echo"fs.file-max=65535" >> /etc/sysctl.conf
}
#InstallMySQL
functionInstallMySQL56()
{
echo"============================Install MySQL5.6.22=================================="
cd$cur_dir
#Backupold my.cnf
#rm -f/etc/my.cnf
if [ -s/etc/my.cnf ]; then
mv /etc/my.cnf /etc/my.cnf.`date+%Y%m%d%H%M%S`.bak
fi
#mysqldirectory configuration
groupadd mysql -g 512
useradd -u 512 -g mysql -s /sbin/nologin -d /home/mysql mysql
tar xvf/root/mysql-5.6.25-linux-glibc2.5-x86_64.tar.gz
mv /root/mysql-5.6.25-linux-glibc2.5-x86_64 /usr/local/mysql
mkdir -p/data/mysql
mkdir -p/log/mysql
chown -Rmysql:mysql /data/mysql
chown -Rmysql:mysql /usr/local/mysql
chown -Rmysql:mysql /log
#ln -s/usr/local/mysql-5.6.16 /usr/local/mysql
#if [ -d/data ] && [ -d /log ];then
# ln -s /data /opt/mysql/data
# ln -s /log /opt/mysql/log
# mkdir -p /opt/mysql/run
#else
# mkdir -p /opt/mysql/{data,log,run}
#fi
#if [ -d/data ] && [ -d /log ];then
# chown -R mysql.mysql /opt/mysql
# chown -R mysql.mysql /data
# chown -R mysql.mysql /log
#fi
#edit/etc/my.cnf
SERVERID=`ifconfigeth0 | grep "inet addr" | awk '{ print $2}'| awk -F. '{ print$4"3306"}'`
cat>>/etc/my.cnf<<EOF
[client]
port =3306
socket =/tmp/mysql.sock
default-character-set=utf8
[mysql]
default-character-set=utf8
[mysqld]
port =3306
socket =/tmp/mysql.sock
basedir =/usr/local/mysql
datadir =/data/mysql
open_files_limit = 3072
back_log= 103
max_connections = 512
max_connect_errors= 100000
table_open_cache= 512
external-locking= FALSE
max_allowed_packet= 32M
sort_buffer_size= 2M
join_buffer_size= 2M
thread_cache_size= 51
query_cache_size= 32M
tmp_table_size= 96M
max_heap_table_size= 96M
slow_query_log= 1
slow_query_log_file= /log/mysql/slow.log
log-error= /log/mysql/error.log
long_query_time= 1
server-id= $SERVERID
log-bin =/log/mysql/mysql-bin
sync_binlog= 1
binlog_cache_size= 4M
max_binlog_cache_size= 8M
max_binlog_size= 1024M
expire_logs_days= 60
key_buffer_size= 32M
read_buffer_size= 1M
read_rnd_buffer_size= 16M
bulk_insert_buffer_size= 64M
character-set-server=utf8
default-storage-engine= InnoDB
binlog_format= row
innodb_buffer_pool_dump_at_shutdown = 1
innodb_buffer_pool_load_at_startup = 1
binlog_rows_query_log_events = 1
#log_slave_updates=1
#gtid_mode=on
#enforce_gtid_consistency=1
transaction_isolation= REPEATABLE-READ
innodb_additional_mem_pool_size= 16M
innodb_buffer_pool_size = 512M
#innodb_data_home_dir=
innodb_data_file_path= ibdata1:1024M:autoextend
innodb_flush_log_at_trx_commit= 1
innodb_log_buffer_size= 16M
innodb_log_file_size= 512M
innodb_log_files_in_group= 2
innodb_max_dirty_pages_pct= 50
innodb_file_per_table= 1
innodb_locks_unsafe_for_binlog= 0
wait_timeout= 300
interactive_timeout = 300
skip-name-resolve
[mysqldump]
quick
max_allowed_packet= 32M
EOF
/usr/local/mysql/scripts/mysql_install_db--basedir=/usr/local/mysql --datadir=/data/mysql --defaults-file=/etc/my.cnf--user=mysql
cp /usr/local/mysql/support-files/mysql.server /etc/init.d/mysqld
chmod 700/etc/init.d/mysqld
chkconfig --add mysql
chkconfig --level 2345 mysqld on
cat>> /etc/ld.so.conf.d/mysql-x86_64.conf<<EOF
/usr/local/mysql/lib
EOF
ldconfig
if [ -d"/proc/vz" ];then
ulimit -sunlimited
fi
/etc/init.d/mysqldstart
cat>> /etc/profile <<EOF
export PATH=/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin:/root/bin:/usr/local/mysql/bin:/usr/local/mysql/lib
export LD_LIBRARY_PATH=/usr/local/mysql/lib
EOF
/usr/local/mysql/bin/mysqladmin-u root password $mysqlrootpwd
cat >/tmp/mysql_sec_script<<EOF
usemysql;
delete from mysql.user where user!='root' orhost!='localhost';
grant all privileges on *.* to 'sys_admin'@'%' identified by 'MANAGER';
flush privileges;
EOF
/usr/local/mysql/bin/mysql-u root -p$mysqlrootpwd -h localhost < /tmp/mysql_sec_script
#rm -f/tmp/mysql_sec_script
/etc/init.d/mysqldrestart
source/etc/profile
echo"============================MySQL 5.6.25 installcompleted========================="
}
functionCheckInstall()
{
echo"===================================== Check install==================================="
clear
ismysql=""
echo"Checking..."
if [ -s/usr/local/mysql/bin/mysql ] && [ -s /usr/local/mysql/bin/mysqld_safe ]&& [ -s /etc/my.cnf ]; then
echo "MySQL: OK"
ismysql="ok"
else
echo "Error: /usr/local/mysql notfound!!!MySQL install failed."
fi
if ["$ismysql" = "ok" ]; then
echo"Install MySQL 5.6.25 completed! enjoy it."
echo"========================================================================="
netstat-ntl
else
echo"Sorry,Failed to install MySQL!"
echo"You can tail /root/mysql-install.log from your server."
fi
}
#Theinstallation log
InitInstall2>&1 | tee /root/mysql-install.log
CheckAndDownloadFiles2>&1 | tee -a /root/mysql-install.log
InstallDependsAndOpt2>&1 | tee -a /root/mysql-install.log
InstallMySQL562>&1 | tee -a /root/mysql-install.log
CheckInstall2>&1 | tee -a /root/mysql-install.log
本文出自 “岁伏” 博客,请务必保留此出处http://suifu.blog.51cto.com/9167728/1754063
MySQL5.6自动化部署(二进制)的更多相关文章
- Mysql5.6 自动化部署
主机环境:Centos6.5 前提: 1. 配置yum源 2. 移除系统自带的mysql 3. 删除原先的mysql用户 4. 使用mysql二进制安装包:https://dev.mysql.com/ ...
- MySQL5.7多实例自动化部署脚本
一.安装说明 ------------------------------------------------------ mysql5.7.10_onekey_install.sh自动化部署脚本支持 ...
- MySQL5.6.12 rpm制作及及自动化部署安装
转自:http://blog.itpub.net/29254281/viewspace-1268918/ 首先,下载rpmbuildyum install rpm-build -y它是Red Hat用 ...
- MySQL主从复制原理及配置详细过程以及主从复制集群自动化部署的实现
一.复制概述 Mysql内建的复制功能是构建大型,高性能应用程序的基础.将Mysql的数据分布到多个系统上去,这种分布的机制,是通过将Mysql的某一台主机的数据复制到其它主机(slaves)上,并重 ...
- Jenkins与gitlib实现自动化部署与持续构建
Jenkins概念 Jenkins是一个功能强大的应用程序,允许持续集成和持续交付项目,无论用的是什么平台.这是一个免费的源代码,可以处理任何类型的构建或持续集成.集成Jenkins可以用于一些测试和 ...
- LTMP手动编译安装以及全自动化部署实践(附详细代码)
大家使用LNMP架构,一般可以理解为Linux Shell为CentOS/RadHat/Fedora/Debian/Ubuntu/等平台安装LNMP(Nginx/MySQL /PHP),LNMPA(N ...
- 基于saltstack自动化部署高可用kubernetes集群
SaltStack自动化部署HA-Kubernetes 本项目在GitHub上,会不定期更新,大家也可以提交ISSUE,地址为:https://github.com/skymyyang/salt-k8 ...
- Ansible自动化部署K8S集群
Ansible自动化部署K8S集群 1.1 Ansible介绍 Ansible是一种IT自动化工具.它可以配置系统,部署软件以及协调更高级的IT任务,例如持续部署,滚动更新.Ansible适用于管理企 ...
- 编写自己的 GitHub Action,体验自动化部署
本文将介绍如何使用 GitHub Actions 部署前端静态页面,以及如何自己创建一个 Docker 容器 Action. 简介 Actions GitHub Actions 是 GitHub 官方 ...
随机推荐
- JQuery的隐式迭代和each函数和map函数
1.JQuery选择器选择出来的是一个数组对象,可是给这些每一个元素都要设置内容时,就会隐式迭代,JQuery自己实现内部循环给每个元素绑定上设置. 2.如果是获取的话,那就是默认获取第一个元素的值. ...
- away3d 汽车路线编辑器
2012年的时候,跟朋友去到一个公司,打算用away3d做一个赛车模拟养成游戏,后来由于种种原因,立项未成,由于朋友已经转行,自己也想对自己做过的事情有一些交代,所以将我负责的部分,赛道编辑器的源码公 ...
- python redis list操作
LPUSH list_name value [value ...] Prepend one or multiple values to a list 从左侧插入值,最早插入的值在最右边 LPUSHX ...
- logback配置
好吧,项目中一直使用的是logback做日志记录. 开始跑Demo的时候,一直会报Failed to load class org.slf4j.impl.StaticLogger的错误.后来googl ...
- nexus 中央仓库
nexus 中央仓库 下载地址:http://www.sonatype.org/nexus/archived 下载最新版本 mkdir -p /opt/local/nexus tar zxvf nex ...
- MODBUS协议详解
MODBUS是一个工业上通信常用的通讯协议,一般在PLC上面用的比较多,主要是定义了一种数据传输的规范,比如数据发给谁,数据是干嘛的,数据错没错,接收到数据的从机告诉我数据有没有接受到等. 传输的方式 ...
- Android中使用http协议访问网络
HTTP协议的工作原理:客户端向服务器端发送http请求,服务器端收到请求后返回一下数据给客户端,客户端接受消息并进行解析. 在Android中发送http请求的方式有两种,第一种是通过HttpURL ...
- team talk 主要框架
Android TeamTalk的原型是Android-IM, 注:本文假设你已经有Android开发环境,且对Android开发的基本常识有所了解 本文以eclipse为例启动Eclipse,导入A ...
- html的URL参数传值问题
在URL中的参数传值时,例如:www.nihao.com?id=001 ,= 两边不能有空格,不然PHP在通过$_GET['id']获取时会出现传值为空.
- onchange、oninput、onpropertyChange事件的异同
onchange事件适用于input\textarea\select元素上,支持各大浏览器,该事件只有在键盘或者鼠标操作改变对象属性,且失去焦点时触发,脚本触发无效: oninput事件适用于inpu ...