1、but there is no HDFS_NAMENODE_USER defined. Aborting operation.
  
  [root@xcff sbin]# ./start-dfs.sh
  
  Starting namenodes on [localhost]
  
  ERROR: Attempting to operate on hdfs namenode as root
  
  ERROR: but there is no HDFS_NAMENODE_USER defined. Aborting operation.
  
  Starting datanodes
  
  ERROR: Attempting to operate on hdfs datanode as root
  
  ERROR: but there is no HDFS_DATANODE_USER defined. Aborting operation.
  
  Starting secondary namenodes [localhost]
  
  ERROR: Attempting to operate on hdfs secondarynamenode as root
  
  ERROR: but there is no HDFS_SECONDARYNAMENODE_USER defined. Aborting operatio
  
  然后就晕了, 解决方法:
  
  在/hadoop/hadoop-3.0.3/sbin/start-dfs.sh中:
  
  HDFS_DATANODE_USER=root
  
  HADOOP_SECURE_DN_USER=hdfs
  
  HDFS_NAMENODE_USER=root
  
  HDFS_SECONDARYNAMENODE_USER=root
  
  在/hadoop/hadoop-3.0.3/sbin/start-yarn.sh中:
  
  HDFS_DATANODE_USER=root
  
  HADOOP_SECURE_DN_USER=hdfs
  
  HDFS_NAMENODE_USER=root
  
  HDFS_SECONDARYNAMENODE_USER=root
  
  在/hadoop/hadoop-3.0.3/sbin/stop-dfs.sh中:
  
  HDFS_DATANODE_USER=root
  
  HADOOP_SECURE_DN_USER=hdfs
  
  HDFS_NAMENODE_USER=root
  
  HDFS_SECONDARYNAMENODE_USER=root
  
  在/hadoop/hadoop-3.0.3/sbin/stop-yarn.sh中:
  
  HDFS_DATANODE_USER=root
  
  HADOOP_SECURE_DN_USER=hdfs
  
  HDFS_NAMENODE_USER=root
  
  HDFS_SECONDARYNAMENODE_USER=root
  
  2、localhost: Permission denied (publickey,www.meiwanyule.cn/ gssapi-keyex,gssapi-with-mic,password).
  
  这个问题 是需要免密登陆
  
  [root@xcff sbin]# ./start-dfs.sh
  
  WARNING: HADOOP_SECURE_DN_USER www.qinlinyu.cn/ has been replaced by HDFS_DATANODE_SECURE_USER. Using value of HADOOP_SECURE_DN_USER.
  
  Starting namenodes on [localhost]
  
  上一次登录:一 1月 7 15:19:55 CST 2019从 192.168.101.18pts/8 上
  
  localhost: Permission www.tongqt178.com denied (publickey,gssapi-keyex,gssapi-with-mic,password).
  
  Starting datanodes
  
  上一次登录:一 1月 7 15:34:53 CST 2019pts/0 上
  
  localhost: Permission denied (publickey,gssapi-keyex,gssapi-with-mic,password).
  
  Starting secondary namenodes [localhost]
  
  上一次登录:一 1月 7 15:34:53 CST 2019pts/0 上
  
  localhost: Permission denied (www.gouyiflb.cn publickey,gssapi-keyex,gssapi-with-mic,password).
  
  解决方法是:
  
  ssh-keygen -t rsa -P ""
  
  最后的样子是:
  
  最后进入的数据的目录中: /root/.ssh/id_rsa
  
  在~目录的.ssh下生成秘钥 
  
  将生成的公钥id_rsa.pub 内容追加到authorized_keys
  
  使用的命令是(需要进入到这个目录中才行):
  
  cat id_rsa.pub >> authorized_keys
  
  3、localhost: ERROR: www.michenggw.com JAVA_HOME is not set and could not be found.
  
  但是有JAVA_HOME 环境变量啊, 为啥不行呢?
  
  [root@xcff sbin]# ./start-dfs.sh
  
  WARNING: HADOOP_SECURE_DN_USER has been replaced by HDFS_DATANODE_SECURE_USER. Using value of HADOOP_SECURE_DN_USER.
  
  Starting namenodes on [localhost]
  
  上一次登录:一 1月 7 15:43:15 CST 2019pts/0 上
  
  localhost: ERROR: JAVA_HOME is not set and could not be found.
  
  Starting datanodes
  
  上一次登录:一 1月 7 15:45:53 CST 2019pts/0 上
  
  localhost: ERROR: JAVA_HOME is not set and could not be found.
  
  Starting secondary namenodes [localhost]
  
  上一次登录:一 1月 7 15:45:54 CST 2019pts/0 上
  
  localhost: ERROR: JAVA_HOME is not set and could not be found.
  
  修改/hadoop/hadoop-3.0.3/etc/hadoop
  
  添加环境变量
  
  打开注释, 最后, 在后面加上 echo $JAVA_HOME显示的目录, 保存

CentOS 装hadoop3.0.3 版本踩坑的更多相关文章

  1. 超详细!CentOS 7 + Hadoop3.0.0 搭建伪分布式集群

    超详细!CentOS 7 + Hadoop3.0.0 搭建伪分布式集群 ps:本文的步骤已自实现过一遍,在正文部分避开了旧版教程在新版使用导致出错的内容,因此版本一致的情况下照搬执行基本不会有大错误. ...

  2. HDP 3.1.0 集成 Sqoop2 踩坑问题记录

    HDP 3.1.0 集成 Sqoop2 踩坑问题记录 本文原始地址:https://sitoi.cn/posts/65261.html 问题一 $ sqoop:000> start job -n ...

  3. navicate 连接mysql8.0,个人踩坑问题汇总

    navicate 连接mysql8.0,个人踩坑问题汇总本文目录:1:安装mysql8.0新增全新验证方式,安装如果不修改mysql连接不上2:mysql启动命令问题3:navicate 运程连接My ...

  4. MySQL切换版本踩坑记录(包括恢复数据方法)

    踩坑起因:在创建数据库时, 字段:create_time datetime DEFAULT CURRENT_TIMESTAMP, 报异常--Error Code: 1067 - Invalid def ...

  5. centos 7( linux )下搭建elasticsearch踩坑记

    原文:https://blog.csdn.net/an88411980/article/details/83150380 概述    公司最近在做全文检索的项目,发现elasticsearch踩了不少 ...

  6. centos下安装redis(记录其中踩坑的过程)

    一.先下载到redis-3.0.4.tar.gz包(本文以3.0.4版本为例) 我将这个包放在/opt目录下,在/opt下并解压这个包 tar -zxvf redis-.tar.gz 然后进入redi ...

  7. XXLJOB2.1.0数据源配置踩坑记录

    最近在看XXLJOB,因为截至到发文时间最新的版本是2.1.0而且需要建立的数据库与Quartz解耦了,所以就用了最新的版本. 首先说一下踩坑过程: 代码开发完成之后,在定时跑的时候第一次跑的多数失败 ...

  8. CentOS 6.5 Maven 编译 Apache Tez 0.8.3 踩坑/报错解决记录

    最近准备学习使用Tez,因此从官网下载了最新的Tez 0.8.3源码,按照安装教程编译使用.平时使用的集群环境是离线的,本打算这一次也进行离线编译,无奈一编译就开始报缺少jar包的错,即使手动下载ja ...

  9. 服务器端 CentOS 下配置 JDK 和 Tonmcat 踩坑合集

    一.配置 JDK 时,在 /etc/profile 文件下配置环境变量,添加   #java environment export JAVA_HOME=/usr/java/jdk- export CL ...

随机推荐

  1. MySQL高级-查询截取分析

    一.如何分析 1.观察.至少跑1天,看看生产的慢SQL情况. 2.开启慢查询日志,设置阙值比如超过5秒钟的就是慢SQL,并将它抓取出来. 3.explain + 慢SQL分析 4.show profi ...

  2. iOS UIWebView加载时添加进度条01

    标注:此框架仅适合UIWebView  对iOS8后新出的WKWebView不适用,当然,你可以尝试修改框架里的几个代理方法. 框架是:NJKWebViewProgress 导入头文件 #import ...

  3. spring使用set方法注入的常见类型写法

    首先配置spring的pom.xml文件 <project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi=" ...

  4. 韦大仙--Katalon---一款好用的selenium自动化测试插件

    selenium框架是目前使用较广泛的开源自动化框架,一款好的.基于界面的录制工具对于初学者来说可以快速入门:对于老手来说可以提高开发自动化脚本的效率.我们知道Selenium IDE是一款使用较多的 ...

  5. python函数参数默认值及重要警告

    最有用的形式是对一个或多个参数指定一个默认值.这样创建的函数,可以用比定义时允许的更少的参数调用,比如: def ask_ok(prompt, retries=4, reminder='Please ...

  6. Github协作图想

    首先 git pull 从远程拉下代码,并在本地与本地代码自动合并 在本地解决冲突后,可将本地代码进行远程推送 版本库的Repository中存储的是版本树状链,每一根链接线代表每一次的修改,每一个节 ...

  7. ubuntu16.04图形界面安装中文输入法,中文展示

    打开system Settings 设置   打开设置语言   安装Language Support   点击installed languages 选择chinese 打勾,安装   安装IBus框 ...

  8. POJ 3608 Bridge Across Islands(计算几何の旋转卡壳)

    Description Thousands of thousands years ago there was a small kingdom located in the middle of the ...

  9. mysql 启动报错

    之前用我这个机器做mysql的测试来,今天启动准备搭建一套线上的主从,结果起不来了... 错误日志: ;InnoDB: End of page dump 170807 11:37:02 InnoDB: ...

  10. windows下cudnn的安装过程

    在CUDA安装成功之后,系统环境变量中会有如下两个变量显示:CUDA_PATH和CUDA_PATH_8 在安装完CUDA之后,到官网下载与其版本对应的CUDNN        下载地址:https:/ ...