在安装pike  compute node节点的时候遇到启动nova-compute失败,问题如下(注意红色字体):

[root@compute1 nova]# systemctl start openstack-nova-compute.service
Job for openstack-nova-compute.service failed because the control process exited with error code.
See "systemctl status openstack-nova-compute.service" and "journalctl -xe" for details.
[root@compute1 nova]# systemctl status openstack-nova-compute.service
● openstack-nova-compute.service - OpenStack Nova Compute Server
Loaded: loaded (/usr/lib/systemd/system/openstack-nova-compute.service; enabled; vendor preset: disabled)
Active: activating (start) since Tue -- :: CST; 2s ago
Main PID: (nova-compute)
Tasks:
CGroup: /system.slice/openstack-nova-compute.service
└─ /usr/bin/python2 /usr/bin/nova-compute Sep :: compute1 systemd[]: openstack-nova-compute.service holdoff time over, scheduling restart.
Sep :: compute1 systemd[]: Starting OpenStack Nova Compute Server...
[root@compute1 nova]# date
Tue Sep :: CST
[root@compute1 nova]# journalctl -xe
Sep :: compute1 avahi-daemon[]: Withdrawing workstation service for lo.
Sep :: compute1 avahi-daemon[]: Withdrawing workstation service for virbr0-nic.
Sep :: compute1 avahi-daemon[]: Withdrawing address record for 192.168.122.1 on virbr0.
Sep :: compute1 avahi-daemon[]: Withdrawing workstation service for virbr0.
Sep :: compute1 avahi-daemon[]: Withdrawing address record for fe80::fc81:46e3:49a7:d1da on ens35.
Sep :: compute1 avahi-daemon[]: Withdrawing address record for fe80::8fb9:::d538 on ens35.
Sep :: compute1 avahi-daemon[]: Withdrawing address record for 192.168.70.73 on ens35.
Sep :: compute1 avahi-daemon[]: Withdrawing workstation service for ens35.
Sep :: compute1 avahi-daemon[]: Withdrawing address record for fe80::fe24:180a:91a7:8bdf on ens34.
Sep :: compute1 avahi-daemon[]: Host name conflict, retrying with compute1-
Sep :: compute1 avahi-daemon[]: Registering new address record for 192.168.122.1 on virbr0.IPv4.
Sep :: compute1 avahi-daemon[]: Registering new address record for fe80::fc81:46e3:49a7:d1da on ens35.*.
Sep :: compute1 avahi-daemon[]: Registering new address record for fe80::8fb9:::d538 on ens35.*.
Sep :: compute1 avahi-daemon[]: Registering new address record for 192.168.70.73 on ens35.IPv4.
Sep :: compute1 avahi-daemon[]: Registering new address record for fe80::fe24:180a:91a7:8bdf on ens34.*.
Sep :: compute1 avahi-daemon[]: Registering new address record for fe80:::9aae::6a4a on ens34.*.
Sep :: compute1 avahi-daemon[]: Registering new address record for 10.50.70.73 on ens34.IPv4.
Sep :: compute1 avahi-daemon[]: Registering new address record for 192.168.184.135 on ens33.IPv4.
Sep :: compute1 avahi-daemon[]: Registering HINFO record with values 'X86_64'/'LINUX'.
Sep :: compute1 systemd[]: openstack-nova-compute.service: main process exited, code=exited, status=/FAILURE
Sep :: compute1 systemd[]: Failed to start OpenStack Nova Compute Server.
-- Subject: Unit openstack-nova-compute.service has failed
-- Defined-By: systemd
-- Support: http://lists.freedesktop.org/mailman/listinfo/systemd-devel
--
-- Unit openstack-nova-compute.service has failed.
--
-- The result is failed.
Sep :: compute1 systemd[]: Unit openstack-nova-compute.service entered failed state.
Sep :: compute1 systemd[]: openstack-nova-compute.service failed.
Sep :: compute1 systemd[]: openstack-nova-compute.service holdoff time over, scheduling restart.
Sep :: compute1 systemd[]: Starting OpenStack Nova Compute Server...
[root@compute1 nova]#vim /var/log/nova/nova-compute.log 
... ERROR nova AccessRefused: (, ): () ACCESS_REFUSED - Login was refused using authentication mechanism AMQPLAIN.
For details see the broker logfile.

从上面的记录中可以推断应该message queue出了问题。导致无法login。

再想想涉及login到rabbit的使用的是用户名和密码:

查看rabbit server [on controller node]用户名密码:

[root@controller ~]# rabbitmq-plugins enable rabbitmq_management                 //开启rabbit web界面 
[root@controller ~]#lsof |grep rabbit                                            //查询rabbit web服务端口 15672
async_63   1089 2034       rabbitmq   49u     IPv4              32616       0t0        TCP *: (LISTEN)

在浏览器中输入controller:15672地址,如下图

再在compute node中的nova.conf中查找相关的用户名和密码

[DEFAULT]

。。。
enabled_apis = osapi_compute,metadata
transport_url = rabbit://openstack:rabbit@controller

用户名为openstack

密码为rabbit

login 失败

查看rabbit sever的用户列表发现没有openstack这个用户:

[root@controller ~]# rabbitmqctl list_users
Listing users ...
admin [administrator]
guest [administrator]

[重点]使用admin用户登录,由于忘记密码又不能直接查看明文密码,所以在rabbit_server[controller node]上重置用户为admin的用户密码:

[root@controller nova]# rabbitmqctl change_password admin admin

再次使用用户名和密码登录

用户名:admin

密码:admin

最后修改nova.conf [on compute node or controller node]

transport_url= rabbit://admin:admin@controller

启动nova-compute.service

[root@compute1 nova]# systemctl start openstack-nova-compute.service
[root@compute1 nova]# systemctl status openstack-nova-compute.service
● openstack-nova-compute.service - OpenStack Nova Compute Server
Loaded: loaded (/usr/lib/systemd/system/openstack-nova-compute.service; enabled; vendor preset: disabled)
Active: active (running) since Tue -- :: CST; 49s ago
Main PID: (nova-compute)
Tasks:
CGroup: /system.slice/openstack-nova-compute.service
└─ /usr/bin/python2 /usr/bin/nova-compute Sep :: compute1 systemd[]: Starting OpenStack Nova Compute Server...
Sep :: compute1 systemd[]: Started OpenStack Nova Compute Server.

问题解决

[原][openstack-pike][compute node][issue-1]openstack-nova-compute.service holdoff time over, scheduling restart.的更多相关文章

  1. 《转》 Openstack Grizzly 指定 compute node 创建 instance

    声明:此文档仅仅做学习交流使用,请勿用作其它商业用途 作者:朝阳_tony 邮箱:linzhaolover@gmail.com 2013年6月4日9:37:44 星期二 转载请注明出处:http:// ...

  2. Openstack组件部署 — Nova_Install and configure a compute node

    目录 目录 前文列表 Prerequisites 先决条件 Install and configure a compute node Install the packages Edit the etc ...

  3. openstack pike 集群高可用 安装 部署 目录汇总

    # openstack pike 集群高可用 安装部署#安装环境 centos 7 史上最详细的openstack pike版 部署文档欢迎经验分享,欢迎笔记分享欢迎留言,或加QQ群663105353 ...

  4. openstack pike 使用 openvswitch + vxlan

    # openstack pike 使用 openvswitch + vxlan# openstack pike linuxbridge-agent 换为 openvswitch-agent #open ...

  5. openstack pike 单机 一键安装 shell

    #openstack pike 单机  centos 一键安装 shell #openstack pike 集群高可用  安装部署 汇总 http://www.cnblogs.com/elvi/p/7 ...

  6. CentOS7.2非HA分布式部署Openstack Pike版 (实验)

    部署环境 一.组网拓扑 二.设备配置 笔记本:联想L440处理器:i3-4000M 2.40GHz内存:12G虚拟机软件:VMware® Workstation 12 Pro(12.5.2 build ...

  7. openstack pike与ceph集成

    openstack pike与ceph集成 Ceph luminous 安装配置 http://www.cnblogs.com/elvi/p/7897178.html openstack pike 集 ...

  8. OpenStack Pike超详细搭建文档 LinuxBridge版

    前言 搭建前必须看我 本文档搭建的是分布式P版openstack(1 controller + N compute + 1 cinder)的文档. openstack版本为Pike. 搭建的时候,请严 ...

  9. 照着官网来安装openstack pike之创建并启动instance

    有了之前组件(keystone.glance.nova.neutron)的安装后,那么就可以在命令行创建并启动instance了 照着官网来安装openstack pike之environment设置 ...

随机推荐

  1. Mac下多个jdk自由切换

    1.缘由,某些场合下需特别配置jdk,如最近学习遇到 annotation注解支持jdk1.5以上版本,而我用的jdk1.8,导致tomcat启动失败,提示降低jdk版本到1.7,1.6 2.搜索ma ...

  2. JS自学笔记02

    JS自学笔记02 1.复习 js是一门解释性语言,遇到一行代码就执行一行代码 2.查阅mdn web文档 3.提示用户输入并接收,相比之下,alert只有提示的作用: prompt(字符串) 接收: ...

  3. 对指针和引用的理解(c++)

    1.指针 typedef说明一种新类型名,来代替已有类型名. a.案例:typedef char* String_t和#define String_d char *这两句在使用上的区别? 1)前者声明 ...

  4. enctype和Content-type有什么关系

    enctype和Content-type有什么关系 当我们使用form表单上传文件时post请求的时候,需要在form表单中添加enctype="multipart/form-data&qu ...

  5. 关于cxf生成客户端代码中的JAXBElement<String>

    1.使用自动生成的java文件中的 ObjectFactory构造入参 关于cxf生成客户端代码中的JAXBElement<String>    在使用cxf或者x-fire进行webse ...

  6. Win10系统的SurfacePro4如何重装系统-4 如何再次备份和还原系统

    还是进入到PE环境,直接用GHOST,Local-Partition-ToImage即可创建C盘新的备份   选择目标硬盘   选择要备份的分区   选择保存文件的路径(如果没有接键盘,打开底部的屏幕 ...

  7. ChartControl控件0和null的效果

    DevExpress的ChartControl虽然还不能完全代替Office图表(例如它暂时不支持添加数据表),但它算同类产品中相当优秀的了,下面是对0值和空值的处理. DataTable zeroD ...

  8. C#调用系统打印机和收银钱箱

    打印示例: StringBuilder builder = new StringBuilder();builder.AppendLine("--------------打印测试------- ...

  9. HashMap代码解析

    hashmap (jdk 1.7)使用 “数组-链表” 方式进行存储,图形化表示如下: 即,前面是一个数组,后面跟一个链表,那么数据结构这个对应到HashMap的代码里面是什么样子的呢? 在HashM ...

  10. Python并行实例

    任务 def single(): # 单进程单线程实现 s = 0 for i in range(1, N): s += math.sqrt(i) return s 结论 Python多线程无法利用多 ...