启动Apollo后,进入网页版管理中心后报错:500: Server Error

https://127.0.0.1:61681/console/index.html

网页抓包

报错:{"code":"500: Internal Server Error","message":"java.lang.IllegalArgumentException: port out of range:-1","resource":"/api/json/broker","other":[]}

apollo.log日志:

2018-11-28 17:23:11,174 | INFO  | OS     : Windows 10 10.0 |
2018-11-28 17:23:11,177 | INFO | JVM : Java HotSpot(TM) 64-Bit Server VM 1.8.0_161 (Oracle Corporation) |
2018-11-28 17:23:11,177 | INFO | Apollo : 1.7.1 (at: E:\Data\apache-apollo-1.7.1) |
2018-11-28 17:23:11,407 | INFO | Starting store: leveldb store at E:\Data\apache-apollo-1.7.1\bin\mybroker\data |
2018-11-28 17:23:11,679 | INFO | Opening the log file took: 141.28 ms |
2018-11-28 17:23:11,950 | INFO | Accepting connections at: tcp://0.0.0.0:61613 |
2018-11-28 17:23:11,950 | INFO | Accepting connections at: tls://0.0.0.0:61614 |
2018-11-28 17:23:12,000 | INFO | Accepting connections at: ws://0.0.0.0:61623/ |
2018-11-28 17:23:12,020 | WARN | FAILED SslSelectChannelConnector@0.0.0.0:61624: java.net.BindException: Address already in use: bind |
java.net.BindException: Address already in use: bind
at sun.nio.ch.Net.bind0(Native Method)
at sun.nio.ch.Net.bind(Net.java:433)
at sun.nio.ch.Net.bind(Net.java:425)
at sun.nio.ch.ServerSocketChannelImpl.bind(ServerSocketChannelImpl.java:223)
at sun.nio.ch.ServerSocketAdaptor.bind(ServerSocketAdaptor.java:74)
at org.eclipse.jetty.server.nio.SelectChannelConnector.open(SelectChannelConnector.java:182)
at org.eclipse.jetty.server.AbstractConnector.doStart(AbstractConnector.java:311)
at org.eclipse.jetty.server.nio.SelectChannelConnector.doStart(SelectChannelConnector.java:260)
at org.eclipse.jetty.server.ssl.SslSelectChannelConnector.doStart(SslSelectChannelConnector.java:626)
at org.eclipse.jetty.util.component.AbstractLifeCycle.start(AbstractLifeCycle.java:59)
at org.eclipse.jetty.server.Server.doStart(Server.java:283)
at org.eclipse.jetty.util.component.AbstractLifeCycle.start(AbstractLifeCycle.java:59)
at org.apache.activemq.apollo.broker.jetty.WebSocketTransportFactory$WsTransportServer$$anonfun$_start$1.apply$mcV$sp(WebSocketTransportFactory.scala:183)
at org.fusesource.hawtdispatch.package$$anon$4.run(hawtdispatch.scala:357)
at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624)
at java.lang.Thread.run(Thread.java:748)
2018-11-28 17:23:12,022 | WARN | FAILED org.eclipse.jetty.server.Server@4aa1007d: java.net.BindException: Address already in use: bind |
java.net.BindException: Address already in use: bind
at sun.nio.ch.Net.bind0(Native Method)
at sun.nio.ch.Net.bind(Net.java:433)
at sun.nio.ch.Net.bind(Net.java:425)
at sun.nio.ch.ServerSocketChannelImpl.bind(ServerSocketChannelImpl.java:223)
at sun.nio.ch.ServerSocketAdaptor.bind(ServerSocketAdaptor.java:74)
at org.eclipse.jetty.server.nio.SelectChannelConnector.open(SelectChannelConnector.java:182)
at org.eclipse.jetty.server.AbstractConnector.doStart(AbstractConnector.java:311)
at org.eclipse.jetty.server.nio.SelectChannelConnector.doStart(SelectChannelConnector.java:260)
at org.eclipse.jetty.server.ssl.SslSelectChannelConnector.doStart(SslSelectChannelConnector.java:626)
at org.eclipse.jetty.util.component.AbstractLifeCycle.start(AbstractLifeCycle.java:59)
at org.eclipse.jetty.server.Server.doStart(Server.java:283)
at org.eclipse.jetty.util.component.AbstractLifeCycle.start(AbstractLifeCycle.java:59)
at org.apache.activemq.apollo.broker.jetty.WebSocketTransportFactory$WsTransportServer$$anonfun$_start$1.apply$mcV$sp(WebSocketTransportFactory.scala:183)
at org.fusesource.hawtdispatch.package$$anon$4.run(hawtdispatch.scala:357)
at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624)
at java.lang.Thread.run(Thread.java:748)

日志提示是地址端口61624已经被使用

FAILED SslSelectChannelConnector@0.0.0.0:61624: java.net.BindException: Address already in use: bind

解决方案:

找到自定义的broker\etc下的apollo.xml配置文件,找到61624端口,对应的是wss,修改其中的端口,启动后就成功了

  <connector id="wss" bind="wss://0.0.0.0:21624" connection_limit="2000"/>

默认配置:

  <web_admin bind="http://127.0.0.1:61680"/>
<web_admin bind="https://127.0.0.1:61681"/> <connector id="tcp" bind="tcp://0.0.0.0:61613" connection_limit="2000"/>
<connector id="tls" bind="tls://0.0.0.0:61614" connection_limit="2000"/>
<connector id="ws" bind="ws://0.0.0.0:61623" connection_limit="2000"/>
<connector id="wss" bind="wss://0.0.0.0:61624" connection_limit="2000"/>

2018-11-28 17:23:11,174 | INFO  | OS     : Windows 10 10.0 | 2018-11-28 17:23:11,177 | INFO  | JVM    : Java HotSpot(TM) 64-Bit Server VM 1.8.0_161 (Oracle Corporation) | 2018-11-28 17:23:11,177 | INFO  | Apollo : 1.7.1 (at: E:\Data\apache-apollo-1.7.1) | 2018-11-28 17:23:11,407 | INFO  | Starting store: leveldb store at E:\Data\apache-apollo-1.7.1\bin\mybroker\data | 2018-11-28 17:23:11,679 | INFO  | Opening the log file took: 141.28 ms | 2018-11-28 17:23:11,950 | INFO  | Accepting connections at: tcp://0.0.0.0:61613 | 2018-11-28 17:23:11,950 | INFO  | Accepting connections at: tls://0.0.0.0:61614 | 2018-11-28 17:23:12,000 | INFO  | Accepting connections at: ws://0.0.0.0:61623/ | 2018-11-28 17:23:12,020 | WARN  | FAILED SslSelectChannelConnector@0.0.0.0:61624: java.net.BindException: Address already in use: bind | java.net.BindException: Address already in use: bindat sun.nio.ch.Net.bind0(Native Method)at sun.nio.ch.Net.bind(Net.java:433)at sun.nio.ch.Net.bind(Net.java:425)at sun.nio.ch.ServerSocketChannelImpl.bind(ServerSocketChannelImpl.java:223)at sun.nio.ch.ServerSocketAdaptor.bind(ServerSocketAdaptor.java:74)at org.eclipse.jetty.server.nio.SelectChannelConnector.open(SelectChannelConnector.java:182)at org.eclipse.jetty.server.AbstractConnector.doStart(AbstractConnector.java:311)at org.eclipse.jetty.server.nio.SelectChannelConnector.doStart(SelectChannelConnector.java:260)at org.eclipse.jetty.server.ssl.SslSelectChannelConnector.doStart(SslSelectChannelConnector.java:626)at org.eclipse.jetty.util.component.AbstractLifeCycle.start(AbstractLifeCycle.java:59)at org.eclipse.jetty.server.Server.doStart(Server.java:283)at org.eclipse.jetty.util.component.AbstractLifeCycle.start(AbstractLifeCycle.java:59)at org.apache.activemq.apollo.broker.jetty.WebSocketTransportFactory$WsTransportServer$$anonfun$_start$1.apply$mcV$sp(WebSocketTransportFactory.scala:183)at org.fusesource.hawtdispatch.package$$anon$4.run(hawtdispatch.scala:357)at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149)at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624)at java.lang.Thread.run(Thread.java:748)2018-11-28 17:23:12,022 | WARN  | FAILED org.eclipse.jetty.server.Server@4aa1007d: java.net.BindException: Address already in use: bind | java.net.BindException: Address already in use: bindat sun.nio.ch.Net.bind0(Native Method)at sun.nio.ch.Net.bind(Net.java:433)at sun.nio.ch.Net.bind(Net.java:425)at sun.nio.ch.ServerSocketChannelImpl.bind(ServerSocketChannelImpl.java:223)at sun.nio.ch.ServerSocketAdaptor.bind(ServerSocketAdaptor.java:74)at org.eclipse.jetty.server.nio.SelectChannelConnector.open(SelectChannelConnector.java:182)at org.eclipse.jetty.server.AbstractConnector.doStart(AbstractConnector.java:311)at org.eclipse.jetty.server.nio.SelectChannelConnector.doStart(SelectChannelConnector.java:260)at org.eclipse.jetty.server.ssl.SslSelectChannelConnector.doStart(SslSelectChannelConnector.java:626)at org.eclipse.jetty.util.component.AbstractLifeCycle.start(AbstractLifeCycle.java:59)at org.eclipse.jetty.server.Server.doStart(Server.java:283)at org.eclipse.jetty.util.component.AbstractLifeCycle.start(AbstractLifeCycle.java:59)at org.apache.activemq.apollo.broker.jetty.WebSocketTransportFactory$WsTransportServer$$anonfun$_start$1.apply$mcV$sp(WebSocketTransportFactory.scala:183)at org.fusesource.hawtdispatch.package$$anon$4.run(hawtdispatch.scala:357)at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149)at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624)at java.lang.Thread.run(Thread.java:748)

apache-apollo启动报错的更多相关文章

  1. apache无法启动报错No space left on device

    apache无法启动报错No space left on device 故障现象:apache无法启动ipcs信号量很多 # service httpd startStarting httpd : [ ...

  2. Apache无法启动报错查看

    wampserver橙色图标 查找原因 1.测试80端口 . 如已被占用,则改别的端口在启动apache.怎么改apache的的端口去百度一下都有. 2.找到httpd.exe的目录.在cmd命令行下 ...

  3. Hbase master启动报错:Failed construction of Master: class org.apache.hadoop.hbase.master.HMaster Caused by: java.net.UnknownHostException:

    Hbase master启动报错: java.lang.RuntimeException: Failed construction of Master: class org.apache.hadoop ...

  4. 转 : Apache启动报错:could not bind to address [::]:443 解决办法

    转:Apache启动报错:could not bind to address [::]:443 解决办法 安装Apache服务器的时候,报如下错误: Installing the 'apache' s ...

  5. 【报错】spring整合activeMQ,pom.xml文件缺架包,启动报错:Caused by: java.lang.ClassNotFoundException: org.apache.xbean.spring.context.v2.XBeanNamespaceHandler

    spring版本:4.3.13 ActiveMq版本:5.15 ======================================================== spring整合act ...

  6. TOMCAT启动报错:org.apache.tomcat.jni.Error: 730055

    TOMCAT启动报错:org.apache.tomcat.jni.Error: 730055 具体原因:不清楚 解决方式:重启应用服务器后,再启动tomcat就可以了 欢迎关注公众号,学习kettle ...

  7. Weblogic 启动报错:java.lang.NoClassDefFoundError

    Weblogic 启动报错:java.lang.NoClassDefFoundError  ####<2015-6-17 下午03时30分47秒 CST> <Error> &l ...

  8. weblogic启动报错

    重启了一次linux服务器后,weblogic启动莫名报错,查看日志发现说部署的项目有个bean类无法加载, 1.然后手动删除 已经部署的项目,先在 domais/servers/AdminServe ...

  9. zookeeper启动报错(数据目录权限不对)

    zookeeper启动报错日志: 2016-11-16 11:19:43,880 [myid:3] - INFO [WorkerReceiver[myid=3]:FastLeaderElection@ ...

  10. struts2启动报错com/opensymphony/xwork2/spring/SpringObjectFactory.java:220:-1

    好久没有搞struts2,今天配置strut2.2.1,启动时遇到个小问题.记录下. tomcat启动报错: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 ...

随机推荐

  1. Jdk1.6 HTTPS访问问题解决办法

    真是艹蛋的一次经历,jdk6上面去访问别人的https,还好有百度搞定了问题.现在写下随笔,记录下; 首先要自己重写SSLSocketFactory这个类, 下面是自己重写的这个类:TLSSocket ...

  2. ybt1107题解和方法总结

    今天花了三个小时的时间刷了些基础题,虽说是简单题,但是有一些还是有点难度的 比如ybt1107,我死嗑了半个小时. [题目描述] 某校大门外长度为L的马路上有一排树,每两棵相邻的树之间的间隔都是1米. ...

  3. ArcGIS Pro Add-In插件开发[ArcGIS Pro SDK for .NET]

    本文基于 Windows7 + VS2019 + .NET Framework 4.8 + ArcGIS Pro 2.5 开发和撰写. 目录 开发环境配置 获取ArcGIS Pro 安装VS2019 ...

  4. css3新属性position: sticky 一分钟实现 导航栏悬停功能

    css3新属性position: sticky 一分钟实现 导航栏悬停功能 前言 正文 前言 想必很多前端小伙伴经常会在开发中遇到这样一个需求,就是在下划时,导航栏悬停在屏幕最上方,例如咱们的csdn ...

  5. 使用 codeblocks 编写C++ udp组播程序遇到的问题

    编译错误 会出现好多undefined reference to'WSAStartup to@8之类的错误,都是undefind开头的 解决方法: Settings -> Compiler se ...

  6. 12c RAC 用Rman 恢复到异机单实例

    准备工作 原服务器软件部署:Redhat 6.6 + Oracle 12.2.0.1 rac Oracle12c单实例安装 1.创建恢复服务器,设置大于原库数据大小的磁盘容量.设置相同的服务器主机名参 ...

  7. Java类库以及它的基本组织结构

    Java 类库概念: Java 的应用程序编程接口 (API  (Application Programming Interface) )以包的形式来组织,每个包提供了大量的相关类.接口和异常处理类, ...

  8. 也谈基于Web的含工作流项目的一般开发流程

    项目包含的通用模块代码等我有时间一并剥离贡献出来(基于WebSocket的通知引擎,工作流整合模块,自定义表单,基于RBAC权限设计),最近太忙了,Web项目有一段时间没碰,有点生疏的感觉,主要在忙G ...

  9. 通过WordCount解析Spark RDD内部源码机制

    一.Spark WordCount动手实践 我们通过Spark WordCount动手实践,编写单词计数代码:在wordcount.scala的基础上,从数据流动的视角深入分析Spark RDD的数据 ...

  10. Unity踩过的坑

    1.InvokeRepeating调用会在手机后台切换时失效,Coroutine就不会 2.DLL内的函数不支持默认参数,必须传入全部参数 不然会出现如下错误: Unhandled Exception ...