现象

登录失败

告警日志:

由此可知,归档日志空间已满

解决方式:

一、增大归档日志空间

1、启动数据库至nomount

 [oracle@CentOS ~]$ sqlplus / as sysdba

 SQL Production  :: 

 Copyright (c) , , Oracle.  All rights reserved.

 Connected to an idle instance.

 SQL> startup nomount
 ORACLE instance started.

 Total System Global Area   bytes
 Fixed Size             bytes
 Variable Size           bytes
  bytes
 Redo Buffers             bytes
 SQL> show parameter db_recovery_file_dest_size

 NAME                     TYPE     VALUE
 ------------------------------------ ----------- ------------------------------
 db_recovery_file_dest_size         big integer 3882M
 SQL> show parameter db_recovery_file_dest

 NAME                     TYPE     VALUE
 ------------------------------------ ----------- ------------------------------
 db_recovery_file_dest             string     /u01/app/oracle/flash_recovery
                          _area
 db_recovery_file_dest_size         big integer 3882M

查看db_recovery_file_dest路径在磁盘空间中是否有足够空间

 [root@CentOS ~]# df -h
 文件系统          容量  已用  可用 已用%% 挂载点
 /dev/sda6              56G   24G   30G  % /
 tmpfs                 932M  480M  452M  % /dev/shm
 /dev/sda1             194M   32M  152M  % /boot
 /dev/sda2              20G   18G  .4G  % /home
 /dev/sda3              20G  592M   19G   % /opt
 .host:/                40G   15G   25G  % /mnt/hgfs

增加归档空间

SQL System altered.

启动数据库

 SQL> shutdown immediate;
 ORA: database not mounted

 ORACLE instance shut down.
 SQL> startup
 ORACLE instance started.

 Total System Global Area   bytes
 Fixed Size             bytes
 Variable Size           bytes
  bytes
 Redo Buffers             bytes
 Database mounted.
 Database opened.

如有必要,清理归档日志

查看归档日志

 [oracle@CentOS ~]$ rman target /

 Recovery Manager: Release   :: 

 Copyright (c) , , Oracle and/or its affiliates.  All rights reserved.

 connected )

 RMAN> crosscheck archivelog all;

 using target database control file instead of recovery catalog
 allocated channel: ORA_DISK_1
 channel ORA_DISK_1: SID device type=DISK
 ......

清理七天前的归档日志

 RMAN> DELETE ARCHIVELOG ALL COMPLETED BEFORE 'SYSDATE-7';

 released channel: ORA_DISK_1
 allocated channel: ORA_DISK_1
 channel ORA_DISK_1: SID device type=DISK
 List of Archived Log Copies for database with db_unique_name VMDB
 =====================================================================

 Key     Thrd Seq     S Low Time
 ------- ---- ------- - ---------
                  A
         Name: /o1_mf_1_41_dr44tg7r_.arc

                  A
         Name: /o1_mf_1_42_dr650bv8_.arc

                  A
         Name: /o1_mf_1_43_dr73pv06_.arc

 ......

参考资料

https://zhidao.baidu.com/question/1575284660590623380.html

归档日志空间满导致DB启动失败的更多相关文章

  1. ORA-00257归档日志写满的解决方法

    背景: 在前一篇博客中我们提到了如何启动或关闭oracle的归档(ARCHIVELOG)模式,在我成功设定数据库为归档模式以后, 第二天再次尝试连接数据库,报错:ORA-00257.在网上找到了一圈资 ...

  2. (转)ORA-00257归档日志写满的解决方法

    转自:http://www.cnblogs.com/xwdreamer/p/3804509.html 背景: 在前一篇博客中我们提到了如何启动或关闭oracle的归档(ARCHIVELOG)模式,在我 ...

  3. oracle归档日志写满错误解决方法

    最近一年,手头上负责的项目要部署到很多个地方,由于项目组里没有人对oracle比较熟悉,只能给自己增加一个DBA的角色了.由于短时间内要部署很多单位,备份策略没有设置好,结果过了一个月,用户报告程序开 ...

  4. 因为错误关闭Selinux导致CentOS7启动失败(进度条卡死,图形界面加载卡死)

    我在CentOS7上安装oracle,非常麻烦,搞半天终于安装完毕,当天我没有发现任何问题,第二天上班打开虚拟机CentOS7就进不去了. 我想起来之前关闭了Selinux,把系统名称改成了redha ...

  5. 云服务器 linux文件系统异常an error occurren during the file system check导致服务器启动失败

    云服务器 linux文件系统异常an error occurren during the file system check导致服务器启动失败 文件系统宕机,重启后报错,无法启动 处理流程: 1.编辑 ...

  6. 解决nginx启动时域名解析失败而导致服务启动失败的问题

    问题: nginx启动或者reload的时候,会对proxy_pass后面的域名进行DNS解析,如果解析失败,启动就会失败或者reload失败. 我们是to B的产品,客户的环境可能是不通公网的,因此 ...

  7. DG备库磁盘空间满导致无法创建归档

    上周五去某客户那里做数据库巡检.是window 2008系统上10g的一套NC系统的库,已经配置了DG,可是巡检时发现数据库报错: Tue Nov 11 10:13:57 2014 LNS: Stan ...

  8. ORA-01078和LRM-00109问题导致ORACLE启动失败解决方法

    操作环境 SuSE11sp3 + ORACLE11gR2(11.2.0.3) 问题现象 新安装的ORACLE启动失败,提示ORA-01078和LRM-00109错误.具体错误现象如下 SQL> ...

  9. selinux导致docker启动失败

    1. 问题描述:一向运行正常的一群容器,突然有一天挂掉了,再也起不来,报错如下 Error response from daemon: devmapper: Error mounting '/dev/ ...

随机推荐

  1. Nginx 调优经验记录

    1.2017年连续爆出5.x版本xshell安全问题和intel的cpu设计漏洞 ,此时我就注意到尽量少暴露自己线上使用的工具以及版本.例如:mysql版本,以及缓存层策略,服务器版本等,以下为 隐藏 ...

  2. HashMap并发导致死循环 CurrentHashMap

    为何出现死循环简要说明 HashMap闭环的详细原因 cocurrentHashMap的底层机制 为何出现死循环简要说明 HashMap是非线程安全的,在并发场景中如果不保持足够的同步,就有可能在执行 ...

  3. linux mysql重启命令

    1.通过rpm包安装的MySQL 1 2 service mysqld restart /etc/inint.d/mysqld start 2.从源码包安装的MySQL 1 2 3 4 // Linu ...

  4. mysql 主从同步 mysql代理服务器

    搭建mysql主从同步(实现数据自动备份)实例:把主机192.168.4.100的数据库配置为主机192.168.4.99的从数据库 主数据库服务器配置修改配置文件: [root@mysql ~]# ...

  5. UnicodeDecodeError: 'utf-8' codec can't decode byte 0xce in position 52: invalid continuation byte

    代码: df_w = pd.read_table( r'C:\Users\lab\Desktop\web_list_n.txt', sep=',', header=None) 当我用pandas的re ...

  6. Bind、Apply、Call三者的区别

    1)bind与apply.call 的最大区别就是:bind不会立即调用,其他两个会立即调用 var fn = { _int: function(){return 3}, fun: function( ...

  7. 在DirectShow的视频图像上叠加线条和文字

    在DirectShow的视频图像上叠加线条和文字 最近一直在从事工业测量方面的开发工作,难免会用到各种各样的相机,其中支持DX的USB相机开发起来比较方便,由于工作需要经常要在视频图像上叠加线条和文字 ...

  8. 芝麻HTTP:Python爬虫入门之Urllib库的基本使用

    1.分分钟扒一个网页下来 怎样扒网页呢?其实就是根据URL来获取它的网页信息,虽然我们在浏览器中看到的是一幅幅优美的画面,但是其实是由浏览器解释才呈现出来的,实质它是一段HTML代码,加 JS.CSS ...

  9. span是没有value标签的,要向获得标签内部的值改怎么办。

    1,js实现 var div = document.getElementById('divId');var spans = div.getElementsByTagName('span');var s ...

  10. ubuntu安装pycharm桌面快捷方式

    1.sudo gedit /usr/share/applications/Pycharm.desktop 2.输入 [Desktop Entry] Encoding=UTF-8 Name=Pychar ...