解决报错ExecStart=/usr/sbin/mysqld --daemonize --pid-file=/run/mysqld/mysqld.pid (code
问题的由来
MySQL服务没有正常关机,是电脑没电后自动关机产生,记录一下排查过程
1.本以为是pid的问题,上网找了教程,解决不了,然后看日志
看了网上各种说是数据库内存溢出
2021-03-12T10:41:18.317167Z 0 [Note] Binlog end
2021-03-12T10:41:18.317217Z 0 [Note] Shutting down plugin 'CSV'
2021-03-12T10:41:18.317389Z 0 [Note] /usr/sbin/mysqld: Shutdown complete 2021-03-12T10:41:18.671273Z 0 [Warning] TIMESTAMP with implicit DEFAULT value is deprecated. Please use --explicit_defaults_for_timestamp server option (see documentation for more details).
2021-03-12T10:41:18.672016Z 0 [Note] /usr/sbin/mysqld (mysqld 5.7.33-0ubuntu0.18.04.1) starting as process 2125 ...
2021-03-12T10:41:18.675569Z 0 [Note] InnoDB: PUNCH HOLE support available
2021-03-12T10:41:18.675608Z 0 [Note] InnoDB: Mutexes and rw_locks use GCC atomic builtins
2021-03-12T10:41:18.675611Z 0 [Note] InnoDB: Uses event mutexes
2021-03-12T10:41:18.675614Z 0 [Note] InnoDB: GCC builtin __atomic_thread_fence() is used for memory barrier
2021-03-12T10:41:18.675617Z 0 [Note] InnoDB: Compressed tables use zlib 1.2.11
2021-03-12T10:41:18.675619Z 0 [Note] InnoDB: Using Linux native AIO
2021-03-12T10:41:18.675770Z 0 [Note] InnoDB: Number of pools: 1
2021-03-12T10:41:18.675820Z 0 [Note] InnoDB: Using CPU crc32 instructions
2021-03-12T10:41:18.677170Z 0 [Note] InnoDB: Initializing buffer pool, total size = 128M, instances = 1, chunk size = 128M
2021-03-12T10:41:18.684020Z 0 [Note] InnoDB: Completed initialization of buffer pool
2021-03-12T10:41:18.685248Z 0 [Note] InnoDB: If the mysqld execution user is authorized, page cleaner thread priority can be changed. See the man page of setpriority().
2021-03-12T10:41:18.699329Z 0 [ERROR] InnoDB: Only one log file found.
2021-03-12T10:41:18.699360Z 0 [ERROR] InnoDB: Plugin initialization aborted with error not found
2021-03-12T10:41:19.310191Z 0 [ERROR] Plugin 'InnoDB' init function returned error.
2021-03-12T10:41:19.310270Z 0 [ERROR] Plugin 'InnoDB' registration as a STORAGE ENGINE failed.
2021-03-12T10:41:19.310284Z 0 [ERROR] Failed to initialize builtin plugins.
2021-03-12T10:41:19.310290Z 0 [ERROR] Aborting 2021-03-12T10:41:19.310340Z 0 [Note] Binlog end
2021-03-12T10:41:19.310422Z 0 [Note] Shutting down plugin 'CSV'
2021-03-12T10:41:19.310978Z 0 [Note] /usr/sbin/mysqld: Shutdown complete
2.排查日志后发现,因为/var/lib/ib_logfile中记录者innoDB一些引擎的信息,在server未正常关闭的情况下,重启后的server不支持innodb的引擎,删除记录innodb的配置文件, rm -rf ./ib_logfile*
重启mysql,启动正常
systemctl start mysqld
Failed to start mysqld.service: Unit mysqld.service not found.
root@mysql-master:/var/lib/mysql# systemctl start mysqld
Failed to start mysqld.service: Unit mysqld.service not found.
root@mysql-master:/var/lib/mysql# systemctl start mysql
root@mysql-master:/var/lib/mysql# systemctl status mysql
● mysql.service - MySQL Community Server
Loaded: loaded (/lib/systemd/system/mysql.service; enabled; vendor preset: enabled)
Active: active (running) since Fri 2021-03-12 18:44:30 CST; 5s ago
Process: 2199 ExecStart=/usr/sbin/mysqld --daemonize --pid-file=/run/mysqld/mysqld.pid (code=exited,
Process: 2175 ExecStartPre=/usr/share/mysql/mysql-systemd-start pre (code=exited, status=0/SUCCESS)
Main PID: 2201 (mysqld)
Tasks: 27 (limit: 2290)
CGroup: /system.slice/mysql.service
└─2201 /usr/sbin/mysqld --daemonize --pid-file=/run/mysqld/mysqld.pid Mar 12 18:44:28 mysql-master systemd[1]: Starting MySQL Community Server...
Mar 12 18:44:30 mysql-master systemd[1]: Started MySQL Community Server.
查看MySQL的端口3306
ss -tnl
State Recv-Q Send-Q Local Address:Port Peer Address:Port
LISTEN 0 128 0.0.0.0:111 0.0.0.0:*
LISTEN 0 128 127.0.0.53%lo:53 0.0.0.0:*
LISTEN 0 128 0.0.0.0:22 0.0.0.0:*
LISTEN 0 128 127.0.0.1:6010 0.0.0.0:*
LISTEN 0 128 0.0.0.0:37211 0.0.0.0:*
LISTEN 0 64 0.0.0.0:2049 0.0.0.0:*
LISTEN 0 128 0.0.0.0:47459 0.0.0.0:*
LISTEN 0 64 0.0.0.0:43461 0.0.0.0:*
LISTEN 0 128 0.0.0.0:50475 0.0.0.0:*
LISTEN 0 64 [::]:37039 [::]:*
LISTEN 0 128 [::]:111 [::]:*
LISTEN 0 128 [::]:22 [::]:*
LISTEN 0 128 [::]:38455 [::]:*
LISTEN 0 128 [::1]:6010 [::]:*
LISTEN 0 64 [::]:2049 [::]:*
LISTEN 0 128 [::]:52773 [::]:*
LISTEN 0 128 [::]:37129 [::]:*
LISTEN 0 80 *:3306 *:* mysql的端口ok,正常访问数据库没有问题
解决报错ExecStart=/usr/sbin/mysqld --daemonize --pid-file=/run/mysqld/mysqld.pid (code的更多相关文章
- mysql报错:/usr/sbin/mysqld:unknown variable 'default-character-set=utf8'
修改mysql的字符集时,为了将默认字符集设置为utf-8,便将/etc/my.cnf下[mysqld]加了一行 default-character-set=utf8, 但是在下次启动系统的时候,my ...
- PID file /run/zabbix/zabbix_server.pid not readable (yet?) after start. 报错解决
报错如下: [root@localhost zabbix]# systemctl start zabbix-server Job for zabbix-server.service failed be ...
- 报错:/usr/sbin/mysqld: Can't find file: './performance_schema/events_waits_summary_by_account_by_event_name.frm' (errno: 13 - Permission denied)
报错背景: Linux环境下安装MySQL数据库. 安装完成,数据库初始化,启动数据库时报错. 报错现象: -- :: [ERROR] Native table 'performance_schema ...
- python ConfigParser读取配置文件,及解决报错(去掉BOM)ConfigParser.MissingSectionHeaderError: File contains no section headers的方法
先说一下在读取配置文件时报错的问题--ConfigParser.MissingSectionHeaderError: File contains no section headers 问题描述: 在练 ...
- svn报错cleanup failed–previous operation has not finished; run cleanup if it was interrupted的解决办法
今天在svn提交的时候它卡顿了一下,我以为已经提交完了,就按了一下,结果就再也恢复不了,也继续不了了... 报错 cleanup failed–previous operation has not f ...
- 解决FPDF报错:FPDF error: Not a JPEG file / FPDF error: Not a PNG file
最近有个项目需要用到FPDF,但是输出的时候报错: FPDF error: Not a JPEG file: http://***/data/attachment/forum/201603/19/10 ...
- 解决Undefined symbols for architecture x86_64: 报错 和 ld: warning: ld: warning: ignoring file警告
出现这种错误的情况: 用iphone5模拟器编译程序正常, 用iphone5s以上的模拟器编译出现Undefined symbols for architecture x86_64: 报错 和 ld: ...
- vue 解决报错1
[Vue warn]: You are using the runtime-only build of Vue where the template compiler is not available ...
- centOS7 vsftp ExecStart=/usr/sbin/vsftpd /etc/vsftpd/vsftpd.conf (code=exited, status=0/SUCCESS) 启动失败问题?
[root@localhost c]# systemctl status vsftpd.service ● vsftpd.service - Vsftpd ftp daemon Loaded: loa ...
随机推荐
- 基于 range 的 for 循环和 auto
基于 range 的 for 循环和 auto C++11 引入一种循环的新形式,叫基于 range 的 for 循环,它允许我们用更简单易读的形式遍历容器中的所有元素 vector<int&g ...
- idea的快捷键(复制) IntelliJ Idea 常用快捷键列表
Ctrl+Shift + Enter,语句完成'!',否定完成,输入表达式时按 "!"键 Ctrl+E,最近的文件Ctrl+Shift+E,最近更改的文件Shift+Click,可 ...
- 用简单的 Node.js 后台程序浅析 HTTP 请求与响应
用简单的 Node.js 后台程序浅析 HTTP 请求与响应 本文写于 2020 年 1 月 18 日 我们来看两种方式发送 HTTP 请求,一种呢,是命令行的 curl 命令:一种呢是直接在浏览器的 ...
- 探索ABP基础架构
为了了解应用程序是如何配置和初始化,本文将探讨ASP.NET Core和ABP框架最基本的构建模块.我们将从 ASP.NET Core 的 Startup类开始了解为什么我们需要模块化系统,以及 AB ...
- postman 脚本和变量
背景 后端接口有登录或鉴权验证,通过 swagger 调用比较费劲,并且 java 的 swagger 库(不够自动化,嵌套类支持需要各种配置才能正常显示 schema)个人感觉也没有 .net co ...
- CIAGAN: Conditional Identity Anonymization Generative Adversarial Networks阅读笔记
CIAGAN: Conditional Identity Anonymization Generative Adversarial Networks 2020 CVPR 2005.09544.pdf ...
- python模块详情与开发规范
目录 循环导入 py文件类型 模块的查找顺序 相对导入与绝对导入 包 软件开发目录规范 循环导入 在初学模块时,我们有些时候会出现两个文件彼此导入,这时候可能会有报错. 比如有以下两个py文件 a.p ...
- 初识 Redis 以及其基本使用方法
1.什么是Redis redis 是一个高性能的key-value数据库,它支持的类型更多 包括 string(字符串).list(链表).set(集合).zset(sorted set --有序 ...
- 第06组 Beta冲刺 (3/5)
目录 1.1 基本情况 1.2 冲刺概况汇报 1.郝雷明 2. 方梓涵 3.曾丽莉 4.杜筱 5. 董翔云 6.黄少丹 7.鲍凌函 8.詹鑫冰 9.曹兰英 10.吴沅静 1.3 冲刺成果展示 1.1 ...
- SSE图像算法优化系列三十二:Zhang\Guo图像细化算法的C语言以及SIMD指令优化
二值图像的细化算法也有很多种,比较有名的比如Hilditch细化.Rosenfeld细化.基于索引表的细化.还有Opencv自带的THINNING_ZHANGSUEN.THINNING_GUOHALL ...