1.安装必要的依赖包,关防火墙,向/etc/hosts内添加域名等

2.安装ceph

配置yum源

(如果嫌慢,可以配置cachedir=/home/yum/$basearch/$releasever和keepcache=1两个参数,在第一次安装时将安装包下载到本地做成yum源,给后面的多个服务器使用)

[root@ceph1 mycluster]# cat /etc/yum.repos.d/ceph.repo
[ceph-noarch]
name=Ceph noarch packages
baseurl=http://eu.ceph.com/rpm-luminous/el7/noarch/
enabled=
gpgcheck=
type=rpm-md
gpgkey=http://eu.ceph.com/keys/release.asc
priority= [Ceph]
name=Ceph packages for $basearch
baseurl=http://eu.ceph.com/rpm-luminous/el7/$basearch
enabled=
gpgcheck=
type=rpm-md
gpgkey=http://eu.ceph.com/keys/release.asc
priority= [ceph-source]
name=Ceph source packages
baseurl=http://eu.ceph.com/rpm-luminous/el7/SRPMS
enabled=
gpgcheck=
type=rpm-md
gpgkey=http://eu.ceph.com/keys/release.asc
priority=

安装ceph

yum -y install ceph ceph-radosgw

3.手动安装配置

按照官网:http://docs.ceph.com/docs/master/install/manual-deployment/的方法,

搭建monitor是没有问题的

需要注意的是,如果搭建的是多个monitor需要自己把ceph.conf配置好,多个monitor要使用同一个ceph.mon.keyring和monmap创建,就不会出什么问题。

当使用Centos7时,启动的命令:

systemctl start ceph-mon.target

如果此时ps -ef | grep ceph-mon没有看见此进程,那么依照下面的方法查看:

[root@node1 my-cluster]# systemctl list-unit-files | grep ceph
ceph-create-keys@.service static
ceph-disk@.service static
ceph-mds@.service enabled
ceph-mon@.service enabled
ceph-osd@.service enabled
ceph-radosgw@.service enabled
ceph-mds.target enabled
ceph-mon.target enabled
ceph-osd.target enabled
ceph-radosgw.target enabled
ceph.target enabled

如果发现ceph-mon@.service 不是enabled状态,那么需要 systemctl enable ceph-mon@hostname来开启之后重启ceph-mon。(其他模块类似)

如果还是没有启动,journalctl -f看一下打印的日志,如果显示的是什么启动太快, 可以vi /etc/systemd/system/ceph-mon.target.wants/ceph-mon\@ceph1.service类似一类的文件中的

StartLimitInterval=30min改小之后,用systemctl daemon-reload命令使生效,然后重启ceph-mon

接下来是安装ceph-osd

按官网操作,当执行到sudo ceph-disk activate /dev/hdd1的时候,发现需要一个keyring来鉴权,但是之前并没有操作来加这个keyring。这就需要自己加了

执行"ceph auth get-or-create client.bootstrap-osd mon 'allow profile bootstrap-osd' -o ceph.bootstrap-osd.keyring"(其他的key类似),当在ceph auth list命令执行结果中看见bootstrap-osd就说明把key导入进去了,然后,用生成的ceph.bootstrap-osd.keyring即可激活osd。然后再后面写个脚本:

#!/bin/bash

UUID="c0ba1324-f840-4ae0-a5dc-01816be2f57f"  #以你集群的ID为准
OSD_SECRET=$(ceph-authtool --gen-print-key) ID=$(echo "{\"cephx_secret\": \"$OSD_SECRET\"}" | \
ceph osd new $UUID -i - \
-n client.bootstrap-osd -k /var/lib/ceph/bootstrap-osd/ceph.bootstrap-osd.keyring)
mkdir /var/lib/ceph/osd/ceph-$ID

执行这个脚本osd就安装成功了。如果不小心多执行了几次,创建了很多失败的osd。使用"ceph osd tree"查找到失败的osd,比如是osd.2那么再执行

ceph osd crush remove osd.
ceph auth del osd.
ceph osd rm

即可删除。安装其他osd的id也不会受此id的影响。安装其他osd和这个osd使用同一个keyring就行。

然后安装mds和mgr按官网的方法安装和配置即可。

但是安装完mgr之后用netstat -tlanp | grep ceph-mgr |grep LISTEN查看居然只监听一个端口,dashboard的端口没有被监听,说明dashboard没有被启动。

使用网上大神们的操作

ceph config-key put mgr/dashboard/server_addr 192.168.0.3
ceph config-key put mgr/dashboard/server_port

依然没有成功,原来dashboard需要自己启用:ceph mgr module enable dashboard,(虽然配置文件里也可以写,显然我在配置文件里写的并没有起作用)

然后就是愉快地使用Luminous版的ceph了,然而,为什么我的dashboard跟别人的不一样,我也建了cephfs。

原来换Chrome浏览器就好了。

ceph Luminous版手动安装零散记录的更多相关文章

  1. ceph luminous版本的安装部署

    1. 前期准备   本次安装环境为:   ceph1(集群命令分发管控,提供磁盘服务集群) CentOs7.5 10.160.20.28   ceph2(提供磁盘服务集群) CentOs7.5 10. ...

  2. ceph luminous版部署bluestore

    简介 与filestore最大的不同是,bluestore可以直接读写磁盘,即对象数据是直接存放在裸设备上的,这样解决了一直被抱怨的数据双份写的问题 Bluestore直接使用一个原始分区来存放cep ...

  3. Ceph luminous 安装配置

    Ceph luminous 安装配置 #环境centos7 , Ceph V12 openstack pike 与 ceph 集成 http://www.cnblogs.com/elvi/p/7897 ...

  4. ceph hammer 0.94.10手动部署方法Ceph Hammer版(0.94.10)手动部署for CentOS 7.x

    Ceph Hammer版(0.94.10)手动部署for CentOS 7.x --lin.wang 20190310 环境有三个节点node-1,node-2,node-3,每个节点三个ssd盘作为 ...

  5. Docker版EKL安装记录文档

    Docker版EKL安装记录文档 拉取已下三个镜像 docker.io/logstash 7.5.2 b6518c95ed2f 6 months ago 805 MB docker.io/kibana ...

  6. 在linux下手动安装 apache, php, mysql--终极版

    在linux下手动安装 apache, php, mysql: 参考: http://www.cnblogs.com/lufangtao/archive/2012/12/30/2839679.html ...

  7. ceph mimic版本 部署安装

    ceph 寻址过程 1. file --- object映射, 把file分割成N个相同的对象 2. object - PG 映射, 利用静态hash得到objectID的伪随机值,在 "位 ...

  8. 安装jessie记录

    // */ // ]]>   安装jessie记录 Table of Contents 1 引言 2 目标 3 usb安装 4 无线网卡 5 代理上网 6 rabbitvcs 7 locale ...

  9. CentOS 7下安装vertica记录

    CentOS 7下安装vertica记录 1.    安装好centeros 并更新 Centeros安装就不说了,安装完之后联网环境下 yum update.更新下,使得那些包都是新的.(要想用中文 ...

随机推荐

  1. 建立请求号 request

    1:获取TR号(一般由团队的负责人创建,发出) 2:进入 i7p系统 3:点击process 4:输入tr号 5:选中 正确的请求号,右键> process item> add task ...

  2. expdp 字符集从ZHS16GBK到AL32UTF8

    源oracle数据库是GBK字符集,目标库是UTF8字符集,现在需要将源库的一个表空间数据导入到目标库.我的解决方法有点繁琐,首先直接导出源库的表空间 expdp trmuser/trmpass sc ...

  3. Address already in use: AH00072: make_sock: could not bind to address 0.0.0.0:443

    (1)端口被占用,找到对应的进行并结束.(2)Linux下查看,无进程占用443端口,确认/etc/httpd/conf.d下只有一个ssl.conf,无其他SSL配置.备份文件,如果有,apache ...

  4. python使用grpc调用rpc接口

    proto文件: syntax = "proto3"; package coupon; // //message UnsetUseC2URequest { // int64 bid ...

  5. Eclipse出现:An internal error occurred during: "Retrieving archetypes:". GC overhead limit exceeded的问题解决

    网上说修改虚拟内存的方式,其实不太可行,最直接的方式就是删除以前的workspace,重新使用一个新的workspace.

  6. svn更新项目之后,项目报错一大堆并且tomcat部署项目时找不到项目

    原因是:svn更新项目以后jdk路劲不对,需要使用自己安装的jdk,即可.具体步骤如下 第一步:右击项目-->Build path-->Configure Build path... 第二 ...

  7. 微信小程序获取用户手机号详解

    最近在做一款微信小程序,需要获取用户手机号,具体步骤如下: 流程图: 1.首先,客户端调用wx.login,回调数据了包含jscode,用于获取openid(用户唯一标识)和sessionkey(会话 ...

  8. 【Spark-SQL学习之一】 SparkSQL

    环境 虚拟机:VMware 10 Linux版本:CentOS-6.5-x86_64 客户端:Xshell4 FTP:Xftp4 jdk1.8 scala-2.10.4(依赖jdk1.8) spark ...

  9. VKD224B触摸芯片调试笔记

    1.通过阅读datasheet了解芯片怎么使用,一般datasheet会提供参考电路.和相应的电气参数. 通过上面的表格可以知道芯片的供电,所需电流. 这个芯片可以通过引脚选择模式.通过上面的选项设置 ...

  10. Linux基础命令---accept/reject 允许拒绝发送打印请求

    accept accept指令用来设置允许向目标打印机发送打印任务. 此命令的适用范围:RedHat.RHEL.Ubuntu.CentOS.Fedora.   1.语法      cupsaccept ...